View Full Version : Help ECM not responding EFILive License

May 23rd, 2011, 08:47 AM
Hello all;

Friday after work I decided to install the DSP5 switch I bought from SoCal Diesel about two years ago. I had been putting it off because of all the problems I have read about with the total re-flash. I followed the instructions to the letter. About half way through the reflash to the DSP5 OS it got stuck in a loop " retrying block 30 " or something to that effect for about 45 minutes. I finally gave up and stopped the process. When I try to connect now it just says ECM not detected.
I have read every thread I can find about this problem and have tried every remedy mentioned I found to restart it with out success. Today I ordered a new ECM from Killerbee.

My question is, Killer Bee mentioned EFILive may provide a new license to customers that have had to replace the ECM because of an reflash error. Who do I need to speak to in order to getting a license issued to use for the new ECM when I get it?

Needless to say im am very gun shy of trying to do the DSP5 now and don't want to gamble another 450$ doing a total reflash. Is there anything I can do to figure out what went wrong and how to fix it? I have flashed the truck over hundreds of times on just a calibration change with out even a hic-up. This was the first total reflash I tried.

Thank You for any information.


2002 GMC LB7 Ally. EFILive V-1 V7.5.6 (build 157) Windows XP 2002

May 23rd, 2011, 10:24 AM
Brett, if you got half way through the full flash then the ECM should have been recoverable once it stopped. There is only a small window of total, non-recoverable failure at the start when doing a full flash.
What you could try is put your old ECM back in now that it's been removed from power for a while, try the full reflash again and see how it goes.
Sorry you had to fork out $450 to get up and running again, but it might not have been necessary.
Send support@efilive.com an Email with a link to this thread and we'll sort something out for you, but please try to full flash your original ECM again first.


May 23rd, 2011, 11:31 AM
Thank you, I will give it another try. I did disconnect the batteries for 24 hours once and tried that.
Sorry i couldn't be more clear about when the full flash stalled. I wasn't paying enough attention and should have written some stuff down before i stopped the process. I was panicking. :( It did say "the ECM is in an unknown state and my not be recoverable" I did find the bug reports and can e_mail them if that will help my cause. I am still at a loss of why. What part of the puzzle am I missing or what may be wrong. I couldn't find an exact list of the fuses I should have pulled so I was guessing at that part. I will keep you updated.

Thank you very much for the response.

On a brighter note before I erased my ECM i was on the Dyno in Redding and made
667 RWHP 1300 FPT with my tuning. :)

May 31st, 2011, 01:02 PM

Tried everything again several time. No luck. Today I received the new ECM from Killer Bee. Installed it and after the relearn the truck started and ran no problem. I pulled the stock calibration out of the new ECM and made my modifications to it. I have one license left so I started to reflash the new ECM with my tune. It stopped the flash and told me the ECM has no serial number and that I need to do a full flash so EFILive can give it a new unique number. I really didn't want to do another Full Flash because I don't know what caused the last failure. Any suggestions would be greatly appreciated. Thank you for your time. Brett~

May 31st, 2011, 04:20 PM
Hmm ok Brett have you tried unchecking the "Use high speed" checkbox before you press the Start button in the flash pop-up? Can you post a screenshot of your calibration details (Flash -> PCM Security, then select your controller and press Get Info). Might want to blur out your VIN if you have a valid one, but this might show if the VIN or serial number is corrupt. Did you license the new ECM to your V1?

June 1st, 2011, 01:00 PM
Thank you for the reply. Since this last post I double checked everything, pulled radio fuse. Did the full flash test on slow, (on the new ECM bty) it went through the test fine. I decided to give it a try because I was just full flashing a calibration and not a DSP5 OS. It went on fine and the truck is back to normal with my tuning on it.

Back to the old ECM, Here are the things I tried to the best of my memory.

1. Read from ECM. "ECM has no calibration" "ECM is in an unknown condition"
2. I tried to do another Full Flash with stock. same
3. full flash with the dsp5 os. same
2. Unchecked use high speed and checked use alt key. same
3. Tried key $FFFF a couple different ways. same
4. Disconnected the batteries 24 hrs. " no response from ECM"
5. Removed ECM for 48 hrs. same "no response from ECM"

The ECM is boxed up and I'm going to send it to Killer Bee to see if he can bring it back to life.

Thank you everyone for the help. Sincerely: Brett~