View Full Version : EFILive can't communicate with ECU

September 2nd, 2011, 06:39 PM
I've just put an EFI 304 and 5spd out of a VN Commodore into my VK. It starts and runs fine, but can't get EFILive working with it, it shows this...

52:09.872: Initialising...
52:10.339: Opening COM7 160,8,N,1
52:10.536: Ready.
52:20.797: Opening COM7 160,8,N,1
52:25.243: Check vehicle interface...
52:25.257: Interface not checked because 160-baud interface is selected

52:25.271: Scanning for heartbeat and chatter frames...
52:25.271: Waiting for Aldl bus silence of at least 50ms...
52:26.421: Com timeout: Expecting frame header byte
52:26.466: No chatter found

52:36.672: Start macro: Get ALDL data: ALDL
52:37.779: No data on 160 baud data bus
52:37.779: Com timeout: Expecting start of frame symbol
52:38.894: No data on 160 baud data bus
52:38.894: Com timeout: Expecting start of frame symbol
52:40.014: No data on 160 baud data bus
52:40.014: Com timeout: Expecting start of frame symbol
52:40.032: Stop macro: Get ALDL data: ALDL

Anyone know wat could be going on?


September 3rd, 2011, 11:02 AM
Is the interface you are using plugged into COM7 which is what the software is attempting to use? COM7 is not likely to be a real COM port. It is more likely to be a virtual COM port.
Make sure you have the 160 baud interface constructed correctly and make sure it is plugged into a real RS232 serial port (not a USB-Serial converter).

Unfortunately most laptops no longer have real serial ports and the 160 baud protocol/interface will not work correctly with a USB-serial converter.


September 3rd, 2011, 03:21 PM
I bought this off of ebay.

When I plugged it into my laptop and installed the drivers, it shows up as COM7 in device manager, and have set EFILive to use COM7 as well.

Just checked all the USB ports and they show up as COM7, COM8, COM9 and COM10.

September 4th, 2011, 09:06 AM
I suggest contacting the seller for help on how to make it work correctly.


September 4th, 2011, 09:19 AM
I already have, this is the reply I got from him. Everything seems fine tho.

Hi there,

There are two things I would check.

1: Check that the COM port is setup correctly. COM7 should be fine, but you need to check that it is the same value in the DEVICE MANAGER->PORTS section, and also configured in EFILive or WinALDL as COM7. Everything needs to be on the same COM port otherwise the software can't talk to the hardware. Also, if you plug the cable into the same USB port on your computer, it usually gets the same COM port number. If you plug into a different USB port, sometimes you get a different COM port number, so its best to check.

2: The ignition needs to be in the ON position for the car computer to start talking to your laptop. If the ignition is in the OFF position or the ACC position then no data will transfer and you will see errors like the log you pasted shows. The car doesnt need to be running, but the key needs to be in the ON position. You can tell that the car computer is trying to send data because the CHECK ENGINE light will flash in a strange way (bright and dim). If you have a VN computer in a VK commodore then you may not have a CHECK ENGINE light to look at.

I hope this information helps.

Have fun!


September 4th, 2011, 09:21 AM
Have you tried WinALDL? Does that report no data as well?

September 4th, 2011, 09:29 AM
I haven't tried that, I better give it a shot. I guess that will tell me if it's the program or the car (or my computer lol).

Just changed the COM port from COM7 to COM2 just incase it doesn't like COM7 or sumfin. Will go have another crack in a sec.

Could it be because of my wiring? I wired up the EFI 304 myself, and I haven't wired up alot of the gear which I don't need, like the thermo switch wire, air con wire, gearbox wires. I just assume if the ECU is running the car fine it should be all good....but thought I should ask.

September 4th, 2011, 09:31 AM
I can't help with the wiring. Do you have any access to a VN Commodore that you could connect up to to verify that the interface and the software are working correctly?

September 4th, 2011, 10:02 AM
Just tried it again and still nothing, on EFILive or WinALDL.

One of me neighbours mate's has a VN V6 and he's there regularly....will go hit him up when I see him pull up next.

Till then, I rekon I'll wire up the engine light just incase the circuit needs to be completed on that for it to send out signals through the ALDL connector.

September 4th, 2011, 05:01 PM
I hooked a test light up to the engine light wire (so the test light becomes the temporary engine light) and it started working! Beauty!

Thx for the help aye!

December 8th, 2011, 12:21 AM
ive run into an identical situation with a vp v6. bought the setup off ebay and having trouble communicating with the car. ive noticed that when i tried to do a self diagnosis by bridging the 2 end wires my check engine light didnt blink at all but the radiator fan did come on. could it be as simple as the check engine bulb on the dash playing up? it seems to be on when i turn the key to the reds, and sometimes not.... hmmmm

December 8th, 2011, 11:11 PM
got it sorted. ended up being the engine indicator globe was blown. swapped it out and presto...