View Full Version : E78 BiDirectional Controls DVT

May 1st, 2014, 12:30 AM
Is there any chance of getting some bidirectional controls available for the e78 controller.
Using the other controller selections only allows for use of setting a desired idle speed and forcing open/closed loop.

I was hoping for injector disable at the very least.

May 1st, 2014, 08:36 AM
If you choose E38 all that should work on the E78 as well, which controller have you been selecting?

May 1st, 2014, 01:53 PM
does this also apply to the e83b or entirely different?

May 1st, 2014, 06:03 PM
Should apply to that too, GM got pretty good on......wait for it.....standardising! between ECM's as the years have progressed.

May 2nd, 2014, 04:31 PM
Anytime I try to enable the control for the injectors, it says that there was a timeout and it won't allow me to disable individual injectors. It was even picky about enabling closed loop if I hadn't enabled the fuel trim learn first.

The above was tried on the E38 but I also tried all of the ECMs that were L4 or looked very similar to the exterior of my ECM

May 3rd, 2014, 09:57 AM
Unfortunately we don't have a car with an E78 to test this on anymore, we'll have to ask around to see what others find. But timing out sounds like a communication issue, still E38 should have worked.

May 3rd, 2014, 10:09 AM
I can test DVTs on my Sonic if you need someone, shoot me a PM.

May 3rd, 2014, 10:22 AM
That would be awesome Eric. If you could test, then run trace files as per the Software a build beta requirements and submit those in the beta section Ross and Paul can follow up. Please make sure you upgrade to yesterday's release first.


May 3rd, 2014, 12:01 PM
Hey, I caught this one just in time! :) I also have a daily E78 if there is anything I can help with.

May 3rd, 2014, 04:40 PM
I'm also good to help with this as well.

May 4th, 2014, 09:15 AM
Well I guess just verify with that the OP said, DVT's not working at all.

May 4th, 2014, 02:11 PM
I tested out the close/open loop fuel control on the e83b and it worked fine. that was all I tried at the time.

oh, I also reset the fuel trims too, i'll test out some other stuff too and let you know.

May 5th, 2014, 07:19 AM
Closed/open fuel loop works.

Also the idle speed works as well but it has a tendency to time out if some other command is not accepted.

May 5th, 2014, 09:04 AM
A number of the override functions in the ECM have a time limit (imposed by the ECM).