PDA

View Full Version : L76 4L80e AFM



4wheelin
July 8th, 2008, 12:12 AM
Working on getting AFM going on a retrofit L76 with 4l80e in a Nissan Patrol, problem is it won't turn on via software. I did put a manual trans OS in and the AFM was active but would not turn off so I know the mechanical side works and am confident the wiring is too.
I think the issue may be that that activation tables all revolve around a 6 speed auto, and I have a 4 speed auto. I think this is why it activated and wouldnt turn off when I installed the manual tune.
Anyone have a stock L76 auto tune I can try?
All suggestions welcome.

Cheers

Joel

GMPX
July 8th, 2008, 12:52 AM
So with a manual tune the engine was in 4cyl mode always?
I have a .tun file for a 07 K1500 with AFM and 4spd auto, OS is 12612291.

Cheers,
Ross

limited cv8r
July 8th, 2008, 01:35 PM
from VZ thunder ute

harascho
July 8th, 2008, 03:27 PM
So with a manual tune the engine was in 4cyl mode always?
I have a .tun file for a 07 K1500 with AFM and 4spd auto, OS is 12612291.

Cheers,
Ross

Hi Ross

the 12612291 is an update from the 12605897 I was looking for. If you could also email it to haraldschoener "add" yahoo.de

Thx a lot

The most actual .tun file for that (LMG) to be 12614088 were they did changes to the E85 calculations..
I could not find additional info on updates for the AFM, sorry

4wheelin
July 8th, 2008, 07:05 PM
So with a manual tune the engine was in 4cyl mode always?
I have a .tun file for a 07 K1500 with AFM and 4spd auto, OS is 12612291.

Cheers,
Ross


Thats correct Ross, even when the activate switch was off.
Can you e-mail me that file to try?
jbbottom@bigpond.com

Joel

GMPX
July 9th, 2008, 11:36 AM
File below -

4wheelin
July 9th, 2008, 09:17 PM
Thanks Ross,

Unfortunatly that Cal dosen't run. I had the same issue with the VZ Thunder Cal. I have tried turning VATS off, yet it isn't in the file I was running. I am going to go through all the diagnostics and make the switches the same as the Calibration that does run, even though th AFM dosent. I started with turning of the CAM position solenoids P0010 to P0014, P0615, P0663, immobilizer and start relay control circuit(not reported). I'll work through them all as yet I've nothin'. Scan tool shows RPM and other sensors seem to read correct. Back to it tomorrow but always open to ideas.

Cheers

Joel

GMPX
July 10th, 2008, 12:55 PM
So it just cranks or not even that?

4wheelin
July 10th, 2008, 02:29 PM
Yep, it cranks, the scan tool shows injection ms, RPM and the coils are on yet there is no spark and with a noid light, no injection pulse. I changed all the DTC values to match the Cal that was running in the car with no sucess, I though their may be an issue due to the missing modules, ABS etc as this engine is in a Nissan Patrol with only a TCM. I think its something in the software not available to me to modify. This is the Cal that works in the car. I have had to do a full reflash over the boot block each time, no problems so far.

Cheers

Joel

4wheelin
July 13th, 2008, 08:13 PM
Any ideas Ross???

GMPX
July 14th, 2008, 11:17 AM
Any ideas on a Saturday or Sunday, no, now it's Monday maybe :)
I have a bunch of things to get done today, I'll try to get a some time to look at this.

4wheelin
July 14th, 2008, 09:06 PM
Moochas Gracias

4wheelin
July 16th, 2008, 09:19 AM
Hello Ross,

anything I can datalog to help?

Cheers

Joel

GMPX
July 16th, 2008, 02:27 PM
Ah not just yet, bad week here, two staff are on vacation so it's kinda crazy. I'll get back to this as soon as I can.

Cheers,
Ross

4wheelin
July 21st, 2008, 10:06 PM
Customer is picking up vehicle on Thursday, any progress I can inspire him with??
We will get it back but it would be nice to have something encouraging to tell him.

Thanks

Joel

GMPX
July 22nd, 2008, 11:26 AM
Mmm, my head hurts everytime I think about this because I know it's going to go very deep into AFM controls :Eyecrazy:.
So you have a T42 controlling the trans? What program is in that (what platform).
Your original file from the Auto was definately from a vehicle with AFM?

Cheers,
Ross

4wheelin
July 22nd, 2008, 02:55 PM
Yep its a T42, the origional file I believe is an AFM file, the ecu's and loom came from speartech, as an LQ9 file, there was AFM controls in the Cal. I'll have to go plug in to find anything more specific, will get more details later today.

Ta

Joel

GMPX
July 22nd, 2008, 04:01 PM
Joel,

The AFM functions can be stopped per gear, it is possible that the tune you have is expecting a 6spd TCM and the T42 is not sending the gear messages the ECM needs (I'm guessing this BTW).

If anyone can think of a 6.0L AFM / T42 factory vehicle that would be of great help!.

Cheers,
Ross

4wheelin
July 22nd, 2008, 11:40 PM
The 6.0L VZ Thunder Ute posted by Limited CV8 is a 4 speed and L76 but the AFM is not active, I see in the engine Calibration it refers to the AFM in 6 gears yet the trans is clearly a 4L60/4L70. That Calibration is one that won't start in my vehicle despite offering no useful codes and showing injector duty cycle and rpm etc. This may be a stupid question but are all E38 wired the same? Could the cal assign different ECU pins ie; the power for the coils and injectors or the AFM solenoid power?? With a manual trans Cal the AFM was constantly engaged, possibly different wiring is required to suit AFM??

Joel

GMPX
July 23rd, 2008, 12:14 AM
Ok, now I understand the VZ issue, I have a feeling the Outputs on the E38 are multiuse depending on the platform. That could be why the AFM was on 100% on the VZ tune because Holden have the outputs configured as something else.

The actual ECM's are all the same but as you suggested the calibration can assign an output for a different task over the different platforms.

So what we need to somehow come up with (or find in GM's stable) is a factory AFM application that used a T42 as well. I might do some Google searching.

Cheers,
Ross

4wheelin
July 31st, 2008, 11:52 PM
Hey Ross, any news??

Joel

ScarabEpic22
August 2nd, 2008, 10:20 AM
There are 5.3L V8s that use the T42 to control a 4L70E box, might be able to use one of those tunes and change the cylinder airmass and then work the VE and spark tables.

GMPX
August 3rd, 2008, 10:43 AM
Hey Ross, any news??

Joel

Sorry Joel not yet, I'm 100% stuck on mapping the 5 new 2009 OS's GM have released in the last few weeks, cars sitting on dyno's not being able to be tuned isn't a good thing.

Cheers,
Ross

4wheelin
August 23rd, 2008, 11:07 PM
I'll be waiting with bells on!

Joel

4wheelin
September 21st, 2008, 11:41 PM
Customer stopped in today, any news??

Joel

GMPX
September 22nd, 2008, 12:23 AM
New OS's will be finished in about a day (yes, it takes a long time!), I'll see what I can do after that.

Cheers,
Ross

4wheelin
September 22nd, 2008, 09:39 PM
Thanks Ross, I appreciate that

Joel

GMPX
September 30th, 2008, 11:18 AM
Yep its a T42, the origional file I believe is an AFM file, the ecu's and loom came from speartech, as an LQ9 file, there was AFM controls in the Cal. I'll have to go plug in to find anything more specific, will get more details later today.

Ta

Joel

LQ9 or L76?
http://en.wikipedia.org/wiki/GM_Vortec_engine#LQ9

There has been a couple of engines of recent times where they were trying to run them on a dyno but with a no start situation, the problem turns out to be the E38 needs to see a starter relay hooked up (Pin C1-52). This might have been the issue you had with the no start using the VZ L76 calibration. Realistically, using the VZ L76 cal is probably the best option at this stage as it was mated to a T42.

Cheers,
Ross

4wheelin
October 1st, 2008, 09:34 AM
OK, I suspect it doesnt have that wire as it came with only the bare essentials, I will get the customer back and take a look.

Thanks

Joel

4wheelin
November 13th, 2008, 08:26 AM
Hello Ross,

You sure about that wire? It go live when you crank, and continues to after you come off the starter which in turn makes the starter continue to run, even after dropping in the VZ thunder cal.

Thanks
Joel

gmh308
November 19th, 2008, 10:32 AM
Hello Ross,

You sure about that wire? It go live when you crank, and continues to after you come off the starter which in turn makes the starter continue to run, even after dropping in the VZ thunder cal.

Thanks
Joel

Hi 4wheelin, how you travelling with this problem?

Cheers.

4wheelin
November 20th, 2008, 11:46 PM
Still waiting for a response from Ross. Wiring diagrams are hard to get for these things.

GMPX
November 21st, 2008, 12:38 PM
You have to shoot me a PM if it goes on for a week, I plain forgot.
Please keep in mind, for myself and Blacky support can't become the priority for us or this company just stops dead in it's tracks. I know I am pretty lapse on responding to PM's etc.
Whilst we really do try to help as much as possible I have placed a daily limit on the amount of time I spend on support issues, we already have two people pretty much full time within the company doing support to try to get it away from Paul and myself, plus those on this forum who monitor posts much closer than myself and Paul.
We recognised a while back that by myself and Paul spending 4 - 5 hrs a day on forum/Email support (yes, it got that bad at one point!), we were getting nowhere, what happens then, we get a flood of Emails asking 'when, when, when'. A vicious circle. I'm just trying to explain why I've been 'slack' on resolving this.
I really don't know what to do for you, because it's not a combination that GM ever offered there could be a myriad of things that need to be set up to make it work, things that unless you are a GM calibrations engineer can't be accessed.
What you need to do is try to find a vehicle drivetrain combination of exactly what you have then change everything over to that. I doubt that having a VZ ECM file with a TrailblazerSS TCM file is going to work. Sorry, but I can't fix everything, I don't really know what else to say, the issues the mismatch of parts is causing probably extends beyond what our software is capable of fixing.

Cheers,
Ross

gmh308
November 21st, 2008, 01:14 PM
You have to shoot me a PM if it goes on for a week, I plain forgot.
Please keep in mind, for myself and Blacky support can't become the priority for us or this company just stops dead in it's tracks. I know I am pretty lapse on responding to PM's etc.
Whilst we really do try to help as much as possible I have placed a daily limit on the amount of time I spend on support issues, we already have two people pretty much full time within the company doing support to try to get it away from Paul and myself, plus those on this forum who monitor posts much closer than myself and Paul.
We recognised a while back that by myself and Paul spending 4 - 5 hrs a day on forum/Email support (yes, it got that bad at one point!), we were getting nowhere, what happens then, we get a flood of Emails asking 'when, when, when'. A vicious circle. I'm just trying to explain why I've been 'slack' on resolving this.
I really don't know what to do for you, because it's not a combination that GM ever offered there could be a myriad of things that need to be set up to make it work, things that unless you are a GM calibrations engineer can't be accessed.
What you need to do is try to find a vehicle drivetrain combination of exactly what you have then change everything over to that. I doubt that having a VZ ECM file with a TrailblazerSS TCM file is going to work. Sorry, but I can't fix everything, I don't really know what else to say, the issues the mismatch of parts is causing probably extends beyond what our software is capable of fixing.

Cheers,
Ross

That seems fair Ross.

4wheelin, its seems like you are in oz. Maybe I can help. PM me.

Conversions can be cans of worms without the right combo......:shock: and I have been thru some wierd combos.

cheers and a good weekend to all.

4wheelin
November 24th, 2008, 10:04 AM
I don't want anyone to get the wrong impression here. I have a customer who wants more economy, the vehicle has been running for 18 months it's not a huge deal. I was hoping in that we have the hardware we may be able to use to software, If it was a pressing issue I would have been chasing Ross. I understand the limitations of time, we all have them, I'm sure we all are faced with shopper customers who tie us up for hours.
I'll happliy forward the I'll post the tune tonight, any help appreciated the more heads the better I say.

Joel