Results 1 to 6 of 6

Thread: what parameters need to be met to run idle catalyst effiency test?

  1. #1
    Senior Member
    Join Date
    Dec 2007
    Posts
    133

    Question what parameters need to be met to run idle catalyst effiency test?

    Im still trying to find a way to work around my P0420 problem.

    I reworked the exhaust after some input from some other members (put the resonator where the cat. used to be and put a spacer in to pull the O2 sensor a little out of the flow) but that still didnt work.

    im wondering what parameters need to be met for the ECM to run the test. im thinking maybe i can work around it, possbly set things up so one of the requirements is never met, possibly increase idle rpm?

  2. #2
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,778

    Default

    When you find out please let me know, I got around the P0442 EVAP Small leak (accidently nicked the EVAP canister and had to reseal it) with some tuning changes.
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, starting the mods
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  3. #3
    Junior Member
    Join Date
    Sep 2007
    Posts
    34

    Default

    I put a spacer in the rear o2 and havent had a code since...no cat
    2003 TB EXT I-6 210,000 miles... Volant CAI.. NO CAT with magnaflow ..efans ...pcmforless tune and hotchkiss swaybar and air bags in back springs...new alt, pwr steering pump and water pump at 200,000 shooting for 300K or more

  4. #4
    Senior Member
    Join Date
    Dec 2007
    Posts
    133

    Default

    Quote Originally Posted by ExtTB View Post
    I put a spacer in the rear o2 and havent had a code since...no cat
    when i welded in the new O2 bung i spaced it an additional 1/2" out of the exhaust flow(and also downstream of the resonator) & im still having the P0420 code come up. but it only sets from the "Idle Catatlyst Efficiency Test"

    regardless, with EFI i shouldnt need to do ANY physical changes. somebody is slacking on the coding & the switching for the MIL/DTC isnt doing what its supposed to.....

  5. #5
    Senior Member
    Join Date
    Feb 2006
    Posts
    112

    Default

    We have the same problem with the 410 code. Deleting it does absolutely nothing, still sets an engine light.

  6. #6
    Senior Member
    Join Date
    Dec 2007
    Posts
    133

    Default

    i ended up cheating and buying a set of those 18mm spacers and no more P0420 code. i havent touched this vehicle in over a year (tuning-wise) and it seems to be running fine and gets about 600-700km to a tank of fuel.

Similar Threads

  1. Idle Parameters
    By Highlander in forum IL4, 97-01 PCM and 02+ P11 PCM
    Replies: 3
    Last Post: November 22nd, 2009, 06:18 PM
  2. OS 12612281 Doesn't have all idle parameters defined
    By Highlander in forum E37, E38 & E67 PFI ECM's
    Replies: 2
    Last Post: August 11th, 2009, 10:27 AM
  3. what parameters need to be met to run Idle Catalyst Efficiency Test?
    By skneeland in forum General (Petrol, Gas, Ethanol)
    Replies: 0
    Last Post: May 25th, 2009, 02:58 AM
  4. Can you define these idle parameters?
    By Redline Motorsports in forum General (Petrol, Gas, Ethanol)
    Replies: 13
    Last Post: March 7th, 2006, 02:07 PM
  5. outside parameters
    By wkdivr in forum General (Petrol, Gas, Ethanol)
    Replies: 3
    Last Post: March 6th, 2005, 02:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •