Results 1 to 2 of 2

Thread: Serious problem with TCM flash

  1. #1
    Junior Member chrleb2's Avatar
    Join Date
    Jan 2008

    Default Serious problem with TCM flash

    I'm working on an early 04 (LB7) and was just raising the torque limits on the TCM. I pulled the stock info, but it would not pull it out in high speed. It pulled just fine without using the the high speed. After i made my changes, i tried to flash (not full flash) and it would not take the tune. It would go for a little bit and then the dash would ding at me and the tune would stop. After one time, it lost the VIN and told me it required a full flash.

    It will not work at all in high speed and will not take any of the flashes. I have unplugged everything i can think of. The aftermarket alarm, radio, turned off lights, shut doors, unplugged the ECM, and so on.

    I AM TOTALLY STUCK RIGHT NOW.... The customer is having to get a ride right now. Any help would be great guys. I've never heard or seen this problem at all.

    I am using 7.5.5 build 88 and i tried to update the firmware also (2.4.72). Any ideas?

  2. #2
    Junior Member chrleb2's Avatar
    Join Date
    Jan 2008


    Alright.... the truck was causing the issues. There was some electrical issues on the truck that i still can't find. I took it over to a friends house, put it in his 03 truck and it worked perfectly. Go figure.

Similar Threads

  1. Pre Full Flash to Full Flash Tune Question
    By Donovan in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 1
    Last Post: January 13th, 2010, 11:43 AM
  2. Rough running after flash and return to stock, TPS problem?
    By Whodunnit in forum LL8 4.2L In-Line 6 - P10 PCM
    Replies: 15
    Last Post: July 27th, 2009, 10:57 AM
  3. flash problem
    By divette in forum FlashScan V2
    Replies: 13
    Last Post: February 20th, 2009, 10:17 PM
  4. Wierd flash problem
    By Tre-Cool in forum 6 speed/8 speed RWD/FWD Transmission Tuning (incl T43, T76, T87)
    Replies: 0
    Last Post: December 14th, 2008, 11:43 PM
  5. First try at flash - have problem
    By voda1 in forum Gen III V8 Specific
    Replies: 6
    Last Post: July 27th, 2007, 01:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts