Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: TCM dead after flash

  1. #1
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,308

    Default TCM dead after flash

    On a 2009 G8, I flashed the TCM and it failed when finished. I tried several times to flash it and it would always fail. The car was undrivable and in the middle of no where. I unhooked the batt for a few mins and was able to reflash it. Im scared to reflash it again, what happen?
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Were you able to get vehicle driving again...?

  3. #3
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,780

    Default

    Lorenz, are you using the latest release? We've had another complaint of this happening just recently.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  4. #4
    Guess who's back!!!! Black02SS's Avatar
    Join Date
    Jan 2004
    Posts
    1,355

    Default

    Subscribing....

  5. #5
    Guess who's back!!!! Black02SS's Avatar
    Join Date
    Jan 2004
    Posts
    1,355

    Default

    What did you change in the TCM file? Anything out of the ordinary?

  6. #6
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,308

    Default

    Quote Originally Posted by joecar View Post
    Were you able to get vehicle driving again...?

    yes only after unhooking the batt and reflashing the TCM


    Quote Originally Posted by GMPX View Post
    Lorenz, are you using the latest release? We've had another complaint of this happening just recently.

    Yes, the latest. This is also the same G8 that says contact dealer when I plug into with it runing.
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

  7. #7
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,308

    Default

    Quote Originally Posted by Black02SS View Post
    What did you change in the TCM file? Anything out of the ordinary?
    No, just your normal basic trans tune without tq management. I was actually putting back my old tune I had in for the last couple thousand miles.
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

  8. #8
    EFILive Reseller ringram's Avatar
    Join Date
    Oct 2005
    Posts
    1,412

    Default

    Upgrade your firmware as well mate. I think that issue was resolved in newer firmware. Though maybe you have done that already..
    Get EFILive in europe (http://www.efilive.eu).
    2007 Escalade ESV L92 6.2L VVT.
    2014 VF SV LS3 Maloo.

  9. #9
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,308

    Default

    Quote Originally Posted by ringram View Post
    Upgrade your firmware as well mate. I think that issue was resolved in newer firmware. Though maybe you have done that already..
    Have the latest..........usually I update within a day or two of something new coming out.
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

  10. #10
    Lifetime Member Chuck CoW's Avatar
    Join Date
    Feb 2006
    Posts
    459

    Default So far.....

    So far, Ross seems to be the only person to have killed a T43 in the name of EFI LIve Tuning!

    I've done evil things to T43s even including accidentally yanking the usb from the laptop in the middle of a TIS flash!

    While I had a few scares, I've NEVER had one go south.

    Shutting the battery off or grounding the positive bat cable (WITH THE POSITIVE CABLE DISCONNECTED FROM THE BATTERY) to the negative is all I've ever had to do.

    Proceed as usual...It was likely a fluke and I wouldn't sweat it.

    Chuck CoW
    CoW BOOSTER! Electronic Throttle Enhancement.

    - CLICK HERE NOW FOR MORE INFORMATION! -

    VARARAM, EDELBROCK, AMERICAN RACING HEADERS, BAER BRAKES, BORLA, EFI Live, Magnuson,
    COMP Cams, PROCHARGER, PRO TORQUE, PHADT Racing, INNOVATORS WEST, and more.



Page 1 of 2 12 LastLast

Similar Threads

  1. Full flash and batteries went dead. ecm not working
    By 05DirtyMax in forum Duramax LLY
    Replies: 2
    Last Post: February 1st, 2010, 01:00 PM
  2. Another TCM dead after re-flash
    By minytrker in forum 6 speed/8 speed RWD/FWD Transmission Tuning (incl T43, T76, T87)
    Replies: 3
    Last Post: December 4th, 2009, 11:52 AM
  3. Is my PCM dead?
    By kenkaru in forum Gen III V8 Specific
    Replies: 10
    Last Post: March 22nd, 2007, 07:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •