Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: 4l80e 4th gear and tcc problem (running from 4L60E segment)

  1. #1
    Junior Member
    Join Date
    Feb 2010
    Posts
    11

    Default 4l80e 4th gear and tcc problem (running from 4L60E segment)

    I hope this is in the right post.

    I have a 1993 chevy truck i swaped a 4l80e into, had a 4l60e
    Howell efi did the computer and harness.
    The truck has no 4th gear and no tcc apply, the scanner shows im in 3rd on the gear selector when i am in 4th. I checked all wires and are good. I can manually ground both solenoids at 55mph and it will shift into fourth, but still no tcc apply and yes the brake light wire is wired in and working. I am grounding them inside next to the ecm. I changed the ecm and no difference. Could it be the fluid pressure valve position switch? Should i be able to manually make the tcc apply by grounding?

    Thanks for any help, I am stumped and no one has been able to help.
    Last edited by joecar; December 27th, 2012 at 07:19 AM.

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,785

    Default

    How did you wire the ECM to the 4L80E...?

    Do you have a wire diagram for your ECM->4L60E and a wire diagram for the 4L80E you're using...?

    The shift solenoid on/off table is different than the 4L60E.

    The 4L60E (1993) TCC solenoid may be on a different wire than the 4L80E TCC PWM wire.

  3. #3
    Member
    Join Date
    Dec 2008
    Posts
    70

    Default

    Other reasons could be a low pressure scenario (switching to a Sonnax Boost valve fixed my problem) or a bad Manual Valve Position Switch.

  4. #4
    Junior Member
    Join Date
    Feb 2010
    Posts
    11

    Default

    Howell Efi wired my harness and sent me a 7427 computer and chip. Yesterday i double checked the wiring that they sent me. If someone else has a wiring diagram i would be glad to compare and make sure its right.

    The transmission was just rebuilt by a shop here in town. I am going to go check that i am getting power again to the tcc wire at the tranny is getting power, terminal k and if i ground it at J that it does not work.

    My scanner shows three things now:
    Driver quad module 27
    Torque convertor stuck off
    and it show my gear selector to be in third when its in fourth.
    But again i can ground both solenoids and it shifts to fourth.

    Thanks so much, 3 months ago i started on this swap, i gave up till this weekend bc i seemed at a dead end. Howell says its the tranny and the tranny shop say its the computer. I am also going to by a service manual to help figure out where my electrical problem is. This is the first help i have found online, Thank you.

  5. #5
    Member
    Join Date
    Dec 2008
    Posts
    70

    Default

    Here is a file comparing '94 up 4L80es with 4L60es.

    I'm pretty sure factory 91-93 4l80es had different wiring harnesses.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	transwiring.jpg 
Views:	4673 
Size:	50.0 KB 
ID:	7242  

  6. #6
    Junior Member
    Join Date
    Feb 2010
    Posts
    11

    Default

    Anyother help? I pulled the pan and the tcc solenoid shows to work, i checked the wires to and from the ecm. Does the pressure switch justify what gear the ecm believes its in? Anyway to test a pressure manifold?
    What do i look for on the quad driver module code?

  7. #7
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,785

    Default

    Have you considered these things:

    - that the 4L80E 2-3 shift solenoid sequence for 1st, 2nd, 3rd, 4th is Off, Off, ON, ON
    (which is different than the 4L60E sequence of ON, ON, Off, Off.

    - that the 4L60E TCC PWM signal will spike high at various times while the 4L60E TCC signal is off.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	4L80E-range-chart.png 
Views:	15871 
Size:	44.4 KB 
ID:	7298   Click image for larger version. 

Name:	4L60E-range-chart.png 
Views:	10338 
Size:	39.3 KB 
ID:	7299  

  8. #8
    Junior Member
    Join Date
    Feb 2010
    Posts
    11

    Default

    For the first week it did shift in all gears including 4th, but has never had a tcc apply. I understand the ecm can kill 4th if the tcc does not apply, but i have swited ecms and still no change. Could my prom have a problem?

  9. #9
    Member
    Join Date
    Dec 2008
    Posts
    70

    Default

    If your only showing D3 when the shifter is in D4, that is why the PCM isn't commanding 4th. It knows that you can only get 4th oil in D4. You may either have a low pressure issue (not enough pressure to trigger the Manifold Pressure Switch) or it may be a bad Manifold Pressure switch. What does the scanner say in all of the gears?

  10. #10
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,785

    Default

    Good point, I had missed that.

    Also, what is this DTC:
    Quote Originally Posted by kkustomz View Post
    ...

    My scanner shows three things now:
    Driver quad module 27
    Torque convertor stuck off
    and it show my gear selector to be in third when its in fourth.
    But again i can ground both solenoids and it shifts to fourth.
    ...

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Why does 1st gear slam into 2nd? 4L80E translplant
    By 1SlowHoe in forum Gen III V8 Specific
    Replies: 82
    Last Post: May 22nd, 2010, 08:47 AM
  2. 4L80E TCC problem
    By Arnoldi in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 0
    Last Post: March 19th, 2010, 10:26 AM
  3. manual gear selection overide 4l80e
    By 2500ak in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 4
    Last Post: January 6th, 2010, 03:48 PM
  4. 4L80E 2nd & 3rd gear only
    By rickwils51 in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 4
    Last Post: November 1st, 2007, 05:06 AM
  5. 4L80E 4rth Gear problem
    By almusafir in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 18
    Last Post: March 14th, 2007, 01:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •