Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: E38 VATS will not disable

  1. #1

    Default E38 VATS will not disable

    Hey to anyone interested. I have been working with this E38 for a couple of months now when I get a chance. I have tried to disable VATS many different ways and have followed the advice here on this forum and It appears that there may be further issues. I have a 4.8 liter 58X engine, ls2 intake and TBody. F body pan, corvette brackets pulleys etc. The engine came on a crate and is new. The ecm was ordered through the mail. I have had many programs on it to get it to run. I have had it running well on a test stand with a 2007 corvette manual program. If I try ANY other program it does not run. It cranks good because the vehicle is a 93 vette with the start relay bypassed. I will eventually connect all of the extras but I am really desperate right now to end this awful experience with programming. If I put a stock program from the 2007 vette with the VATS active, it will run for 2 seconds then die. Remove VATS and do the patch and it will start and run. BUT when I do any other program on the thing, I.E. (truck with automatic trans) it will NOT run even for a second. As I scan this issue in the scan tool it continually shows the (Vehicle Theft Deterent 2 Fuel) is still enabled and active, so no fuel injector activity. I have read on here about HPTuners and even willing to try that If I need to, but I want to get this option working. Any help would be great. I just can't do it any more.
    Just one guy tryin' to make a difference

  2. #2
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,763

    Default

    Is there any reason you can't just use the Corvette tune and remap it for the 4.8L?
    I'm thinking the problem may be tied in with it looking for a TCM (given the truck tune you test with is an Auto), from that it would also be looking for a message from the TCM to say the trans is in P/N before allowing it to run.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  3. #3

    Default

    Thank you for responding. Well when the engine is in a test stand I can use the the corvette manual program, but now that it is in a car I need to use the auto trans with a T42 TCM. I'm trying to run a 4L60E. So in that I need to use the automatic program. If the VTD #2 stays enabled, is that correlating with a P/N signal? Is the P/N signal for a safety on these or simply and indicator to the ECM of the idle loaded RPM? This set up is basicaly a stand alone system that will piece by piece be integrated into the 93 corvette electronics (at least where it is able to be), so as it stands now the engine and trans are in a situation like an Austin Healy with no other electronics than the E38 and T42. I do have the P/N switch so that it grounds in Park and Neutral. Thank you for the help, if you can think of more I will try anything.
    Just one guy tryin' to make a difference

  4. #4
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,763

    Default

    ok, now I see.
    What you probably need to do is spend some time on Ebay motors and find a vehicle (say a 2007) with your engine / trans combo. I guess that would be an express van.
    Once you have found one, PM me the VIN.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  5. #5
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,795

    Default

    Any chance you have an 07+ E67 file with OS 12618588 from a Caddy XLR-V??
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, starting the mods
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  6. #6

    Default

    i have seen some files on holden crazy but I don't know about that specific tune. I hope this helps

    Robert
    Just one guy tryin' to make a difference

  7. #7

    Default

    well, just spent another 7.5 hours going over everything in the wiring wiring. I have gone thro9ugh every pid to look at data between the programming that works (manual) vs programming that doesn't (auto). I have used a completely stock ECM and simply pulled the vats out and the thing will not start. I have had the accy voltage hooked up. I have had the brake switch hooked up. I have looked at each line of data in the scans and the only thing that I have not been able to eliminate is a code for imobilization key not programmed and imobilization key not valid until I turn off the codes in the diagnostic pages. I get cam pulses, I get crank pulses, I get spark, I do not get injector pulses at all not even for 1 second. I have poured gas in the tbody and it will run. The throttle body works with the pedal, The data talks from TCM to ECM or rather ECM to TCM then OBD2 connector. I have purchased more licenses to re flash other ecms but.... Now I need to ask... has anyone had these issues before? I have read that one guy used HP tunners and it solved his problem but I have not seen anything since. HP Tunners runs $499 for the basic package with 4 ecm worth of credits. I can't believe that would be the fix for this. It's probably some thing realy obvious but I can't see it.
    Just one guy tryin' to make a difference

  8. #8
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,308

    Default

    I had the same problem. I was trying to run a 6.2 with a TH400 trans using the stock 6.2 tune. I disabled VATS and did the patch and full flash several times. It wouldnt start at all, just spin over. After hours of trouble shooting and tons of phone calls I flashed it with HPT and it fired right up. I even tried it again with efi and it would never start. After the flash with HPT I tuned it with efi. Once running a few other problems vame up with using the auto tune and no trans, in the end I had to use a manual corvette tune.
    Now Im not saying HPT will solve your problems, I wouldnt go out and buy it just to flash your car.
    PM your contact info and I will help you out.
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

  9. #9
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,763

    Default

    I'm not sure what the problems are you are having. There is a shop local to me who does lots of GenIV conversions using the E38, they've never had a no start situation once the VATS was disabled, so please don't rush out and buy HPT thinking that is going to solve your problem, there should be no reason ours would not work.
    I'll try to get some files for you to test next week.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  10. #10
    Member
    Join Date
    Nov 2008
    Posts
    95

    Default

    My 2007 E38 Auto truck tune would not start after applying the VATS patch. I ended up having to ground (through a resistor to emulate the relay trigger) the "starter enable" wire, yellow and black in my case. Hope this helps.

Page 1 of 5 123 ... LastLast

Similar Threads

  1. E38 / E67 VATS disable guide
    By GMPX in forum E37, E38 & E67 PFI ECM's
    Replies: 135
    Last Post: September 20th, 2019, 09:08 AM
  2. cant completely disable VATS in 01 holden SS?
    By Dopey in forum Gen III V8 Specific
    Replies: 10
    Last Post: September 29th, 2011, 05:58 PM
  3. E38 cant disable VATS
    By minytrker in forum E37, E38 & E67 PFI ECM's
    Replies: 30
    Last Post: October 30th, 2009, 03:43 PM
  4. How do I disable VATS.
    By PRAY in forum Gen III V8 Specific
    Replies: 6
    Last Post: February 18th, 2009, 11:45 AM
  5. LBZ/LMM VATs
    By Biodiesel66 in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 2
    Last Post: July 22nd, 2007, 08:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •