Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: GEN IV E38 Holden Commodore Cooling Fans

  1. #1
    New Member
    Join Date
    Feb 2011
    Posts
    9

    Question GEN IV E38 Holden Commodore Cooling Fans

    Hi Forum,
    New guy here who needs advice. I've just transplanted an L98 into a Nissan Patrol and am running a dedicated wiring harness with an E38 from a VZ Commodore with the VATS removed.

    Problem is I cannot get the cooling fans to operate when the coolant temp gets to the preset level. The fans are set to 'Discrete' in EFILIVE and the high and low speed fan relay drive wires are connected to pins 17 and 58 of the E38 respectively.

    Any advice?

  2. #2
    Lifetime Member
    Join Date
    Aug 2010
    Posts
    1,934

    Default

    Hello CRFaig,

    What OS is your E38 running ?

    Did you apply the “Cooling Fan Operation Range Patch” (B9904) ? You won’t see this patch unless you have the V2 connected to your Laptop prior to opening the tune file.


    Regards,
    Taz

  3. #3
    New Member
    Join Date
    Feb 2011
    Posts
    9

    Default

    Thanks Taz,

    Firstly, it's great to see a Canuck with an Aussie nickname.
    Ok, I don't currently have efilive at my disposal but the E38 has been flashed using it. So, I don't know the the operating system my E38 has.
    The supplier gave me a new E38 and now I have the low speed fans operating........Immediately after start-up and they stay on. High speed fans will not come on. I don't know if the supplier is using V2 and don't know if they have applied the B9904 patch. It's one of those situations where I don't want to tell them what they should be doing until I'm fully informed.

  4. #4
    Lifetime Member
    Join Date
    Dec 2007
    Posts
    1,142

    Default

    B9904 wont make any difference. Whoever disabled your VATS could have fixed this for you. If they didnt, then maybe there are some other revisions required too. When we set an ECM up for a conversion we supply a calibration that has all the revisions for a conversion. Your tuner appears to be using EFILive, so they can fix the problem .
    Last edited by gmh308; February 12th, 2011 at 09:39 PM.

  5. #5
    New Member
    Join Date
    Dec 2010
    Posts
    7

    Default

    Hey mate, who did the conversion? and how much roughly? Always wanted an L98 in a patrol.

  6. #6
    New Member
    Join Date
    Feb 2011
    Posts
    9

    Default

    Hey DMAX,

    The conversion fit was done by myself with the parts kit and engine supplied by Marks 4WD in Dandenong, Victoria.

    Cost............Including everything aside from labour, the bill is up to approx $23000.

  7. #7
    New Member
    Join Date
    Dec 2010
    Posts
    7

    Default

    Cool man, Had it on the dyno yet? How much does Marks charge for the engine?

  8. #8
    New Member
    Join Date
    Feb 2011
    Posts
    9

    Default

    No dyno time yet. It has a twin 2.25" primaries through the two cats to a very small 2.25" single through 2 mufflers. I don't think there would be a dyno out there that could read such low figures. Very congested exhaust. It still goes well though. The exhaust will be opened up after the engineering certificate is written. Then the grunt should appear.

    Marks charged $8300 for the L98 crate engine which included the A/C compressor, alternator, power steering pump and all bracketry (all brand new with GM part #'s). From what I can tell, the L98 is a VE Commodore manual engine.

    Marks conversion kit is pretty good but I've struggled with a few other aspects of the conversion as a result of what had been supplied unfortunately.

  9. #9
    New Member
    Join Date
    Dec 2010
    Posts
    7

    Default

    Are you a member of the Patrol forum? Would love to see pics of it all. I was going to go with the same engine before I went with a Duramax/allison combo, but still love me ls motors.

  10. #10
    New Member
    Join Date
    Feb 2011
    Posts
    9

    Default

    Not a member but it could be good to upload some pics. Will wait to all is finished; i.e. the cooling fans work as they should, the A/C is functional and the exhaust is corrected after the engineers goes through.

    Still at a loss with the cooling fans........

Page 1 of 2 12 LastLast

Similar Threads

  1. Holden Commodore VR Buick 3.8 V6 Tune?
    By strongarmz in forum General (Petrol, Gas, Ethanol)
    Replies: 7
    Last Post: August 16th, 2011, 12:02 PM
  2. E38 pwm cooling fan control
    By vette5797 in forum Conversions / Aftermarket Parts
    Replies: 1
    Last Post: December 24th, 2009, 04:07 AM
  3. E38 Cooling fans question
    By Chalky in forum E37, E38 & E67 PFI ECM's
    Replies: 2
    Last Post: September 1st, 2009, 12:11 PM
  4. Holden VE Commodore Engineering Mode
    By Blacky in forum Lounge
    Replies: 2
    Last Post: June 4th, 2009, 07:19 PM
  5. 2002 Holden Commodore spark scaler problems
    By caver in forum General (Petrol, Gas, Ethanol)
    Replies: 4
    Last Post: December 9th, 2005, 06:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •