Results 1 to 6 of 6

Thread: FI LS3 Corvette not passing readiness checks

  1. #1
    Junior Member
    Join Date
    May 2010
    Posts
    12

    Default FI LS3 Corvette not passing readiness checks

    Hi all,
    The short version...I have a supercharged 08 (LS3) Corvette that I had tuned by a "professional". The car runs fine, but I'm having trouble getting it to pass the readiness checks for emissions. Seems the rear O2's have been tuned out.

    Since having it tuned, I've moved roughly 15 hours drive away and having it retuned isn't an option. Not only the long drive, but discovered my tuner had done some shady things so I refuse to go back. (locking my ECM, selling me EFIL and wideband O2 setup, then trying to charge me to unlock it....for starters) Besides, I'm more of a DIY type and I'd rather...ya know...DIY.

    I have the v2 setup that I've slowly be learning, but I can't for the life of me get those rear o2's back in service. Even temporarily just to pass the emissions check to get my registration renewed.

    Any help or advice would be more that welcome and appreciated. I hate asking, but I'm at a loss and need to get this sorted on my daily driver asap. Thanks so much.

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,192

    Default

    Can you post your tune file if that's ok with you...?

  3. #3
    Junior Member
    Join Date
    May 2010
    Posts
    12

    Default

    I have no problems at all posting it. Will have to do so when I get home tomorrow.
    I'll even post my specs and upload it to the modified tune repository, in case anyone wants to use/modify it later on. It's a little on the rich side w/ my custom cam, but I'm still very much a novice w/ EFIL.

    Thank you.

  4. #4
    Junior Member
    Join Date
    May 2010
    Posts
    12

    Default

    Here's my tune...and specs

    08 C6 (LS3)
    224/232, 113*, .625 cam
    ported LS3 intake/TB
    1 7/8" headers
    Novi 1500 @ 8.25 psi
    160* stat

    Thanks for any help or advice. Maybe once I can get this sorted I can tackle the hot-start issue I'm having as well. lol.
    Attached Files Attached Files

  5. #5
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,192

    Default

    Some more info regarding the Readiness (Inspection/Maintenance) Tests...
    Attached Files Attached Files

  6. #6
    Junior Member
    Join Date
    May 2010
    Posts
    12

    Default

    Thank you.

    Looks like I DO need to complete more drive cycles...

Similar Threads

  1. Tuning a LS3 corvette
    By johnnoumea in forum Gen IV V8 Specific
    Replies: 5
    Last Post: December 27th, 2010, 12:08 AM
  2. CVN checks
    By eboggs_jkvl in forum E37, E38 & E67 PFI ECM's
    Replies: 10
    Last Post: June 14th, 2010, 09:14 AM
  3. checks and balances.....
    By 0rion in forum General (Diesel)
    Replies: 0
    Last Post: March 30th, 2010, 04:59 AM
  4. 2008 Corvette LS3 support added
    By GMPX in forum Gen IV V8 Specific
    Replies: 15
    Last Post: August 12th, 2007, 12:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •