Results 1 to 9 of 9

Thread: 4L80E, unexplainable code 68 and weird 4-3 shift.

  1. #1
    New Member
    Join Date
    Jun 2011
    Posts
    2

    Default 4L80E, unexplainable code 68 and weird 4-3 shift.

    Hopefully someone can help me out here..

    I have a -93 Suburban 5.7L with 4L80E. There have been some trouble with the tranny since I've bought it 6 months ago. But haven't found time to check it out until now. It had code 68, and no 4th gear. decided to take down the pan and install a shift kit, and go trough the valve body. (The man I bought it from told me the tranny was rebuild like 2000miles ago, but the warranty was out cause he had not been using the truck the last year.) I soon realized this rebuild was done by someone who had never seen the inside of a tranny before, when I dropped the pan. So I pulled the tranny out right away, so I could do the rebuild properly my self. ( the tranny was not inline with the engine, broken 4th clutch suply bolt, loose center-support bolt, generally over tightened bolts +++) So I did a proper rebuild on it, installed the shift kit, new internal wiring hardness. reused all solenoids, changed input speed sensor cause of a leak trough the sensor itself in the old one, new converter, and of course all seals, clutches etc. Then I put it back in the truck, and took it for a test run.

    I experienced a delayed delayed 2-3 shift and a to early 3-2 shift (ECM comands it that way). I but can live with that.

    To my big problem: have been using it for a few days now constantly monitoring it with my scan tool. sometimes it sets code 68 and shifts down from 4th to stay in 3rd until i clear the code. when clearing the code while driving it shifts right back up and can stay that way all day, or it can set the code again after a few miles. the code is set and then it goes about 2 seconds before it downshifts. I don't notice any slip, TCC is applied and seems to be holding fine when it sets the code. any ideas what can cause this? faulty ECM??

    Another thing started today, sometimes when downshifting from 4th to 3rd (kickdown only, both partial and WOT) it appears to go in neutral until I let off the throttle a little. then it engages 3rd. no code is sett. have tried to hold it rewed up when it frees out in the shift to force it to sett a code held it there for about 10 seconds, still no code. no burned oil, so I've concluded with that it's not slipping just no engage at all. cause I've tried to burn oil and clutches, just to make a visible fault in the tranny in case I had to open it again. (ECM is commanding 3rd)

    I have one theory that I hope is wrong.. valves sticking in valve body when it's tightened to the case. Caused by earlier over tightened vb bolts. I'd be glad for any thoughts you might have on this issue or any other theory you might have. Considering to get a used tranny to rebuild, but I'm usually not the kind that gives up on a tranny.

    For the record, I have rebuilt approximately 50 of these transmissions without any problems, and now this.. I'm glad it's in my own truck and not a tranny for a customer...

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,887

    Default

    Quote Originally Posted by team-pontiac View Post
    ...

    Another thing started today, sometimes when downshifting from 4th to 3rd (kickdown only, both partial and WOT) it appears to go in neutral until I let off the throttle a little. then it engages 3rd. no code is sett. have tried to hold it rewed up when it frees out in the shift to force it to sett a code held it there for about 10 seconds, still no code. no burned oil, so I've concluded with that it's not slipping just no engage at all. cause I've tried to burn oil and clutches, just to make a visible fault in the tranny in case I had to open it again. (ECM is commanding 3rd)

    ...
    This is what I understand is happening (but I'm no expert):

    when shifting 4->3 the overdrive roller clutch keeps overrunning (fails to hold) until you relax the throttle (and then it starts holding).

    Edit: my fingers typed the wrong word, I corrected it.
    Last edited by joecar; June 16th, 2011 at 06:48 AM.

  3. #3
    Member
    Join Date
    Dec 2008
    Posts
    70

    Default

    Quote Originally Posted by joecar View Post
    This is what I understand is happening (but I'm no expert):

    when shifting 4->3 the overdrive overrun clutch keeps overrunning (fails to hold) until you relax the throttle (and then it starts holding).
    If the shifter is in the 4th gear position, the overrun clutches will never come on. The overdrive roller clutch holds power for all forward gears in the 4th gear shifter position (if it was broken, you would never have 4th gear, reverse, or any forward gear with the shifter in the D4 position).

  4. #4
    Member
    Join Date
    Dec 2008
    Posts
    70

    Default

    a/c compressor relay circuit failure?

  5. #5
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,887

    Default

    Quote Originally Posted by slow67 View Post
    If the shifter is in the 4th gear position, the overrun clutches will never come on. The overdrive roller clutch holds power for all forward gears in the 4th gear shifter position (if it was broken, you would never have 4th gear, reverse, or any forward gear with the shifter in the D4 position).
    Ah, sorry, my typing misadventure, I meant to say overdrive roller clutch...

    it may not be broken...
    for some reason can it fail to grab after freewheeling...?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	overrun roller.png 
Views:	653 
Size:	72.8 KB 
ID:	11165  
    Last edited by joecar; June 16th, 2011 at 08:37 AM. Reason: typo

  6. #6
    Member
    Join Date
    Dec 2008
    Posts
    70

    Default

    Quote Originally Posted by joecar View Post
    Ah, sorry, my typing misadventure, I meant to say overdrive roller clutch...

    it may not be broken...
    for some reason can it fail grab after freewheeling...?
    I would say not a likely scenario, usually when they fail, its either slipping in all gears, or completely fail.

    OP, Did you do anything to the VB during the rebuild? I'm thinking maybe an AFL valve issue or possibly a weird acting shift solenoid. If Solenoid B kicks off (for whatever reason) it will act like neutral because it would be 1st gear, but since the shifter is in the D4, you wont have any engine braking.

  7. #7
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,887

    Default

    Quote Originally Posted by slow67 View Post
    I would say not a likely scenario, usually when they fail, its either slipping in all gears, or completely fail.
    ...
    Ok, I see, thanks.

  8. #8
    New Member
    Join Date
    Jun 2011
    Posts
    2

    Default

    Thanks for tips, but I'm guessing I was right about the earlier overtightened vb bolts. I, have taken out the tranny again, found myself a new (used) case and vb. installed all my the parts from my old tranny into this one, including the vb valves and solenoids. None of the old valves was sticking and I found no visible damage to either the case or vb. But I'm guessing there must be some deformation that was causing sticking valves or internal leaks when vb is tightened. Either way, now it shifts like a dream!! Even the delayed 2-3shift has corrected itself!

    Note to self.. If you ever again find yourself taking apart a transmission with what appears to be a serious overtightened vb, use a new case and vb the first time! Especially if one or more of the vb bolts is so tight that it breaks a socket, as this one did!

  9. #9
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,887

    Default

    Good job

Similar Threads

  1. rpm cut off comes up before the 2>3 shift , wont shift
    By Eric in forum Gen III V8 Specific
    Replies: 7
    Last Post: June 6th, 2011, 09:58 AM
  2. Adaptive Shift Times 4l80e + HD2
    By 2500ak in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 9
    Last Post: January 26th, 2010, 09:22 AM
  3. Code P062F and Code P0633 Help
    By Airtime in forum General (Diesel)
    Replies: 6
    Last Post: September 28th, 2009, 01:57 AM
  4. why 1>2 shift happens at higher rpm than 2>3 shift?
    By 350SS in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 1
    Last Post: March 13th, 2008, 11:54 AM
  5. Disable adaptive shift learning after Shift Kit Install
    By BlackGMC in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 3
    Last Post: January 24th, 2008, 05:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •