Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Pre-Release Update July 18, 2011

  1. #1
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,119

    Default Pre-Release Update July 18, 2011

    A Pre-Release update of the EFILive V7.5 and V8 software is available for download.
    This software update is a pre-release version and has not yet completed testing at EFILive.
    Only install and use this update if you require one or more of the fixes and/or updates it contains.
    Please do not use in a production environment until this update has been publicly released.

    Auto Update:
    Is not available for pre-release updates, you must manually download and install the pre-release from the links below.

    Manual download/install available here:
    Important information
    New ECM Support: E83 (Service #12636386)
    We have added the ability to read and flash this ECM, however, no calibration files have been provided in this beta release, we are just looking for stock tunes to be Emailed in.
    The E83 is currently used on the following US vehicles: (there maybe other European / Asian Chevrolet branded markets also using this ECM)

    • 2011-2012 Chev Cruze 1.8L (LUW)
    • 2009-2011 Chev Aveo 1.6L (LXV)
    • 2009-2010 Pontiac G3 1.6L (LXV)
    • We also expect the new 2012 Chevrolet Sonic to use the E83.

    Bosch gas ECM read/flash:
    This beta also gives users the ability to read and flash the Bosch E55, E69 & E77 ECM's. It is important to understand that EFILive is not actively working on providing a full tuning solution for these ECM's. We have however had a number of customers request that we allow the ECM's to be read and flashed using V8 (V2 or Autocal) as they are using tuning packages from Europe that allow them to save files in open .bin formats. All they wanted was a way to read/flash the ECM's.
    There is no stream option for these and it will cost you $99 per vehicle. There has not been extensive on vehicle testing for these ECM's, hence, it's beta.
    Known Issues:
    Issue #1
    Sometimes at the start of a read or flash operation the V7.5 software will complain that it cannot communicate with the FlashScan device. Sometimes after clicking [Ok] the software is able to reconnect. Sometimes you need to restart the read or flash procedure and other times you need to exit and restart the Tuning Tool application.
    We are trying to find a set of actions that can reliably reproduce that situation. If you know of any way to cause that error to occur reliably, please let us know at support@efilive.com

    Reporting Issues:
    If you discover any problems/faults, please make a note of them in this thread.

    What's new in this update:

    V7.5.7 Build 172 (July 18, 2011)

    • Added BEN factors when using dyno lambda serial wide band PIDs:
      CALC.BEN_DYNO Base Efficiency Numerator 1 - Dyno.
      CALC.BEN_DYNO_B Base Efficiency Numerator 1 - Dyno LS2 style.
      CALC.BEN_DYNO_E38 Base Efficiency Numerator 1 - Dyno E38 style.
      CALC.BEN_DYNO_E67 Base Efficiency Numerator 1 - Dyno E67 style.
    • Fixed definition of PID GM.CASERL.
    • Fixed phantom DTC P2911 showing up in V7.5 Scan Tool.
    • Fixed address error for E38, table B1848 in OS 12633056 & 22633056.

    V8.2.1 Build 161 (July 18, 2011)

    • Fixed user supplied unlock key being ignored.
    • Update selected PID lists when changing controller type in BBX setup instead of just deleting all selected PIDs.
    • Allow copy/paste of PID lists from V7 to V8.

    FlashScan/AutoCal Firmware V2.07.15 (July 18, 2011)

    • Fixed enumerated PIDs not displaying correctly on V2 BBL.

    Regards
    Paul
    Last edited by Blacky; July 26th, 2011 at 11:02 PM.
    Before asking for help, please read this.

  2. #2
    Lifetime Member Cougar281's Avatar
    Join Date
    Jan 2006
    Posts
    820

    Default

    I found that the V2 doesn't appear to be able to log the ECM & TCM at the same time now. I set up a PSL with ECM & TCM PIDs, and it appeared to only pull some data from the TCM. Everything else was 0's. When I split the PSLs into one for the TCM and one for the ECM, both PSLs work properly. The V2 also appeared to not save a log file when I tried to log both the ECM & TCM, despite saying it did. I've attached the trace file from right after stopping logging.
    USR_0668.zip


    Also got what appears to be a corrupt log. I tried restarting with no change. I can open the log I took of the TCM before the corrupt one just fine.
    E35A_0665.efi

    Any chance the IAT & IAT2 PIDs for the E35A ECM will ever get straightened out (IAT is the sensor in the MAF and IAT2 is the senor in the intake bridge; EFILive shows only the IAT2 sensor and it appears as IAT)? although I haven't logged a LMM to verify, the PIDs appear correct in the PID list for the LMM's E35B.
    Last edited by Cougar281; July 24th, 2011 at 01:45 AM.

  3. #3
    Lifetime Member Cougar281's Avatar
    Join Date
    Jan 2006
    Posts
    820

    Default

    Another possible issue. I read the tune out of my "Daily driver" A40 TCM, then swapped to another TCM and flashed the file I had just read. That flashed fine. I then modified that file and saved it with a new name. When I tried to flash that file into the TCM, first I get "Unlocking: Wait 10 seconds", then it checks the file, finally, I get "Error: $0322 Conditions Not Correct or Request Sequence Error. The same ctd file flashed fine using the V8 Passthrough.

  4. #4
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,781

    Default

    Quote Originally Posted by Cougar281 View Post
    Any chance the IAT & IAT2 PIDs for the E35A ECM will ever get straightened out (IAT is the sensor in the MAF and IAT2 is the senor in the intake bridge; EFILive shows only the IAT2 sensor and it appears as IAT)? although I haven't logged a LMM to verify, the PIDs appear correct in the PID list for the LMM's E35B.
    So the IAT PID's are good for the LBZ but not LMM?

    Quote Originally Posted by Cougar281 View Post
    I get "Error: $0322 Conditions Not Correct or Request Sequence Error. The same ctd file flashed fine using the V8 Passthrough.
    We have solved that, it will be in the next update, it can also happen in V8 passthrough.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  5. #5
    Member jay p's Avatar
    Join Date
    Dec 2005
    Posts
    53

    Default

    Quote Originally Posted by Blacky View Post
    This beta also gives users the ability to read and flash the Bosch E55, E69 & E77 ECM's.
    What are these controllers in?
    2017 2500HD L5P
    2010 2500HD LMM (sold)
    2005 Harley Ultra Classic

  6. #6
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,781

    Default

    HFV6's and SIDI V6's generally from about 2005 to 2010, such as your 2008 Arcadia, I am pretty sure that is using an E69.
    But as the original post states, it is important to understand that EFILive is not actively working on providing a full tuning solution for these ECM's.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  7. #7
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,119

    Default

    Quote Originally Posted by Cougar281 View Post
    Also got what appears to be a corrupt log. I tried restarting with no change. I can open the log I took of the TCM before the corrupt one just fine.
    There seems to be an issue with the PID definitions being different between V7.5 and V8 for the following PIDs:
    GM.FRPADES
    GM.FRPACOM

    We'll get it sorted asap.

    Regards
    Paul
    Before asking for help, please read this.

  8. #8
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,119

    Default

    Quote Originally Posted by Cougar281 View Post
    I found that the V2 doesn't appear to be able to log the ECM & TCM at the same time now. I set up a PSL with ECM & TCM PIDs, and it appeared to only pull some data from the TCM. Everything else was 0's. When I split the PSLs into one for the TCM and one for the ECM, both PSLs work properly. The V2 also appeared to not save a log file when I tried to log both the ECM & TCM, despite saying it did. I've attached the trace file from right after stopping logging.
    That problem has been fixed in the next update. It was a timing issue when starting both controllers logging.

    Quote Originally Posted by Cougar281 View Post
    Also got what appears to be a corrupt log. I tried restarting with no change. I can open the log I took of the TCM before the corrupt one just fine.
    Turns out the two PIDs FRPACOM and FRPADES are not supported properly on LBZ/LMM. They will be removed from the V8 BBL software configuration for those two controllers in the next release.
    Until then, try re-logging without those two PIDs selected.

    They won't be removed from the V7.5 software, but their logged values will almost certainly be invalid.

    Regards
    Paul
    Before asking for help, please read this.

  9. #9
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,781

    Default

    I will add to Paul's last post by saying this is another example of how 'wonderful' those Bosch ECM's are to work with. It sends back data, even though it's not valid.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  10. #10
    Lifetime Member Cougar281's Avatar
    Join Date
    Jan 2006
    Posts
    820

    Default

    Quote Originally Posted by GMPX View Post
    So the IAT PID's are good for the LBZ but not LMM?
    No, the LMM appears to be right according to the PSL (Shows both IAT and IAT2), although I haven't actually logged an LMM to be sure. The LBZ only shows IAT, and from my testing, it's actually giving the value of IAT2. The 'real' IAT isn't in the PSL. One or both of scan tool companies I had contacted regarding non-gm scanning (Ease diagnostics and autoenginuity) indicated that they did support both IAT and IAT2 on the LBZ when I asked them that in passing along side my questions about their tools functionality with other makes.

    I'm guessing Bosch did something stupid (big surprise there) with the LBZ's programming, but I know they're both there as I've viewed both IAT and IAT2 with my Tech2.

    Any thoughts when the next update might be? I was hoping to be able to log both ECM & TCM on thursday at the pull. If it'll be out by then it would be great, but if not, I can survive with just ECM data.

Page 1 of 2 12 LastLast

Similar Threads

  1. Public Release Update July 03, 2011
    By Blacky in forum Software Updates and Installation Help
    Replies: 40
    Last Post: July 17th, 2011, 07:21 AM
  2. Public Release Update June 24, 2011
    By Blacky in forum Software Updates and Installation Help
    Replies: 105
    Last Post: July 9th, 2011, 05:21 AM
  3. Public Release Update June 06, 2011
    By Blacky in forum Software Updates and Installation Help
    Replies: 18
    Last Post: June 20th, 2011, 06:12 AM
  4. January 24th 2011 pre-release
    By Blacky in forum Software Updates and Installation Help
    Replies: 81
    Last Post: April 10th, 2011, 03:17 AM
  5. January 31st 2011 pre-release (Updated Feb 03, 2011)
    By Blacky in forum Software Updates and Installation Help
    Replies: 21
    Last Post: February 24th, 2011, 05:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •