Results 1 to 5 of 5

Thread: shift solenoids not working till commanded

  1. #1
    Junior Member
    Join Date
    Dec 2007
    Posts
    29

    Default shift solenoids not working till commanded

    my buddy put his truck back to stock with a stock 60E. the truck starts out in 3rd gear because for some reason my shift solenoids are not turning on. However with my scan tool i can go into the DVT(f12) tab and command both of them on. When i do that the truck starts off in 1st gear like it is suppose to. So to me that tells me that the solenoids are not bad and it must be something else.

    its not throwing any codes. does anyone have any ideas as to what it could be? something in the tune maybe?
    has no idea how to tune!!

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Compare the tune against a stock tune to see if any DTC's have been disabled.

    Check also these components for correct operation: TPS, VSS, ECT, IAT, TFT, MAP, MAF.

    Also look at the TSTATE07 and TSTATE08 pids.

  3. #3
    Junior Member
    Join Date
    Dec 2007
    Posts
    29

    Default

    Quote Originally Posted by joecar View Post
    Compare the tune against a stock tune to see if any DTC's have been disabled.

    Check also these components for correct operation: TPS, VSS, ECT, IAT, TFT, MAP, MAF.

    Also look at the TSTATE07 and TSTATE08 pids.
    i cant compare the tune with a stock one because its locked because it was tuned by nelson out of texas.

    i did make a small log in the driveway. it included pids you listed above. im not sure how to check if they are working correctly.
    Attached Files Attached Files
    has no idea how to tune!!

  4. #4
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    For example:

    TPS: with key on engine off (KOEO) log this pid and slowly sweep the throttle from zero to max and back, the log graph should show a steady increase to max followed by a steady decrease to zero with no dips/spikes or dead/flat spots.

    VSS: when driving does it look sane with no dips/spikes.

    MAP: with KOEO does it read same as barometric pressure (~100kPa close to sea level).

    IAT, ECT, TFT: at KOEO after sitting overnite do they all read very close to each other, and when driving do they make sense.

  5. #5
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    If the tune is locked, then:
    - you won't be able to check if any transmission DTC's have been turned off,
    - you won't be able to check that the shift tables and throttle kickdown tables make sense.

    If you can command the shift solenoids via DVT (are you sure they responded correctly) then the problem is either in a failed sensor or in the tune.

    Can you command 1st, 2nd and 4th, and does the trans correctly go into each of those gears (get your buddy to drive while you command DVT on the laptop, listen/feel for the commanded gear, log VSS, RPM, GEAR, TIS, TOS to verify).

Similar Threads

  1. New V2 License How long till it gets emailed?
    By MN C5 in forum Purchase and Shipping
    Replies: 7
    Last Post: June 11th, 2008, 01:45 PM
  2. Shift Point Adjuster not working?
    By Ninety8C5 in forum Gen III V8 Specific
    Replies: 1
    Last Post: October 16th, 2007, 02:09 PM
  3. shift point adjustment not working anymore
    By Alvin in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 19
    Last Post: October 2nd, 2007, 11:57 AM
  4. Idles fine till I turn on AC
    By skippy in forum General (Petrol, Gas, Ethanol)
    Replies: 2
    Last Post: June 8th, 2006, 03:02 AM
  5. How long till we can tune 98/97 ls1's.
    By red12secz28 in forum General (Petrol, Gas, Ethanol)
    Replies: 2
    Last Post: March 3rd, 2005, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •