Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30

Thread: E38/T42 4l60E P0717 Code

  1. #21
    Lifetime Member Chuck CoW's Avatar
    Join Date
    Feb 2006
    Posts
    465

    Default

    Hey Guys,

    This past year my buddy built an expensive project vehicle with an 08 vintage LS3 and a T42. Someone supplied the harness and modules.

    The vehicle didn't start or run, no less shift.

    If got it running now with some 2008 Silverado calibrations, but it won't shift and the speedo only bounces.

    I believe the problem is that he installed a 4L60e that does not have an ISS sensor and the tcm is expecting it.

    I have no definitive answers from anyone that has successfully used a NON-ISS trans with a T42. Turning off

    codes or telling the TCM the ISS is not present has not helped thus far.

    Anyone have experience with this or can shed some light?

    Your thoughts are much appreciated.

    Chuck CoW
    CoW BOOSTER! Electronic Throttle Enhancement.

    - CLICK HERE NOW FOR MORE INFORMATION! -

    VARARAM, EDELBROCK, AMERICAN RACING HEADERS, BAER BRAKES, BORLA, EFI Live, Magnuson,
    COMP Cams, PROCHARGER, PRO TORQUE, PHADT Racing, INNOVATORS WEST, and more.



  2. #22
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,841

    Default

    Hey Chuck, there are a handful of TrailBlazer SS guys running around with non-ISS transmissions swapped in, just by killing the codes and changing the tune values. If that's not working for you, not sure what would solve it as I haven't dug into it before. There must be a way, at least with E67+T42 combo (LS3 to me usually means E38).
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, starting the mods
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  3. #23
    Lifetime Member Chuck CoW's Avatar
    Join Date
    Feb 2006
    Posts
    465

    Default

    We've done all that and still no luck.

    The other problem is that we have a very erratic speedo that does not seem to want to behave.

    It's an 08 E38 T42 combo originally TIS flashed from a single truck vin.

    Chuck CoW
    CoW BOOSTER! Electronic Throttle Enhancement.

    - CLICK HERE NOW FOR MORE INFORMATION! -

    VARARAM, EDELBROCK, AMERICAN RACING HEADERS, BAER BRAKES, BORLA, EFI Live, Magnuson,
    COMP Cams, PROCHARGER, PRO TORQUE, PHADT Racing, INNOVATORS WEST, and more.



  4. #24
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,841

    Default

    Did you look through the TCM and kill everything released to ISS? P0716 codes as well?

    Does it run and drive now, just troubleshooting the P0717 and ISS related codes?
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, starting the mods
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  5. #25
    Lifetime Member Chuck CoW's Avatar
    Join Date
    Feb 2006
    Posts
    465

    Default

    Quote Originally Posted by ScarabEpic22 View Post
    Did you look through the TCM and kill everything released to ISS? P0716 codes as well?

    Does it run and drive now, just troubleshooting the P0717 and ISS related codes?
    Yeah, tried all that and it didn't seem to make a difference.

    Strange enough, I got back involved in this thread because a 2007 Suburban came in with a P0716 & P0717

    Did lots of testing with it and can't seem to put my finger on it but this kid has had 4 transmissions in the truck

    previously and 2 or 3 of them had the P0717 code.... Chased wiring, grounds, replace controller, and all sorts of other

    stuff and still every so often it throws the code and while it shifts and drives, the TCM commands max line and it

    blasts into second much harder than is acceptable. I've never seen an ISS fail and I've rebuilt many of those units

    so this is killing me.... It's a low voltage code, but the solenoids in the trans all share the same power feed....

    Up next, Gotta get the pan off and see what there is to see inside.

    No fun.

    Chuck CoW

    've
    CoW BOOSTER! Electronic Throttle Enhancement.

    - CLICK HERE NOW FOR MORE INFORMATION! -

    VARARAM, EDELBROCK, AMERICAN RACING HEADERS, BAER BRAKES, BORLA, EFI Live, Magnuson,
    COMP Cams, PROCHARGER, PRO TORQUE, PHADT Racing, INNOVATORS WEST, and more.



  6. #26
    Lifetime Member Chuck CoW's Avatar
    Join Date
    Feb 2006
    Posts
    465

    Default

    Quote Originally Posted by ScarabEpic22 View Post
    Did you look through the TCM and kill everything released to ISS? P0716 codes as well?

    Does it run and drive now, just troubleshooting the P0717 and ISS related codes?
    So, now I have another friend who came in with a 09 Trailblazer I5 with an E67 and T42. Same shit with P0716 and P0717 going into max pressure mode.

    Disabling the same codes on this vehicle also created a P0741 TCC stuck off condition. The other vehicle did not do this.

    This is an E67 / T42 combo.

    To the best of my knowledge there is no T42 calibration that does not utilize the ISS for 4L60/70e. If anyone knows of a calibration or application that

    does not use the ISS I would love to know about it.

    Additionally, the 2 vehicles where I have the ISS turned off and the codes disabled, each person says that the trans is a bit better but the overall trans behavior

    is not what it was before the ISS fault happened and was disabled.....

    Still a mystery.... Hopefully someone has some input here.

    I cant believe that you can turn off something the tcm is expecting to see without consequence.

    Iss is used for lots of stuff, especially converter slip and I can't imagine that it can be just "turned off"

    Your thoughts?

    Chuck CoW
    CoW BOOSTER! Electronic Throttle Enhancement.

    - CLICK HERE NOW FOR MORE INFORMATION! -

    VARARAM, EDELBROCK, AMERICAN RACING HEADERS, BAER BRAKES, BORLA, EFI Live, Magnuson,
    COMP Cams, PROCHARGER, PRO TORQUE, PHADT Racing, INNOVATORS WEST, and more.



  7. #27
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,879

    Default

    Thinking Out Loud:

    besides DTC's, are there any other diagnostic data that we can look at...

    for example, will Mode $6 data reveal anything, is there Mode $6 or equivalent for T42...?

  8. #28
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,841

    Default

    09+ may be a different story as that's when GM switched to the internal MLPS, removed a solenoid, and changed the wiring harness (think that's correct).

    Weird to hear about the ISS fighting you like this Chuck, not sure why it is. I think you're correct, all T42s had a trans equipped with the ISS...
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, starting the mods
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  9. #29
    Lifetime Member Chuck CoW's Avatar
    Join Date
    Feb 2006
    Posts
    465

    Default

    Hey Joe I don't think efilive ever mapped out mode $ parameters in the trans controllers.... I've never really looked, but don't remember seeing it either.

    Chuck CoW
    CoW BOOSTER! Electronic Throttle Enhancement.

    - CLICK HERE NOW FOR MORE INFORMATION! -

    VARARAM, EDELBROCK, AMERICAN RACING HEADERS, BAER BRAKES, BORLA, EFI Live, Magnuson,
    COMP Cams, PROCHARGER, PRO TORQUE, PHADT Racing, INNOVATORS WEST, and more.



  10. #30
    Lifetime Member minytrker's Avatar
    Join Date
    Jan 2006
    Posts
    1,310

    Default

    Quote Originally Posted by Chuck CoW View Post
    Hey Guys,

    This past year my buddy built an expensive project vehicle with an 08 vintage LS3 and a T42. Someone supplied the harness and modules.

    The vehicle didn't start or run, no less shift.

    If got it running now with some 2008 Silverado calibrations, but it won't shift and the speedo only bounces.

    I believe the problem is that he installed a 4L60e that does not have an ISS sensor and the tcm is expecting it.

    I have no definitive answers from anyone that has successfully used a NON-ISS trans with a T42. Turning off

    codes or telling the TCM the ISS is not present has not helped thus far.

    Anyone have experience with this or can shed some light?

    Your thoughts are much appreciated.

    Chuck CoW

    From reading the rest of the post it sounds like there may be other issues. I have successfully tuned many swaps now with E38/T42 with a 4l60 with no ISS and made them work correctly. They all took some tweaking and not just turning off codes.
    99 Z28 Camaro|LS1 Heads & cam Tuned by LSX Power Tuning
    2003 CC Duramax Dually|19.5 w/245/70/19.5|Tuned by LSX Power Tuning|5in exhaust
    2009 G8 GT Vararam CAI|Tuned by LSX Power Tuning|GXP Mufflers|Custom System
    2006 CTS-V K&N CAI|OBX Headers|Cammed LS3|Tuned by LSX Power Tuning|

Page 3 of 3 FirstFirst 123

Similar Threads

  1. T42 4L60e TCC tuning
    By jpgmtech in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 6
    Last Post: October 1st, 2010, 09:13 AM
  2. 4l60E / T42 TC lockup problems
    By harascho in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 8
    Last Post: February 16th, 2009, 07:34 AM
  3. searching 4wd 4L60E T42 .tun file OS:24235341
    By harascho in forum Gen IV V8 Specific
    Replies: 0
    Last Post: January 4th, 2009, 01:33 AM
  4. looking for 4wd tranny tune. 4L60E T42 OS:24235341
    By harascho in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 0
    Last Post: January 4th, 2009, 01:32 AM
  5. E38 with T42 for 4L60E (no ISS)
    By gmh308 in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 0
    Last Post: July 24th, 2008, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •