Results 1 to 7 of 7

Thread: Innovate MTX-L to Flashscan V2 Serial Connection

  1. #1
    New Member
    Join Date
    Nov 2011
    Posts
    2

    Default Innovate MTX-L to Flashscan V2 Serial Connection

    I'm trying to figure out why I keep getting WO2 Not Found on the V2 after setting up my MTX-L via serial.

    From the MTX-L Gauge I have used the supplied serial cable from the Serial OUT on the Gauge to then a DB9 female to female converter then using the supplied flashscan v2 cable I plug it into the RS232 port on the V2.

    Has anyone used one of these gauges with a V2 before? Apparently they're exactly the same as the LM2. Do I need to make any alterations to the cable itself?

    Hope someone knows

    Cheers....

    :edit:
    Ended up sorting it out by swapping pin 2 and pin 3 on the rs232 side
    Last edited by foakley; March 8th, 2012 at 12:27 AM.

  2. #2
    Member scottcmb's Avatar
    Join Date
    Aug 2011
    Posts
    97

    Default

    Contact IRA on this website.........he can supply you with the correct cable you need, im using the same MTX-L as you and he helped me out.........it works perfectly!!!

    Regards Scotty

  3. #3
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,189

    Default

    Hi foakley,

    As you discovered, you need a female-female null modem adapter, not a straight adapter.

  4. #4
    New Member
    Join Date
    Jan 2014
    Posts
    3

    Default

    Sorry to bring this one back, but I am having the same problem with the mtx-l data stream not coming into the V2. I am using the innovate serial cable, female to female null modem adaptor, and the efi live serial cable into the v2. Also using the w02afr1 PID as well as the calc.ben1 PID for an LS1 pcm.

    I get no data on the V2 nor into the scan tool. Any ideas?

  5. #5
    New Member
    Join Date
    Jan 2014
    Posts
    3

    Default

    false alarm. the null modem adaptor was loose. I will have to zip tie the 2 serial cables and null modem adaptor as there is no way to use the little screw in connectors on each side of the serial cables.

  6. #6
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,189

    Default

    With the ziptie are you getting data ok...?

  7. #7
    New Member
    Join Date
    Jan 2014
    Posts
    3

    Default

    Quote Originally Posted by joecar View Post
    With the ziptie are you getting data ok...?
    I am. The null modem adaptor only has 2 open threaded connections for one of the serial cables to screw into. The other side of it does not. Guess I ordered the wrong adaptor, but I found it for $5 shipped and it works, just doesn't have a double sided threaded section on the adaptor to screw in both serial cables.

Similar Threads

  1. innovate MTX wideband
    By maudyZ28 in forum Gen III V8 Specific
    Replies: 30
    Last Post: June 21st, 2011, 01:02 PM
  2. LC-1 serial connection question
    By JUSTASBC in forum General
    Replies: 2
    Last Post: March 11th, 2011, 10:41 AM
  3. LC-1 serial connection
    By nathans1987 in forum Tutorials
    Replies: 11
    Last Post: May 26th, 2009, 10:08 AM
  4. FlashScan V2 Wiring w/Innovate LC-1
    By -X- in forum FlashScan V2
    Replies: 8
    Last Post: November 19th, 2007, 04:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •