Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: EFILive on an 05 Chevy Colorado?

  1. #1
    Junior Member
    Join Date
    Jan 2005
    Posts
    27

    Default EFILive on an 05 Chevy Colorado?

    I wanted to try out V7 and V6 on my new Chevy Colorado to do some logging for fun and maybe use it for some future mods. Problem is that it wont log data. It connects fine I can update pids and mods, but when I hit F3 to start logging it gives me an error message. $31 Request out of range... I have checked all of the pids and mods. So is it just that EFILive will not connect and log from my colorado or am I doning something wrong or need to change some setting?
    Help

    PS: attached is the bug report from V6... V7 gives me the same thing

    Error report generated by EFILive at 14:05:12 on Feb 02, 2005

    Error code: ERR_RESPONSE/5
    Response $31: Request Out of Range

    EFILive Version: 6.4.1 (Build 60)

    Platform: Windows XP
    Version: 5.1 (build 2600)
    Processor type: Pentium 2791MHz

    Directories
    Temporary Cache: C:\Program Files\EFILive\ScanToolV6\Temporary cache
    Logged Data: C:\Program Files\EFILive\ScanToolV6\Logged data
    Customers: C:\Program Files\EFILive\ScanToolV6\Customers
    Configuration: C:\Program Files\EFILive\ScanToolV6\Configuration
    Exported Data: C:\Program Files\EFILive\ScanToolV6\Exported data
    Images: C:\Program Files\EFILive\ScanToolV6\Images
    Sounds: C:\Program Files\EFILive\ScanToolV6\Sounds
    Maps: C:\Program Files\EFILive\ScanToolV6\Maps
    Pids: C:\Program Files\EFILive\ScanToolV6\PIDs
    Virtual Dash: C:\Program Files\EFILive\ScanToolV6\VDash
    Print Reports: C:\Program Files\EFILive\ScanToolV6\Print reports
    Bug Reports: C:\Program Files\EFILive\ScanToolV6\Bug reports

    Connected: Yes
    Com port: 5
    Com setup: COM5: 115200,8,N,1
    Requested baud rate: 115200

    Cable id: 2
    Cable code: ATV2 or ATUSB
    Cable desc: B&B Electronics AutoTap cable
    Cable version: 2.0.4
    Cable Firmware date: 20030312
    Cable model: AT1
    Cable Serial number: 000026848029

    Protocols: 0
    Protocol list:

    Auto connect: Yes
    Scan OBDII info: Yes

    Error retries: 1
    Retry delay: 10
    Message throttle: 0

    Most recently used VIN: 1GCDS196858xxxxxx (Note: 1)

    PCM information
    PCM HDW Number: 892876304
    End Model Number: 12596784
    Serial Number: 4258K*ÿGÿ006
    Operating System Software: 12596785
    Engine Calibration: 12586421
    Engine Diagnostic Calibration: 12596808
    Transmission Calibration: 12595358
    Transmission Diagnostic Calibration: 12586396
    Fuel System Calibration: 12597234
    System Calibration: 12597240
    Speedometer Calibration: Unknown
    Operating System BCC: YKWJ
    5x24 scan mode: Not supported
    10x24 scan mode: Not supported
    Maximum dynamic packets: 16

    Detected modules:
    $10=Engine controller
    $28=Brake controller
    $40=Integration/Manufacturer expansion
    $58=Restraints
    $60=Driver information/display
    $80=Entertainment/Audio

  2. #2
    Member
    Join Date
    Oct 2003
    Posts
    58

    Default

    The EFI software may not fully support your PCM operating system yet. Note the following from your error report:

    "5x24 scan mode: Not supported
    10x24 scan mode: Not supported "

    I think the 10x24 is the default scan mode, which does not appear to work with your PCM. Try using the dynamic scan mode and see if you can log anything. Paul will probably reply soon with a better explanation.

    Cheers.
    2003 Silverado SS
    N/A: 14.257 @ 94.63 mph
    N2O: 13.200 @ 102.3 mph

  3. #3
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,437

    Default

    Trying Dynamic is as good an option as any.
    It looks like 5x24 and 10x24 are not supported on your PCM by EFILive.
    Regards
    Paul

  4. #4
    Junior Member
    Join Date
    Jan 2005
    Posts
    27

    Default

    I tried both dynamic and general, nither of which worked. General just returned the request out of range. Dynamic makes like it is logging, but doesnt return any vaild data. At idle it said over 5k rpms, ltft was -20... so i guess it isnt going to work right... any other ideas?

  5. #5
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,437

    Default

    Quote Originally Posted by Blk02Ls1A4
    I tried both dynamic and general, nither of which worked. General just returned the request out of range. Dynamic makes like it is logging, but doesnt return any vaild data. At idle it said over 5k rpms, ltft was -20... so i guess it isnt going to work right... any other ideas?
    Did you only select PIDs that started with SAE?
    Those PIDs should be the same on all vehicles and should log fine in Dynamic or General scan mode.

    The out of range error should only occur if EFILive asks the PCM for PID that it does not "know about".

    Try logging 2 PIDs only: {SAE.RPM} and {SAE.TP}

    With key on, engine off, start logging in General mode and press and release the throttle. You should see the {SAE.TP} value change to match.

    Then try again with engine on, you should see both PIDs change to match the throttle and engine speed.

    Watch the [Dash (F10)] tab page, dashpage "B" - it shows a trace of those two PIDs in the top chart.

    Paul

  6. #6
    Junior Member
    Join Date
    Jan 2005
    Posts
    27

    Default

    When I try logging those 2 pids under general mode, I get the $31 request out of range again. When I try them under dynamic, it seems like it is logging, but all it shows is a flat line. Both with the engine running and with just the ignition on. When I stop logging, the data page shows the rpms at 5694 and the tp at 96.7%... needless to say something is not right...

  7. #7
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,437

    Default

    When you get the $31 error, can you please save the error report and email it to support@efilive.com
    Copy the link to this thread (from the address bar in your browser) into the email so I can reference it back to this thread.

    Thanks
    Paul

  8. #8
    Lifetime Member
    Join Date
    Jul 2004
    Posts
    306

    Default

    Quote Originally Posted by Blk02Ls1A4
    When I try logging those 2 pids under general mode, I get the $31 request out of range again. When I try them under dynamic, it seems like it is logging, but all it shows is a flat line. Both with the engine running and with just the ignition on. When I stop logging, the data page shows the rpms at 5694 and the tp at 96.7%... needless to say something is not right...
    Try logging a single SAE pid like RPM. I have been able to log 2 pids without issue on various GM vehicles and some would log but flatline if you did more than 2.

  9. #9
    Member
    Join Date
    Oct 2003
    Posts
    58

    Default

    Any plans to support the Colorado/Canyon operating systems?
    2003 Silverado SS
    N/A: 14.257 @ 94.63 mph
    N2O: 13.200 @ 102.3 mph

  10. #10
    Lifetime Member GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,166

    Default

    Quote Originally Posted by deezel
    Any plans to support the Colorado/Canyon operating systems?
    For scanning?, It should have supported the SAE PID's anyway!!.
    For tuning, doubtful, I confess, I've never even seen a PCM for the 5cyl engine.
    BTW, that car needs an PCM update from the dealer
    http://calid.gm.com/vci/

    Cheers,
    Ross
    I no longer monitor the forum, please either post your question or create a support ticket.

Page 1 of 2 12 LastLast

Similar Threads

  1. Need 05 colorado 2.8L stock tune
    By blazinblue in forum IL6,IL5,IL4 Atlas Engines - P12 PCM
    Replies: 0
    Last Post: April 22nd, 2010, 05:40 AM
  2. 05 colorado concept/E67 computer/Help!!
    By kelly M in forum E37, E38 & E67 PFI ECM's
    Replies: 7
    Last Post: June 4th, 2009, 06:40 PM
  3. 2005 colorado I5 flash problems
    By nonnieselman in forum IL6,IL5,IL4 Atlas Engines - P12 PCM
    Replies: 7
    Last Post: July 9th, 2008, 04:00 PM
  4. 2007 Colorado IL5 PCM Read Issue
    By CGTMS in forum IL6,IL5,IL4 Atlas Engines - P12 PCM
    Replies: 8
    Last Post: May 12th, 2008, 10:48 AM
  5. Colorado/Canyon tuning
    By jah81592 in forum General (Petrol, Gas, Ethanol)
    Replies: 12
    Last Post: April 23rd, 2007, 02:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •