Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: Oil life

  1. #1
    Junior Member
    Join Date
    Jun 2012
    Posts
    43

    Default Oil life

    I have a 2007.5 GMC 3500 CC LMM
    Every since I installed EFI (3/21/12) the oil life is dropping very quick, like 1% for every 10-12 miles.
    I had the Quadzilla economy nodpf tune for 3 1/2 years the oil life was normal about 1% for every 90 miles.
    I really don't go by the oil life % but it does bug the heck out of me to see this happening, something is not right.
    I have put the Quad back in and the oil life is back to normal.
    I would like to continue using EFI tuning, but I also would like things to be back to normal.
    Any ideas from any one ?
    I did e-mail EFI on this, but no reply

  2. #2
    Lifetime Member AFTERMATH DIESEL's Avatar
    Join Date
    Apr 2011
    Posts
    340

    Default

    check b1406
    Aftermath Diesel Service
    888-494-0019
    Chris Klenke
    Cummins beta tester/EfiLive authorized reseller
    2007 5.3L Suburban and a 2015 Ram 2500 that's stuck on a train

  3. #3
    Lifetime Member AFTERMATH DIESEL's Avatar
    Join Date
    Apr 2011
    Posts
    340

    Default

    do you have your own V2 or how did you recieve your tuning?
    Aftermath Diesel Service
    888-494-0019
    Chris Klenke
    Cummins beta tester/EfiLive authorized reseller
    2007 5.3L Suburban and a 2015 Ram 2500 that's stuck on a train

  4. #4
    Junior Member
    Join Date
    Jun 2012
    Posts
    43

    Default

    Duramaxtuner, Jack of Spades

  5. #5
    Lifetime Member
    Join Date
    Feb 2007
    Posts
    517

    Default

    You need to call Duramaxtuner then because there is nothing you, me, or anyone else can do to fix it.

  6. #6
    Junior Member
    Join Date
    Jun 2012
    Posts
    43

    Default

    Quote Originally Posted by JoshH View Post
    You need to call Duramaxtuner then because there is nothing you, me, or anyone else can do to fix it.
    I have contacted them and have been hoping for something better than to just ignor it, they have known about this for over 2 months with me, even longer with others and still with no fix known.
    EFI is aware of this issue with some vehicles, are they really working on a fix or just ignoring this issue.
    Is this issue with the tuners tunes or actually these few vehicles that have a this problem???
    This is why I posted on this forum with no return messages from EFI on if they are planning on a fix, or am I just being blown off.
    I spent good money for something that is supposely the greatest and not completely working correctly to my satisfaction and being ignored on my question.
    I don't have this problem with my Quadzilla and expected the EFI to be great in all aspects and its not.
    Last edited by RVDAN; June 13th, 2012 at 08:45 AM.

  7. #7
    Lifetime Member vortecfcar's Avatar
    Join Date
    Apr 2007
    Posts
    534

    Default

    Dan,

    I know we've been in contact regarding this issue. I don't have any updates and Ross doesn't have any fix that I know of. I don't know why you're seeing oil life drop quickly. I have your oil change distance set to 10K miles in the tune in table B1406. I've seen this on a few trucks, but haven't pin pointed it's source. Obviously it's in the tune somewhere. If there's something the folks at EFIlive would like me to try to do to fix it I'm happy to comply or send them your files for adjustment.

    I think its noteworthy to those reading that you mentioned in your correspondence to me that your oil tests have indicated nothing unusual.

    Nick

  8. #8
    Junior Member
    Join Date
    Jun 2012
    Posts
    43

    Default

    Quote Originally Posted by vortecfcar View Post
    Dan,

    I know we've been in contact regarding this issue. I don't have any updates and Ross doesn't have any fix that I know of. I don't know why you're seeing oil life drop quickly. I have your oil change distance set to 10K miles in the tune in table B1406. I've seen this on a few trucks, but haven't pin pointed it's source. Obviously it's in the tune somewhere. If there's something the folks at EFIlive would like me to try to do to fix it I'm happy to comply or send them your files for adjustment.

    I think its noteworthy to those reading that you mentioned in your correspondence to me that your oil tests have indicated nothing unusual.

    Nick
    Yes the oil analysis is normal, but the whole thing justs bugs the heck out of me enough that I'm checking it constantly so to solve this I just put my Quad back in yesterday.
    I know not many have this problem and I would prefer it to be the sameway with me, it's just something in the back of my mind that does not seem right and I can not just ignor it.
    All I was hoping for was EFI to communicate with me because I know your at a stand still until you hear something from them.
    I got the vibe (not from you) when I asked this question no one really wanted to talk about it so I tried with EFI.com with no luck so then I tried this forum, hoping for something other than to just ignor it.
    I would not be as upset if someone from EFI would have at least acknowledge my question and contacted me.
    Last edited by RVDAN; June 13th, 2012 at 09:36 AM.

  9. #9
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,987

    Default

    Oil Life is calculated by the ECM...

    EFILive is just an edit/flash tool so it cannot effect Oil Life...

    I am not familiar with your tune file, but if it contained oil life parameters/tables and someone tampered with these then Oil Life would be effected (but can you see that this would be the tune file and not the edit/flash tool...?)

    Or maybe the ECM is detecting conditions that cause the Oil Life calculation to be accelerated (lots of WOT pulls followed by lots of idling).

    (BTW: EFILive isn't "installed" on your ECM)


    I pm'd Tech Support in case they want to clarify or add to the above.

  10. #10
    Junior Member
    Join Date
    Jun 2012
    Posts
    43

    Default

    Quote Originally Posted by joecar View Post
    Oil Life is calculated by the ECM...

    EFILive is just an edit/flash tool so it cannot effect Oil Life...

    I am not familiar with your tune file, but if it contained oil life parameters/tables and someone tampered with these then Oil Life would be effected (but can you see that this would be the tune file and not the edit/flash tool...?)

    Or maybe the ECM is detecting conditions that cause the Oil Life calculation to be accelerated (lots of WOT pulls followed by lots of idling).

    (BTW: EFILive isn't "installed" on your ECM)


    I pm'd Tech Support in case they want to clarify or add to the above.
    Thank you for the info,
    No WOT long pulls or long idling
    I did not want to mention anything or anybody other than what issue that i have and is bothering me.
    I just would like to have this resolved and work correctly.
    I've never just ignored something that I don't think is right the past 60yrs and I'm not going to start now.
    Again thank you for the info.

Page 1 of 5 123 ... LastLast

Similar Threads

  1. Oil life
    By RVDAN in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 0
    Last Post: June 12th, 2012, 03:48 AM
  2. Oil Life?
    By Idle_Chatter in forum Duramax LB7
    Replies: 3
    Last Post: October 1st, 2006, 01:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •