Results 1 to 9 of 9

Thread: what is vats patch and how do i use it

  1. #1
    Lifetime Member
    Join Date
    May 2012
    Posts
    302

    Default what is vats patch and how do i use it

    As the title say what is vats patch and hoew do i use it thanks for all

  2. #2
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,806

    Default

    Because there was no VATS disable as such on the E40, E38, E67 etc like there was on the LS1 PCM, the VATS patch does that job. You would only use it if doing an engine swap in to an old car etc or the engine won't run.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  3. #3
    Lifetime Member
    Join Date
    Aug 2010
    Posts
    1,934

    Default

    A one line post won't get much of a response - if you want assistance from the Forum membership, take the time to explain what it is that you are trying to achieve.

    What ECM & OS are you using ? What engine & transmission are you using ?

    Going in an older vehicle or a newer one with a BCM ?


    Regards,
    Taz

  4. #4
    Lifetime Member
    Join Date
    May 2012
    Posts
    302

    Default

    Thank you taz and thank you gmpx..
    Allright this is the info:
    The engine is a 6.2L VVT, No DOD.
    Transmission: th350
    this combo its isntalled a 1987 silverado..
    -The ECM is a e38, OS: 12636005

    I wanna know where is the vats patch on the tunetool or how do a apply it..


    There is no defined VATS disable in this ECM, to disable VATS you must select either Type 2 or Type 3 from this list and apply the VATS patch to the operating system.

    See Also: {B9903} "(not available in this operating system)"


    Another question is this: i dont know how but the engine is running now, but it has this code: P0108.. the engine starts but rungs pretty bad, it doesnt have power, im sure the problem is that MAP code, i put another MAP sensor and still same problem, i even put this ECM in a 08 truck, and the same code and runs pretty bad too., what i can do?? i will atach the current tune..
    Attached Files Attached Files

  5. #5
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,806

    Default

    Re the VATS patch, just make sure you have the V2 plugged in to the USB port before you start the software, then the option will show up.
    But, if the engine is running now then it must have been done.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  6. #6
    Lifetime Member
    Join Date
    Aug 2010
    Posts
    1,934

    Default

    In the tune you posted, you have applied the VATS patch (B9903) and setup the VATS and Cranking parameters such that the engine should start without a BCM, etc.

    Couple of things .... the ECM tune is a 2010 truck variety. What is the service number on the E38 ECM that you are using ? Did it come with the 6.2L engine ? What wiring harness are you using ? Does the MAP connector in the wiring harness look similar to the connector for the CKP sensor, or is it a different shape and black in colour ?

    MAP sensors - on trucks GM used Delphi MAP sensors up to MY 2008. The 2009+ trucks used Bosch MAP sensors. The parameters in the tune are different for these. Swapping your E38 (with the 2010 tune - set up for a Bosch MAP) into the 2008 truck as a test was of no diagnostic value - the 2008 truck has a Delphi MAP.


    Regards,
    Taz

  7. #7
    Lifetime Member
    Join Date
    May 2012
    Posts
    302

    Default

    Thanks now i understand about the vats patch..

    I get the E38 on a yunkYard, i compare the tune of this E38 with one that i get from tunefiledepot (2010 GMC Yukon Truck Automatic L92 6.2 Litre (12636005)) and both has same parameters so i asume that the E38 that i get from the yunk yard is tuned for 6.2L..

    Thanks for the info about the MAP sensor, i think that is the problem, im using a delphi MAP sensor in this 6.2L ( the part number is the same nmber that my 06 silveradp MAP sensor has) i will get a bosch map sensor and will se how it works

  8. #8
    Lifetime Member
    Join Date
    Aug 2010
    Posts
    1,934

    Default

    Quote Originally Posted by 400ss View Post
    ... Thanks for the info about the MAP sensor, i think that is the problem, im using a delphi MAP sensor in this 6.2L ( the part number is the same nmber that my 06 silveradp MAP sensor has) i will get a bosch map sensor and will se how it works ...
    You can use either MAP sensor - just configure the MAP parameters in the tune to correspond to the MAP you are using. If your wiring harness is setup for a Delphi MAP (sounds like it is) the Bosch MAP will not plug in - without the MAP connector being changed.


    Regards,
    Taz

  9. #9
    Lifetime Member
    Join Date
    May 2012
    Posts
    302

    Default

    I think the wiring harness was from a 08 4L65 silverado, i converted it to stand alone, deleted trans harness..

    If is posible to configure the map sensor parameters on this PCM tune to use the delphi sensor that would be better because i already have the delphi sensor. how can i setup for it?? wich table? thank you very much really

Similar Threads

  1. Replies: 4
    Last Post: June 22nd, 2012, 03:29 AM
  2. E78 1.4 cruse vats patch?
    By MattS in forum E78, E83, E84 PFI ECM's
    Replies: 19
    Last Post: May 9th, 2012, 01:01 PM
  3. Lean cruise patch help
    By schwoch1 in forum General (Petrol, Gas, Ethanol)
    Replies: 10
    Last Post: June 19th, 2011, 05:32 PM
  4. mafless patch
    By The Alchemist in forum E37, E38 & E67 PFI ECM's
    Replies: 3
    Last Post: November 19th, 2010, 07:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •