Results 1 to 5 of 5

Thread: Dumb question for the day...

  1. #1
    Junior Member
    Join Date
    Jan 2004
    Posts
    40

    Default Dumb question for the day...

    I am back with essentially the same issue I had when originally purchased V1 to tune my 1998 Z28 Camaro.

    http://forum.efilive.com/search.php?searchid=642678

    The dumb question is:
    "Leave key off until countdown completes"

    This message displays after I try to make a read and after about 10 attempts are made trying to make a connection, I get the 'can't load bootloader" and then the message displays.

    This is what I understand about the steps to make a read.

    Plug in the device inside the car after making sure the USB cable is attached to my laptop (IBM T61 with Windows7 - 32 bit).
    Turn the ignition key to on but do not start the car.
    Click on "Read PCM Calibration"
    After next screen displays "unclick high speed"
    Check status - this part is successful. It returns all correct information about my car - vin, etc.
    The program than goes through the process of trying to read the pcm.
    It fails with the bootloader issue - same as back in 2005 - see link above.
    The message above appears which has me confused.

    So my dumb question is this?

    If the key is on when you start the read, then where in the steps do you turn the key off?
    If the read is successful, you leave the key on until the read complete, turn the key off, then wait for the countdown.
    But if the read is unsuccessful, as it is for me, when do I turn the key off? The message states to leave the key off until the count down completes.

    Because the read is unsuccessful, the car won't start. So I have been following the steps which are:

    1. Turn key on but don't start car.
    2. Pull PCM BAT and PCM IGN fuses in engine compartment.
    3. Wait a few minutes.
    4. Turn ignition off.
    5. Replace fuses.

    After following the steps above my car starts.

    Now for some history - 2005.

    I never could get my original laptop (Toshiba - new and spec'd for the time frame) to make a successful read or flash. I finally gave up for two years (2005- 2007) because no one could help to resolve the problem of not being able to read my PCM - even though I could successfully use the scanner and make logs, or haul my workstation out to the garage and hook it up and 'believe it not not - make a succesul read". What hazzle and pain to do.

    A person with HP tuners said that he had heard about a similar issue with another EFI live user and that the issue was to reinstall whichever was the current net framework on the laptop.

    So we did that and I was shocked and stunned. After the repair and install of net framework I was finally after nearly 3 years (2005 2008) able to use my Toshiba to read and flash my pcm.

    Fast forward to 2009.

    I gave the Toshiba away and bought a reconditioned IBM T42. I installed all of the current EFI live versions and updates and right out of the gate I was once again able to read and flash my pcm. No problems at all with the T42 other than reads had to done at slow speed.

    Fast forward to current 2012.

    I gave the t42 away and now have a new (when I purchased it) IBM T61 with Windows 7. I did a fresh install of the latest version of EFI Live V7.8 and V8.
    But unfortunately, I am right back to exactly the same message and error I got with the Toshiba back in 2005.

    Same bootloader error message, same funky message "leave the key off until the countdown completes" and then I have to pull fuses to get the car to start.

    Has anybody ever followed the issue with the net framework? I can't find a thing about net framework here on EFI live.

    BTW - I did find a readme on my pc. When I opened it, it said that net framework 2.0 had to be installed in order for whatever folder I was in (EFI live subfolder) to work . That makes sense if the application refers back to code in net framework 2.0.

    I have done some programming - Visual Basic 6.

    When you install an application, if a certain version of net framework is required, by default you are forced to install it. And if it isn't, well, your application won't work same as if a DLL is corrupted or has been renamed or overwritten with a later version. I think it was called "dll hell" which btw the the net framework versions were supposed to eliminate.

    I doubt it is my cable - it has been stored in a protected box since I got it. Paul sent me a new cable in 2005. It didn't work either - well it actually did - but it had nothing to do with either cable. It was software related. In fact, once the software issue is resolved, I think both of my cables will work.

    I have uninstalled and resinstalled many times.
    I even reinstalled a version I had saved back in 2007 thinking if it worked with the T42, it might work with the T61. It didn't, so unistalled and reinstalled V75. and V8.

    Sorry about the long post. I sure would like to use EFI live. All I need to do is change the gear ratio with a new flash.




    Last edited by dlandsvZ28; August 12th, 2012 at 04:54 AM.

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    I notified Paul.

  3. #3
    EFILive Crew Site Admin Tordne's Avatar
    Join Date
    Oct 2004
    Posts
    3,870

    Default

    Hi there,

    The first thing is to please check that your software and firmware are up-to-date. See these knowledgebase articles for general information about on-going software and firmware updates:
    - Software updates
    - Firmware updates

    If you have very old 2.04.x firmware please see the bottom section of the firmware updates article. If you are on this very old release it is imperative that you first upgrade to 2.07.72 prior to upgrading to the later bootblock and firmware versions. This is outlined in the document.

    If you are still having issues (please try both V7 and V8) we need you to send through the trace information (as described HERE). Send that through to support@efilive.com.

    BTW: EFILive is not a .NET application so I wouldn't expect anything to do with the .NET Framework to effect EFILive.

    Cheers,
    Andrew
    EFILive Crew


  4. #4
    Junior Member
    Join Date
    Jan 2004
    Posts
    40

    Default

    All software is up to date.

    I have a V1 cable. Correct me if I am wrong - V2 firmware update apply to V1? I didn't think so.

    If there was a firmware upgrade for my V1 cable, then someone will have to give me the link to it - so I can download it.

    Update:

    After attempting the entire weekend to successfully make a read, I tried again this afternoon and was able to make successful reads and flashes.


    Changes today compared to the weekend.

    I used a Belkin 6 port USB external device powered by normal wall plugin. I plugged the USB V1 cable to it instead of directly to the laptop (Lenovo T61).
    I noticed my radio appeared to be on even though the radio fuse was pulled. I rarely use the radio, it was on, so I turned it off. Whether it was really on or not I don't know. It is the stock radio.
    I also turned off all overhead florescent lights.
    I turned the ignition on and off from the window rather than opening and closing the door.
    I hooked the device to the car, then the usb to the laptop. I next turned the ignition on and next opened the 7.5 tuning application.
    I have always used slow speed before (IBM T42 days), but today left the checkbox checked and used high speed.

    I will test and try again tomorrow but with the florescent lights on. I might also try different USB ports on the laptop. There are three.

    Will keep you updated.

    Thanks in advance.

    DuWayne

    BTW - the speedo calibration did update for my first flash from 3.42 to 3.23. I fine tuned it on the second flash to a 1 mph difference at 65 mph. I compared it to my Garmin GPS which has been tested with two other devices - so it is accurate.

  5. #5
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,119

    Default

    I highly recommend using high speed reading/flashing. Only use low speed if the high speed options consistently fails.

    Plus, as Andrew said, EFILive does not use .NET and does not need any .NET components. Any changes that you may have made to the .NET system(s) on your laptop that appeared to make a difference are purely coincidental.
    The EFILive software does not rely on any external third party dlls other than what ships natively with Windows and the FlashScan/AutoCal USB drivers.

    Regards
    Paul
    Before asking for help, please read this.

Similar Threads

  1. Dumb question...
    By 8100 Power in forum FlashScan V2 BB Logging
    Replies: 2
    Last Post: September 30th, 2008, 03:56 PM
  2. Dumb question...
    By Cougar281 in forum Vortec V6/V8 Specific
    Replies: 2
    Last Post: November 7th, 2007, 08:55 AM
  3. Probably a Dumb question...............
    By FreddyG in forum Petrol / Gas
    Replies: 6
    Last Post: September 17th, 2007, 02:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •