Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Engine starts and then stops straight away.

  1. #1
    New Member
    Join Date
    Nov 2012
    Posts
    7

    Default Engine starts and then stops straight away.

    Firstly I'd like to say hello as I am new here. You guys are doing great things here.

    I have a car in the shop here that the guy brought to us as a none runner. He had a gen3 ecu in his hand and wanted it fitting to the car. So we have manufactured a wire harness using information found on various web sites. So as the title says the car will fire and stop straight away.

    Before we built the harness I spoke to the customer and asked him about the ecu and the fact that I thought all the information pointed towards it being electronic throttle control, he assured me that the supplier had coded that out of the ecu.

    When I scan with EFI live the errors reported are Crank learning and throttle controller out of sync.

    The ecu has a green connector and a blue connector.

    Any 1 able to point me in the right direction?

    Thanks

  2. #2
    Member
    Join Date
    Feb 2008
    Posts
    68

    Default

    Green and Blue connectors are for "drive by wire" Some controllers can work with "drive by cable". But I've always just used the correct harness and pcm for the throttle type. The engine can run with the crank relearn alarm, but the procedure is tedious and a pain. The throttle being used is a electronic driven, correct? If so it could be a wiring issue between the throttlebody, tac module, and pedal in the harness.
    LQ4, Pro-Flo, heads, Stock48 cam'd, twin TO4E 2001 C5
    2001 GMC RCSB pt88/5.3/4l80e/14 bolt 11.34@123.2 best pass so far with a 1,82 60' @ 13lbs boost

  3. #3
    New Member
    Join Date
    Nov 2012
    Posts
    7

    Default

    Hi Joey, thanks for your reply.
    No we are straight cable throttle as guy assured me that the ecu had been changed to be cable throttle. Is that possible to do even?

    Thanks?

  4. #4
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    9,729

    Default

    It is possible to do, but without seeing the tune in the PCM there's no way to tell.
    Before asking for help, please read this.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.

    In The Garage:
    2014 Holden Cruze 2.0L Diesel, A6 (E20 ECM), 430Nm @2,500, (Highway 4.5L/100km : 52MPG), sweet!
    2011 Holden Commodore 3.0L SIDI LFW (E39 ECM), who left the torque out?
    Who, who, who, who, who?.
    1967 Cadillac Fleetwood 75 Sedan
    (old school Prius).
    1964 Cadillac Fleetwood (2010 L96/6L90E swap in progress).

  5. #5
    Lifetime Member 5.7ute's Avatar
    Join Date
    Oct 2006
    Posts
    1,702

    Default

    Anti theft has been disabled?
    The Tremor at AIR

  6. #6
    New Member
    Join Date
    Nov 2012
    Posts
    7

    Default

    Thanks for you reply guys.
    It would seem to me that you are all pointing me towards looking at the ecu program.
    Not sure about anti-theft again was told it was de activated. The guy was sold the ecu out of a race car ( supposedly).

    Would the anti theft allow the engine to start then cut out straight away or would it not even let it crank?

    Thanks guys.

  7. #7
    Member
    Join Date
    Feb 2008
    Posts
    68

    Default

    Are you able to read the tun file in the pcm? If so you can post it (attach it in another message post) and we can try to see what is happening. When I've fought pcm's with the security function on, the vehicle will crank but not run.
    LQ4, Pro-Flo, heads, Stock48 cam'd, twin TO4E 2001 C5
    2001 GMC RCSB pt88/5.3/4l80e/14 bolt 11.34@123.2 best pass so far with a 1,82 60' @ 13lbs boost

  8. #8
    New Member
    Join Date
    Nov 2012
    Posts
    7

    Default

    Yep, i think thats where I need to go next. Read the pcm and see what can be done.
    I might get some time to do this in between dyno jobs over the next couple of days.
    Keep your eyes out and i'll get back to you.
    Thanks again

  9. #9
    Junior Member
    Join Date
    Mar 2012
    Posts
    44

    Default

    I'd be insterested to see how you wired the wiring harness. If you are going green/blue and drive by cable did you verify that the pcm has the stepper motor controller in it? Did you wire for it? What about the TPS, you add that wiring?

  10. #10
    New Member
    Join Date
    Nov 2012
    Posts
    7

    Default

    Quote Originally Posted by SkinnyPedal View Post
    I'd be insterested to see how you wired the wiring harness. If you are going green/blue and drive by cable did you verify that the pcm has the stepper motor controller in it? Did you wire for it? What about the TPS, you add that wiring?
    Hi, to be fair I had't checked to see if the pcm had the stepper motor driver in it as i'd been informed it was good to go.
    I have this morning opened the pcm to see and it does have the motor driver in. So I then read the tune file.
    After a bit of a look at the tune i could see that the thing was set up for a y body. In the options table it said that should have fly by wire. So i changed that to be a f body. (All the options read no).
    Flashed the tune and turned the key.......brum she runs.

    We had wired to be a standard cable operated throttle with a position sensor.

    Please keep your eyes here as I will post some pics of the harness we made and the tune file for interest.
    Any one see any issues with what I have done?

    Thanks for all the input guys.

Page 1 of 2 12 LastLast

Similar Threads

  1. 7.5 stops reponding when flashing or reading
    By seriousdiesel in forum FlashScan V2
    Replies: 2
    Last Post: December 19th, 2011, 10:12 AM
  2. Throttle stops working when accelerating..
    By iViLe in forum Gen IV V8 Specific
    Replies: 12
    Last Post: May 19th, 2011, 09:48 AM
  3. Setting the record straight on Gen IV ADM/DoD and VVT
    By TBMSport in forum Gen IV V8 Specific
    Replies: 19
    Last Post: April 2nd, 2010, 06:56 AM
  4. Dual spark maps, let me get this straight????
    By nitrorocket in forum Custom Operating Systems
    Replies: 4
    Last Post: August 9th, 2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •