Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Water in ECM?

  1. #1
    Senior Member
    Join Date
    Dec 2007
    Posts
    133

    Default Water in ECM?

    Is it possible to get water in the ECM? i washed the engine bay yesterday and now have this list of DTC.

    It will run....poorly and im still able to flash the ECM, i just cant clear these codes.
    I pulled apart every connection i could find under the hood, cleaned it with contact cleaner and hit with the blow-dryer before re-assembly. I also threw a charge on the battery, rechecked the grounds and ran a temporary ground straight to the battery with no avail.

    any thoughts? it looks like its one bundle of sensors that isnt getting full voltage
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DTC.jpg 
Views:	158 
Size:	228.7 KB 
ID:	15281  
    06 Laramie 3500 QC SB 4x4 - Full billet Auto by DTT, HE351/S475 twins, EFI live, lots of custom goodies....

    07 6.2L Yukon Denali - CAI, CAT delete, self tuned with EFI Live

    03 Trailblazer 4.2L I6 - CAI, custom exhaust, EFI live

    2010 Laramie 3500 CC LB 4x4 - H&S, DPF delete, waiting for EFI Live.....

  2. #2
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,109

    Default

    Those ECM's are sealed up really well, I doubt water got in, but I agree it's like you are missing a 5V reference to a bunch of sensors.


  3. #3
    Lifetime Member 2007 5.9's Avatar
    Join Date
    Nov 2010
    Posts
    1,835

    Default

    Maybe not in the ECM ,but possibly in the harness and shorted a circuit out?
    Les Szmidt
    2007 5.9 Dodge Ram
    2014 Ram 3500 Aisin tuning Emissions Equipped
    EFI Live Cummins BETA Tester
    Silver Bullet Tuning
    silverbullettuning@gmail.com
    www.youtube.com/ljszmidt
    http://www.facebook.com/SilverBulletTuninig

  4. #4
    Senior Member
    Join Date
    Aug 2011
    Posts
    150

    Default

    Check the ecm harness plugs have seen moisture get in there had that happen to me when pushing thru snow banks andgot the engine conpartment full of snow and ice.
    Tuning by Zack StarLite diesel

  5. #5
    Senior Member
    Join Date
    Dec 2007
    Posts
    133

    Default

    ive had the ECM plugs off 3 times now & cleaned and dried each time.

    i pulled out the multimeter and checked the MAP sensor plug as it was one on the list. there was a steady 4.95v on the power wire.
    on the ground however, the resistance would hold at 4.0 ohm then spike up to over 12.0 ohm for a few seconds before returning back down to 4 for some reason. im tempted to jumper in a ground lead direct to that wire and see what happens.
    06 Laramie 3500 QC SB 4x4 - Full billet Auto by DTT, HE351/S475 twins, EFI live, lots of custom goodies....

    07 6.2L Yukon Denali - CAI, CAT delete, self tuned with EFI Live

    03 Trailblazer 4.2L I6 - CAI, custom exhaust, EFI live

    2010 Laramie 3500 CC LB 4x4 - H&S, DPF delete, waiting for EFI Live.....

  6. #6
    Senior Member
    Join Date
    Dec 2007
    Posts
    133

    Default

    this morning i cleared DTC and it started and ran fine. no more codes but it has a "miss" now and then. There must be a connection im missing, or perhaps a bad wire that didnt like the water.

    this was a good read tho:
    http://articles.mopar1973man.com/3rd...supply-circuit
    06 Laramie 3500 QC SB 4x4 - Full billet Auto by DTT, HE351/S475 twins, EFI live, lots of custom goodies....

    07 6.2L Yukon Denali - CAI, CAT delete, self tuned with EFI Live

    03 Trailblazer 4.2L I6 - CAI, custom exhaust, EFI live

    2010 Laramie 3500 CC LB 4x4 - H&S, DPF delete, waiting for EFI Live.....

  7. #7
    Lifetime Member killerbee's Avatar
    Join Date
    Jan 2006
    Posts
    1,056

    Default

    Open the hood and let the sun beat on it for a day. I agree it is not likely that water got into the ECM.

    Out of curiosity, did you pressure wash it?
    Michael, Systems Engineer 04.5 D-max LLY, Phoenix, Arizona Email
    Custom Tuning Services
    DURAMAX/CUMMINS ECM's TCM's for sale, all years, 20% wholesale discount available
    EFILive's first VGT "Software Wastegate Tune"

  8. #8
    Senior Member
    Join Date
    Dec 2007
    Posts
    133

    Default

    Quote Originally Posted by killerbee View Post
    Open the hood and let the sun beat on it for a day. I agree it is not likely that water got into the ECM.

    Out of curiosity, did you pressure wash it?
    i soaked it at the carwash with their "tire & engine" cleaner for about 15min, then stood back and rinsed it keeping the direct spray to a minimum
    06 Laramie 3500 QC SB 4x4 - Full billet Auto by DTT, HE351/S475 twins, EFI live, lots of custom goodies....

    07 6.2L Yukon Denali - CAI, CAT delete, self tuned with EFI Live

    03 Trailblazer 4.2L I6 - CAI, custom exhaust, EFI live

    2010 Laramie 3500 CC LB 4x4 - H&S, DPF delete, waiting for EFI Live.....

  9. #9
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,074

    Default

    Quote Originally Posted by skneeland View Post
    ...
    i washed the engine bay
    ...
    Bad deal, avoid doing this.

  10. #10
    Lifetime Member anarchydiesel's Avatar
    Join Date
    Jun 2011
    Posts
    614

    Default

    More than likely water got into the TIPM.

    Anarchy Diesel Tuning/ Advanced Injection Diesel Technologies
    EFI Live Cummins Beta Tester
    Duramax and Cummins Tuning
    423-506-7427

Page 1 of 2 12 LastLast

Similar Threads

  1. Whats in the water down under?
    By LORDDiESEL in forum Lounge
    Replies: 1
    Last Post: September 2nd, 2012, 10:07 AM
  2. Dead Roadrunner, not sure how but water damage.
    By 1998ws6 in forum RoadRunner Real-Time PCM Emulator
    Replies: 5
    Last Post: January 6th, 2012, 05:11 AM
  3. Failed water pump gaskets
    By joecar in forum Lounge
    Replies: 17
    Last Post: May 24th, 2010, 05:55 PM
  4. I might mix water with fuel. The ethanol manuall
    By 98 tigershark in forum General (Petrol, Gas, Ethanol)
    Replies: 0
    Last Post: September 11th, 2009, 04:08 PM
  5. EFI and Meth/Water Injection
    By LBZ in forum General (Diesel)
    Replies: 2
    Last Post: August 6th, 2007, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •