Results 1 to 2 of 2

Thread: Have EFI Live and getting EGR Codes-Engine runs in limp mode-2008 Duramax

  1. #1
    New Member
    Join Date
    Jul 2013
    Posts
    1

    Default Have EFI Live and getting EGR Codes-Engine runs in limp mode-2008 Duramax

    I have a 2008 Duramax and had a diesel shop install EFI live and pull off the DPF. I did this at about 30k miles. The truck now has 76k miles which most are highway. I changed the fuel filter at 69k and yesterday I got a code to replace the fuel filter. When it did this is went into what I am suspecting is called "limp mode". I took it right in and had a new filter put in. The mechanic plugged in his computer and there was a code for the fuel filter and one for the EGR. He deleted both codes and I drove off and it seemed to run fine. After 10 miles the check engine light came on and it went into limp mode again. I thought when they installed the EFI live it deleted the EGR? I have the 5 tune which as I understand gives you 20,40,60,80,110 more horse power depending on level 1-5. 5 being the 110 hp increase. Can anyone help me understand whats going on with this engine?

    thanks,
    Tim

  2. #2
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,792

    Default

    Have to talk with your tuner, he's the one that built your tune. Unless he wants to post it up here for us to examine, there isnt much we can do. There are many different reasons and things that could have caused this, best bet is to work with your shop/tuner and if they cant figure it out, come on here and post the tune.
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, starting the mods
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

Similar Threads

  1. Solution for p2534 limp mode transmission on engine swaps
    By 400ss in forum Conversions / Aftermarket Parts
    Replies: 8
    Last Post: February 25th, 2019, 10:43 AM
  2. Help Clearing codes EFI Live V1
    By speedygoss in forum Duramax LLY
    Replies: 1
    Last Post: January 31st, 2010, 12:14 PM
  3. Replies: 6
    Last Post: December 12th, 2009, 03:07 AM
  4. 2008 denali and efi live?
    By midevil1 in forum Gen IV V8 Specific
    Replies: 27
    Last Post: March 18th, 2009, 11:34 AM
  5. A little bummed about V2 EFI Live and Duramax
    By chevyspy in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 7
    Last Post: August 24th, 2007, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •