Results 1 to 3 of 3

Thread: Trouble connecting to E67 ECM w/FSp V1.2

  1. #1
    New Member
    Join Date
    Feb 2007
    Posts
    2

    Default Trouble connecting to E67 ECM w/FSp V1.2

    I have a friend who is transplanting a 6.0L out of an '08 Trailblazer SS. I tried to scan the ECM but it states "ECM not detected". I have recently updated to the V7.5. I have tried to do a search for the E67, but couldn't find the same circumstances. I then hooked it up to my '69 Camaro with a 2002 LS1 to test and had no issues. What am I missing here?

  2. #2
    Lifetime Member
    Join Date
    Aug 2010
    Posts
    1,934

    Default

    You need a V2 for CAN Bus controllers...

  3. #3
    New Member
    Join Date
    Feb 2007
    Posts
    2

    Default

    Thanks.

Similar Threads

  1. Chevy Traverse... E67?... locked ECM? trouble reading
    By ericdrob67 in forum E37, E38 & E67 PFI ECM's
    Replies: 5
    Last Post: September 17th, 2013, 09:55 AM
  2. Trouble flashing my ECM
    By derrickmanx1 in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 9
    Last Post: May 7th, 2012, 02:20 AM
  3. Having trouble connecting V4 to vehicle
    By jfclubby in forum EFILive V4
    Replies: 12
    Last Post: June 18th, 2011, 10:15 AM
  4. Trouble Communicating with E38 ECM
    By philip.long in forum E37, E38 & E67 PFI ECM's
    Replies: 5
    Last Post: January 25th, 2009, 08:33 AM
  5. Trouble connecting
    By ahall1 in forum General (Petrol, Gas, Ethanol)
    Replies: 1
    Last Post: May 26th, 2005, 10:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •