Results 1 to 6 of 6

Thread: Installed lift pump and now I am gettin lots of smoke.

  1. #1
    Junior Member
    Join Date
    Oct 2014
    Posts
    17

    Default Installed lift pump and now I am gettin lots of smoke.

    I finally installed my Fass 150 on my 07 and now my tunes I worked hard on not to smoke now smoke a lot. It happens when at cruising speed when I go to ease into the throttle; I look in the mirror and holy crap. It's also when I start off from a stop too. Do I need to retard main timing more at cruising speed? Do I need to increase the rail pressure and decrease fuel. I know its delivering a lot more fuel to the cp3 now. The cp3 is all stock and so are my injectors. I have been playin hell gettin my big single to light quick and stay lit. I have the pilot time and quantity set where it started working with no smoke EGTs in the 900-950 range and low main timing. I'm just kind of scratchin my head right now of where I need to start. I would appreciate any help.

  2. #2
    Senior Member tylerltr450's Avatar
    Join Date
    Aug 2014
    Posts
    150

    Default

    Do you not have a low pressure gauge? what is the cp3 reading?
    2006 Cummins Red, Auto to Nv5600, SBC 3600, Traction Bars, Visor, Running Lights, S&B Intake, ATS intake horn, EFI Live, Borg Warner S363 Turbo, Industrial Injection Dragon Fly Injectors.

  3. #3
    Junior Member
    Join Date
    Oct 2014
    Posts
    17

    Default

    Well turns out I get no smoke if I don't use the CSP5 switch. I installed the switch before the Fass. For some reason the CSP5 I makin my tunes smoke. I unplugged it and have tried all my regular tunes I made and they run great. Scratchin my head. Is there somethin I'm doin wrong with my switch? I data logged (finally figured out was Les was talkin about with the new PIDs) sorry Les! Was tryin to log the new PIDs without the csp5.
    07 5.9 4x4, Fully Built SunCoast, II 64/80 Silver Bullet, ARPs, Snow Perf Water/Meth Inj., Fass 150 Titanium, K&N Intake, BD Elbow, CC Tunnel Ram, Own & Others Efi Live Tuning w/CSP5, Glow Shift Max Tow Gauges, 4" Turbo back w/ Axle Dump, 35's, and good Ol Ranch Hands.

    Under Construction:
    2003 Chevy 1500 Z71, w/P-Pumped 5.9 Common Rail, NV4500, South Bend DD, 200Hp Inj.........currently saving greenbacks for more parts.

  4. #4
    Senior Member tylerltr450's Avatar
    Join Date
    Aug 2014
    Posts
    150

    Default

    Don't worry my truck does that with the csp5 tune i wrote also. If you want to send me your tune to look at ill look at. ( I'm not a pro but i have learned a bunch ).

    I have gauges for almost everything important in my truck so I can look at them while driving and let you know what the gauges are reading. I don't have a pump so I can't help you there.
    2006 Cummins Red, Auto to Nv5600, SBC 3600, Traction Bars, Visor, Running Lights, S&B Intake, ATS intake horn, EFI Live, Borg Warner S363 Turbo, Industrial Injection Dragon Fly Injectors.

  5. #5
    Junior Member
    Join Date
    Oct 2014
    Posts
    17

    Default

    What's your email. My switch ran fine without the pump lol. I put the pump on and holy crap the smoke. PM me your email.
    07 5.9 4x4, Fully Built SunCoast, II 64/80 Silver Bullet, ARPs, Snow Perf Water/Meth Inj., Fass 150 Titanium, K&N Intake, BD Elbow, CC Tunnel Ram, Own & Others Efi Live Tuning w/CSP5, Glow Shift Max Tow Gauges, 4" Turbo back w/ Axle Dump, 35's, and good Ol Ranch Hands.

    Under Construction:
    2003 Chevy 1500 Z71, w/P-Pumped 5.9 Common Rail, NV4500, South Bend DD, 200Hp Inj.........currently saving greenbacks for more parts.

  6. #6
    Senior Member tylerltr450's Avatar
    Join Date
    Aug 2014
    Posts
    150

    Default

    pm sent.
    2006 Cummins Red, Auto to Nv5600, SBC 3600, Traction Bars, Visor, Running Lights, S&B Intake, ATS intake horn, EFI Live, Borg Warner S363 Turbo, Industrial Injection Dragon Fly Injectors.

Similar Threads

  1. Lift pump failure!
    By cumminsDK in forum General (Diesel)
    Replies: 0
    Last Post: June 30th, 2013, 01:56 AM
  2. Time For Lift Pump???
    By SmokeSmacked02 in forum Duramax LLY
    Replies: 12
    Last Post: November 5th, 2012, 05:19 PM
  3. Lift pump and injection pump NEED HELP
    By motormadness798 in forum Duramax LB7
    Replies: 17
    Last Post: March 7th, 2012, 10:34 AM
  4. Replies: 1
    Last Post: December 9th, 2008, 01:20 AM
  5. Who on here makes the PPE lift pump install kit i have been hearing about
    By JOKERGERM in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 3
    Last Post: October 17th, 2008, 12:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •