Results 1 to 10 of 10

Thread: EFI Live - RPE Tuning first project

  1. #1
    Junior Member
    Join Date
    Mar 2015
    Posts
    19

    Thumbs up EFI Live - RPE Tuning first project

    Hello fellow enthusiasts/ tuners,

    We are a automotive business in Bathurst, Australia and this is our first EFI Live tune.

    This car is not stock, which adds to the complexity and I would like your input on some issues we have encountered.

    The car is an HSV VE Senator with an LS2 engine. This engine has full exhaust, extractors, cams (don’t know the specs) and a cold air intake.

    I’ve managed to plug into the ecu, clear codes, do some dataloging and download the base file that was on the ECU.

    I would like to ask for your help on the following issues:
    1 – Is the file attached a stock LS2 file?HSV SENATOR LS2 MAFLESS BASE TUNE.ctz
    2 – The car seems to have lost the MAF sensor and the IAT sensor along with it – we are having two error codes from that and they are nowhere on the engine
    o Is this an issue? The car seems to drive fine apart from being substantially lean on idle, causing it unstable idle.
    o Should We do something on the tune to say that the car is only running off the MAP sensor?
    o Should we install/connect an IAT sensor to the car? Currently the sensor is reading -40C which might me interfering with fueling and ignition
    3 – The throttle position with the throttle closed is currently around 22%. Is this normal?
    4 – We tried to do a baseline run on the dyno using third gear but have run into a sort of ignition cut along the way around 4000 rpm. This didn’t happen on the street
    5 – We are having an ABS sensor error. Can the EFI Live do something about this?
    6 – If I wish to make some tuning changes like putting more fuel on the idle sites, should I do full flash or only cal flash?

    Kind Regards,
    Paulo @ RPE

  2. #2
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,781

    Default

    A few quick tips.
    Yes you MUST get the IAT sensor working, others may chime in here but I think you need a relocation wiring kit for that engine. Get that sorted first then others things in your list might change for the better.
    Cal flash is the only thing needed for tuning changes.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  3. #3
    Junior Member
    Join Date
    Mar 2015
    Posts
    19

    Default #2

    Thanks, that has been very helpful.

    So I've connected a GM IAT sensor and its reading just fine now.

    However, the car still fails on the higher gears. For example, in second gear it pulls to redline just fine, 3rd gear cuts at 4500rpm and 4th gear cuts at around 3500rpm. It seems that the cut is speed related so Im wondering if a bad speed sensor can cause this sort of "failsafe"? I can get no speed sensor on the flashscan dashboard...?

    I have an ABS fault on the dash and can't turn off the stability control...Maybe / Hopefully this is all related to a faulty speed sensor?

    I will try to do a Cal flash with minor modifications to the idle area and see if its all good.

    Here is a log I made with of this dyno runs maybe someone can see something wrong?
    Log_Peter - Orange Motor Group_CWT13B_0002.efi

    BTW car did 307 Whp on second gear on a dyno dynamics. I believe this is not good for the mods it has...we will see. AFRs are spot on though.

    Regards,
    Paulo @ RPE

  4. #4
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,785

    Default

    The log shows you're getting a MAF DTC (P0102), this means the ECM understands to ignore the MAF and to use VE only...

    this means you may have to correct the VE using the VVE procedure...

    Quote Originally Posted by joecar
    Links for easy reference:
    E38 VVE Setup Guide
    Virtual VE Tutorial

    Also, you will need to log ETCTP rather than TP.

  5. #5
    Junior Member
    Join Date
    Mar 2015
    Posts
    19

    Default

    Quick update:

    I have sorted the speed related problem - issue with the magnetic suspension - goes away when unplugged.

    I have the IAT sorted as well and reading fine

    I want to improve idle quality and stability, what should I focus on? Its currently idling very lean and that makes it unstable.
    I've read about drilling a hole in the TB plate to improve idle but that seems a bit like a bandaid.
    Idle target is 750 / 800 rpm - should I increase it a bit for stability?

    Thanks for your help, those two documents were spot on!

    Paulo

  6. #6
    Junior Member
    Join Date
    Mar 2015
    Posts
    19

    Default Some progress

    Hello everyone,

    So I've been able to flash the ECU so the gates are open!

    I checked my current calibration (from another tuner -dont know who)

    I have some questions that I hope you can help with:
    Logging
    I can't find the ETCTP Pid you talk about. My throttle goes 18%-88%
    How do I log STFT?

    TuningHSV SENATOR LS2 Ready2Tune.ctz
    My VVE Table (8101 correct?) doesn't look too good...can you please take a look in the tune file? I think he was compensating for it via commanded PE AFRs... because those make little sense
    Is the B0146 table a sort of engine temperature compensation?
    If I want to enrich Idle should I just alter the idle zones on the VVE Map?
    Does EFI live allow for transmission tuning on this ECU/car?

    Many thanks,
    Paulo

  7. #7
    Junior Member
    Join Date
    Mar 2015
    Posts
    19

    Default

    So I've finished tuning this car. All went well and customer was happy.

    Just wanted to thank you for all the help.

    The only issue that wasn't quite perfect was idle. It was a litle rought and made the car vibrate a little. Is it possible to have a richer idle? Does this mean I will lose closed loop at idle?

    Thanks again!

  8. #8
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,785

    Default

    I'm sorry I did not get to your post sooner.


    VVE looks ok (tuned from 1800-5600).

    PE seems a bit low at EQR 1.125, but you compensated with VVE (and sometimes you have no alternative), so it is ok

    ( for NA petrol, set PE to EQR 1.175 )

    PE enable is at 4% TP, this is too free/easy... should be something similar to 2002 F-car.

    Gen4 is not my forte, I'm learning as I go.

  9. #9
    Junior Member
    Join Date
    Mar 2015
    Posts
    19

    Default

    Thanks joecar!

    Couldn't quite understand what you meant with the PE enable...

    Any input on idle AFR?

  10. #10
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,785

    Default

    PE Enable is B0156.

Similar Threads

  1. Replies: 7
    Last Post: June 1st, 2012, 03:26 PM
  2. EFI Live Tuning In Sweden
    By Roscoe Pico Train in forum Gen IV V8 Specific
    Replies: 1
    Last Post: February 25th, 2010, 02:28 PM
  3. NEED HELP TUNING (just got my efi live!)
    By dubya in forum Duramax LB7
    Replies: 0
    Last Post: February 12th, 2010, 08:21 AM
  4. 01 tuning....i have efi live...
    By ZL1Killa in forum General (Petrol, Gas, Ethanol)
    Replies: 3
    Last Post: September 24th, 2005, 07:25 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •