Results 1 to 5 of 5

Thread: Help dreaded P0101 MAF

  1. #1
    New Member
    Join Date
    Nov 2015
    Posts
    3

    Default Help dreaded P0101 MAF

    Hey guys, new to this forum, but a longtime member and Admin on some of the manufacturer specific forums. I will try to be as specific and detailed as possible without cluttering things up. Here goes:

    Car was stock and fitted with high flow cats and ran fine. Car was later fitted with catless downpipes and tuned and also ran fine for at least 2 weeks. Tune was re-tweaked and a few days later I noticed some issues while at track of the car losing power at WOT redline. Did some trial and error testing and discovered P0101 MAF out of range.

    Scenario:

    From dead stop, WOT, the car will throw DTC P0101 at the 3/4 shift, once it hits, the car loses power and I can no longer accelerate. However if I reset the gas pedal by removing my foot for a split second, I can continue accelerating again, so its almost as if the error resets itself with a blip of the pedal. The error only shows up under "CONSTANT" WOT at the 3/4 shift, sometimes the 4/5 shift, but always near redline. If I start my WOT run in 3rd gear there are ZERO issues I can accelerate nicely. This kind of leads me to believe the error is "time" related and the car needs to be under WOT for "X" seconds. Sadly I cant test the theory in higher gears bc I am unable to run WOT in 4th 5th 6th for "X" seconds due to traffic. The car has 2 MAF sensors, both sensors are working properly, the MAP sensor is also working properly so the problem is NOT MAF or MAP, this is 100% confirmed. This AM I plugged the scan tool in and did some recording. I am able to see where the car falls off, sadly I dont know how to interpret the data to make the proper judgement.

    Attached is a copy of the live data. Frame 2 is still OK, but in frame 3 you can see changes in the yellow areas, MAF, boost and relative throttle all drop, even though my foot was still floored and the throttle position was still WOT. Frame 3 was taken a split second BEFORE the DTC was triggered.

    Do you guys say boost leak, bad TPS?

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	MAF.jpg 
Views:	134 
Size:	463.1 KB 
ID:	19034  
    Last edited by mrpa1999; November 18th, 2015 at 04:50 AM.

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,192

    Default

    It's hard to say without a log file.

    P0101 needs to be diagnosed... see here: http://www.gearchatter.com/viewtopic9070.php

    You did not say which year/model/vehicle...?

  3. #3
    Diesel Forum Support Site Admin
    Join Date
    Nov 2005
    Posts
    1,758

    Default

    Quote Originally Posted by joecar View Post
    It's hard to say without a log file.

    P0101 needs to be diagnosed... see here: http://www.gearchatter.com/viewtopic9070.php

    You did not say which year/model/vehicle...?
    X 2 on what Joe says.

  4. #4
    New Member
    Join Date
    Nov 2015
    Posts
    3

    Default

    I did some more testing and discovered, the P0101 has nothing to do with WOT, redline or boost. I believe its all time related.

    I put the car in 4th gear doing like 20mph and floored it, shifted to 5th and by the time i got to 4k rpm the P0101 hit again and the car shut down. So I believe that anytime the car is WOT, approx 7 seconds later the P0101 will hit and cut power. This only happens with a pedal floored and once the error hits, I can correct it by simply blipping the gas pedal. Once I do that I have another 7 seconds of full throttle.

    My guess is something is wrong with the WOT signal, TPS, etc. Going back about 1 month ago I had a Sprint booster DBW hooked up and removed it outright after tuning the car. Perhaps the pedal booster messed the sensors up or somehow a bad signal got programmed into the ECU tune since the car was dyno tuned with the module hooked up, but turned off. Regardless of being off the signals still went thru the module though..

  5. #5
    Lifetime Member
    Join Date
    Aug 2013
    Posts
    717

    Default

    What type of engine is this?

Similar Threads

  1. maf p0101
    By harleyd33 in forum Duramax LB7
    Replies: 5
    Last Post: April 5th, 2011, 02:23 PM
  2. P0101 - MAF out of range keeps setting - VE tune
    By Boost in forum Gen III V8 Specific
    Replies: 4
    Last Post: October 29th, 2010, 12:09 PM
  3. P0101 ...wanted delay in MAF reaction
    By ar99kid in forum Gen III V8 Specific
    Replies: 3
    Last Post: December 22nd, 2009, 11:12 PM
  4. MAF p0101 after installing some parts
    By ALRAJHI in forum General (Petrol, Gas, Ethanol)
    Replies: 1
    Last Post: April 11th, 2007, 05:06 AM
  5. p0101 maf code and a drop out in vacuum
    By madprof01 in forum General (Petrol, Gas, Ethanol)
    Replies: 4
    Last Post: September 18th, 2005, 02:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •