Results 1 to 2 of 2

Thread: "ECM not detected"

  1. #1
    New Member
    Join Date
    Jun 2016

    Default "ECM not detected"

    Trying to do some troubleshooting on one of my vehicles. It's a 2010 Yukon Denali. I believe it's an E38 ECM.

    I'm using 7.5 software and Flashscan V1.

    I've tried every ECM on the list and I still get "ECM not detected"

    I tried hooking up to my other truck and it connects fine. (01 Chevrolet, diesel, LB7)

    I also have a Bluetooth OBD2 adapter to use the Torque App on my phone. This connects just fine to the Yukon.

    I've tried uninstalling and re-installing a new copy of the 7.5 Software.

    What else can I try?

    Is my software/cable too old to connect to a 2010?


  2. #2
    EFILive Reseller wait4me's Avatar
    Join Date
    Aug 2004


    Hi, The V1 unit will not support Can Vehicles. Only VPW.
    So, it is not compatible with your new truck.
    There is a list of V1 vehicle support on the main page.

    You would need a v2 unit as it supports all of the vehicles.
    "If you can leave a black mark on the pavement, from the exit of one corner to the braking point of the next one, you have enough horsepower."

Similar Threads

  1. "File Sys FULL!" followed by "ERROR: $0520"
    By Sushisan in forum AutoCal
    Replies: 2
    Last Post: April 24th, 2012, 06:35 AM
  2. Replies: 2
    Last Post: December 26th, 2011, 08:44 AM
  3. Replies: 3
    Last Post: March 6th, 2011, 02:12 PM
  4. EFILive "Classic"/"Legacy"/"Historic"?
    By emarkay in forum FlashScan V2
    Replies: 6
    Last Post: November 2nd, 2008, 02:48 AM
  5. "PCM is in an Unkown State" & "Reflash Failed"
    By foxySS in forum General (Petrol, Gas, Ethanol)
    Replies: 5
    Last Post: September 8th, 2006, 12:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts