Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Cm 2100 a no communiction after flashing csp5

  1. #1
    Senior Member
    Join Date
    May 2009
    Posts
    195

    Default Cm 2100 a no communiction after flashing csp5

    I read a file from a 2008 cm2100 ECM and converted the file to csp5 did some editing and flashed the file in. After installing the csp5 switch I proceeded to take a test drive but no go. So far I have checked the files a second time to ensure correct VIN and that both v7.5 and v8 said "ok to flash". I have unhooked the batteries and tried but still no communication. Snap-on scanner reveals no comms with ECM and several other modules with ecm comms dtcs. I have checked power and ground to to the ECM on c2 pins, 45,49,50,60 for 12v and pins 47,48,57 for ground. Also checked can + and can - circuits between ECM and TIPM all checks good. Any other ideas and also can I get the VIN License replaced if we end up with a bad ECM that needs replaced?

    thanks
    Trent

  2. #2
    Lifetime Member Move'n Up's Avatar
    Join Date
    Oct 2015
    Posts
    239

    Default

    I assume you did the RSA patch and also that when you flashed the ECM it completed successfully?
    2006 Ram 2500 4x4, 5.9 CTD, Laramie, QC
    Fully Built 48RE, Billet Flex Plate, Triple Disc TC, 62/65 HE351cw
    2017 Corvette 3LZ Z06 M7 with Z07 Package

  3. #3
    Senior Member
    Join Date
    May 2009
    Posts
    195

    Default

    Quote Originally Posted by Move'n Up View Post
    I assume you did the RSA patch and also that when you flashed the ECM it completed successfully?
    I did not do the RSA patch as it did not have the late bootloader revision that will only allow a stock file to be flashed. Am I missing something in a recent update that requires doing the RSA patch even on a 502 bootloader? also yes it did complete successfully.

  4. #4
    Lifetime Member Move'n Up's Avatar
    Join Date
    Oct 2015
    Posts
    239

    Default

    Quote Originally Posted by cumminsDK View Post
    I did not do the RSA patch as it did not have the late bootloader revision that will only allow a stock file to be flashed. Am I missing something in a recent update that requires doing the RSA patch even on a 502 bootloader? also yes it did complete successfully.
    Great and no need to RSA Patch if your OS version isn't one of the later ones that require it. Have you tried to communicate and Flash with just the V2 alone, not via Computer?
    2006 Ram 2500 4x4, 5.9 CTD, Laramie, QC
    Fully Built 48RE, Billet Flex Plate, Triple Disc TC, 62/65 HE351cw
    2017 Corvette 3LZ Z06 M7 with Z07 Package

  5. #5
    Lifetime Member Move'n Up's Avatar
    Join Date
    Oct 2015
    Posts
    239

    Default

    BTW - Try it WITHOUT the CSP5 switch connected
    2006 Ram 2500 4x4, 5.9 CTD, Laramie, QC
    Fully Built 48RE, Billet Flex Plate, Triple Disc TC, 62/65 HE351cw
    2017 Corvette 3LZ Z06 M7 with Z07 Package

  6. #6
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,802

    Default

    Trent any chance the tune that was in the ECM was already modified by something like Smarty?
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  7. #7
    Senior Member
    Join Date
    May 2009
    Posts
    195

    Default

    Yes it most likely was modified with a smarty I didn't catch it and the V7 .5 software actually said under the B9999 that it was incomplete and do not flash but only on the file I removed from the ECM once I converted it to CSP five it no longer said anything down there and I didn't catch it! Rookie mistake I guess but I was told the truck was programmed currently using EFIlive so I assumed if the file worked being flashed in previously that it would also work for me and when I originally went back to look to see what both software versions said post failure about the file it was only in the CSP five file that I had built and I never did look at the file that was originally in the truck until about 30 minutes ago i've already put another ECM in licensed it and it just finished the flash and were good to go! Thanks for all the help!

  8. #8
    Junior Member
    Join Date
    Mar 2016
    Posts
    12

    Default

    Seems that smarty can cause some problems it must change the file structure in some way.

  9. #9
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,802

    Default

    The exact problem with the Smarty tuned files is they are not updating a very important table in the ECM that specifies how much of the flash memory is populated, they tend to add some code in to the ECM after the factory data (not sure why), but EFILive is not aware of this additional code because the flash layout table remains stock. End result is a bricked ECM
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  10. #10
    Lifetime Member Cougar281's Avatar
    Join Date
    Jan 2006
    Posts
    820

    Default

    Quote Originally Posted by GMPX View Post
    The exact problem with the Smarty tuned files is they are not updating a very important table in the ECM that specifies how much of the flash memory is populated, they tend to add some code in to the ECM after the factory data (not sure why), but EFILive is not aware of this additional code because the flash layout table remains stock. End result is a bricked ECM
    Dumb question... since you know what the smarty is doing that is causing the bricked ECMs, wouldn't it be possible for EFILive look for it and either fix it in the read tune, or put up a big warning to not flash it and to get a clean stock tune?

    Sent from my 0PJA2 using Tapatalk

Page 1 of 2 12 LastLast

Similar Threads

  1. Csp5 for 6.7L?
    By billybob in forum Cummins 6.7L
    Replies: 42
    Last Post: November 17th, 2014, 03:42 PM
  2. 6.7 csp5 help
    By lmhenderson93 in forum Cummins 6.7L
    Replies: 1
    Last Post: October 3rd, 2013, 09:38 AM
  3. Csp5
    By easymon in forum Cummins 5.9L
    Replies: 5
    Last Post: July 21st, 2013, 02:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •