Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48

Thread: Question about hooking up AEM gauge output to V2

  1. #21
    Lifetime Member
    Join Date
    Aug 2007
    Posts
    222

    Default

    Wow, I guess I remember seeing it on the V2 from my serial days when I was running a lc1 . I would have chased that forever. Thanks man!!! I will select those pids and do a log and see what happens. Appreciate you as always! !!
    00 GMC,LQ4, Jarrett Faggart pistons, callies rods, Ebay studs, LS9 gaskets, 317's, KBRacing KIT, PT76/75, treadstone intercooler,Eboost2, dual walbro, FIC 75lb, br7ef, Trutrac, Shaftmasters Shaft, 3.5" DP w/4" magnaflow dumped, turbo blanket, Circle D 3200, Jake's built 4l80w/brake, hydroboost, EFILive v2,Lunati dual springs,222/226 cam, cal-tracs, QA1 front shocks, Street/strip Bogarts,Drum swap, Alky-control,MSD8733 936 HP to the tire DD.

  2. #22
    Lifetime Member
    Join Date
    Aug 2007
    Posts
    222

    Default

    Error report generated by EFILive at 05:34:22 on Oct 29, 2016

    Error code: ERR_CONFIG/92
    C:\Users\st0114\Documents\EFILive\V7.5\User Configuration\calc_pids.txt(14): Units LAM not found. .

    EFILive Version: 7.5.8 (Build 311)

    Platform: Windows NT
    Version: 6.1 (build 7601)
    Processor type: Pentium 1648MHz

    Directories
    Temporary Cache: C:\Users\st0114\Documents\EFILive\V7.5\Temporary cache
    Logged Data: C:\Users\st0114\Documents\EFILive\V7.5\Logged data
    Customers: C:\Users\st0114\Documents\EFILive\V7.5\Customers
    Configuration: C:\Program Files (x86)\EFILive\V7.5\Configuration
    Exported Data: C:\Users\st0114\Documents\EFILive\V7.5\Exported data
    Images: C:\Users\st0114\Documents\EFILive\V7.5\Images
    Sounds: C:\Users\st0114\Documents\EFILive\V7.5\Sounds
    Maps: C:\Users\st0114\Documents\EFILive\V7.5\Maps
    Pids: C:\Users\st0114\Documents\EFILive\V7.5\PIDs
    Virtual Dash: C:\Users\st0114\Documents\EFILive\V7.5\VDash
    Print Reports: C:\Users\st0114\Documents\EFILive\V7.5\Print reports
    Bug Reports: C:\Users\st0114\Documents\EFILive\V7.5\Bug reports

    Connected: No

    Auto connect: No
    Scan OBDII info: No

    Error retries: 1
    Retry delay: 10
    Message throttle: 0

    Most recently used VIN: 1GTEC14V5YZxxxxxx (Note: 1)

    PCM information
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Unknown: Unknown
    Stream-Slow scan mode: Unknown
    Stream-Fast scan mode: Unknown
    Maximum dynamic packets: Unknown

    Most recent communication with vehicle:

    Report ID: 138081 (Note: 2)

    Notes:
    (1) The VIN sequence number is not required for this report and for your privacy it is NOT included in this report.

    (2)The report ID is a checksum of the report text and is used to verify the integrity of the report.
    00 GMC,LQ4, Jarrett Faggart pistons, callies rods, Ebay studs, LS9 gaskets, 317's, KBRacing KIT, PT76/75, treadstone intercooler,Eboost2, dual walbro, FIC 75lb, br7ef, Trutrac, Shaftmasters Shaft, 3.5" DP w/4" magnaflow dumped, turbo blanket, Circle D 3200, Jake's built 4l80w/brake, hydroboost, EFILive v2,Lunati dual springs,222/226 cam, cal-tracs, QA1 front shocks, Street/strip Bogarts,Drum swap, Alky-control,MSD8733 936 HP to the tire DD.

  3. #23
    Lifetime Member
    Join Date
    Aug 2007
    Posts
    222

    Default

    I uninstalled and reinstalled the sept. beta release of 7.5 and 8 . I changed the user config calc_pids to

    # ================================================== ============================
    # File details
    # ------------
    #
    # This section defines various details about the file format.

    *FILE

    #Parameter Value Description
    #---------- ---------------- ---------------------------------------------------
    VERSION 7.1.1 File version
    DECSEP . Decimal separator used in this file


    # calc_pids AEM 30-4900
    # ================================================== ============================
    # Units
    # -------------------
    # See sae_generic.txt for more information on the *UNITS section

    *UNITS

    #Code System Abbr Description
    #-------- ---------- -------- -------------------------------------------------------------
    None None "" "No units"
    LAM None "LAM" "Lambda"
    EQR None "EQR" "Equivalence Ratio (1/Lambda)"
    BEN None "BEN" "BEN factor"

    # ================================================== ============================
    # Add slot definitions here
    # --------------------------------
    # See sae_generic.txt for more information on "SLOT" formats
    #
    #Units Low High Fmt Expression
    #------------ ------------- ------------- ---- --------------------------------------------------------------

    *CLC-00-030AF


    8.0 18.0 .2 "{EXT.AD1}*2+10"
    LAM 0.5 1.5 .3 "{CALC.AEM1.AFR}/14.638"
    EQR 0.5 1.5 .3 "1/{CALC.AEM1.LAM}"
    BEN 0.5 1.5 .3 "{CALC.AEM1.LAM}*{GM.EQIVRATIO}"
    # ================================================== ============================
    *PRN - Parameter Reference Numbers
    # --------------------------------
    # See sae_generic.txt for more information on the *PRN section
    #
    #Code PRN SLOT Units System Description
    #------------------------- ---- ------------ ---------------- ---------------- ------------------------------------------

    CALC.AEM1 F030 CLC-00-030 "AFR,LAM,EQR,BEN" Wideband "AEM 30-4900 AFR,LAM,EQR,BEN"


    # leave at least 2 blank lines below this one (i.e. before end of file)

    Then I got this error code !


    Error code: ERR_CONFIG/92

    C:\Users\Owner\Documents\EFILive\V7.5\User Configuration\calc_pids.txt(40): Units 8.0 not found. .
    00 GMC,LQ4, Jarrett Faggart pistons, callies rods, Ebay studs, LS9 gaskets, 317's, KBRacing KIT, PT76/75, treadstone intercooler,Eboost2, dual walbro, FIC 75lb, br7ef, Trutrac, Shaftmasters Shaft, 3.5" DP w/4" magnaflow dumped, turbo blanket, Circle D 3200, Jake's built 4l80w/brake, hydroboost, EFILive v2,Lunati dual springs,222/226 cam, cal-tracs, QA1 front shocks, Street/strip Bogarts,Drum swap, Alky-control,MSD8733 936 HP to the tire DD.

  4. #24
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,189

    Default

    Quote Originally Posted by Slowrc View Post
    Error report generated by EFILive at 05:34:22 on Oct 29, 2016

    Error code: ERR_CONFIG/92
    C:\Users\st0114\Documents\EFILive\V7.5\User Configuration\calc_pids.txt(14): Units LAM not found. .

    ...
    Quote Originally Posted by Slowrc View Post
    ...

    Then I got this error code !


    Error code: ERR_CONFIG/92

    C:\Users\Owner\Documents\EFILive\V7.5\User Configuration\calc_pids.txt(40): Units 8.0 not found. .
    *CLC-00-030AF


    8.0 18.0 .2 "{EXT.AD1}*2+10"
    LAM 0.5 1.5 .3 "{CALC.AEM1.AFR}/14.638"
    EQR 0.5 1.5 .3 "1/{CALC.AEM1.LAM}"
    BEN 0.5 1.5 .3 "{CALC.AEM1.LAM}*{GM.EQIVRATIO}"
    Your CLC-00-030 ^ is misformed...

    It should read like this:
    Code:
    *CLC-00-030
    AFR        8.0      18.0    .2  "{EXT.AD1}*2+10"
    LAM        0.5       1.5    .3  "{CALC.AEM1.AFR}/14.638"
    EQR        0.5       1.5    .3  "1/{CALC.AEM1.LAM}"
    BEN        0.5       1.5    .3  "{CALC.AEM1.LAM}*{GM.EQIVRATIO}"

  5. #25
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,189

    Default

    I edited the calc_pids.txt for the AEM 30-4900, see attached.
    Attached Files Attached Files

  6. #26
    Lifetime Member
    Join Date
    Aug 2007
    Posts
    222

    Default

    Thanks!!!
    00 GMC,LQ4, Jarrett Faggart pistons, callies rods, Ebay studs, LS9 gaskets, 317's, KBRacing KIT, PT76/75, treadstone intercooler,Eboost2, dual walbro, FIC 75lb, br7ef, Trutrac, Shaftmasters Shaft, 3.5" DP w/4" magnaflow dumped, turbo blanket, Circle D 3200, Jake's built 4l80w/brake, hydroboost, EFILive v2,Lunati dual springs,222/226 cam, cal-tracs, QA1 front shocks, Street/strip Bogarts,Drum swap, Alky-control,MSD8733 936 HP to the tire DD.

  7. #27
    Lifetime Member
    Join Date
    Aug 2007
    Posts
    222

    Default Look at these differences please Joecar

    Quote Originally Posted by joecar View Post
    Yes, connect the analog signal to AD1+ and the return to AD1-

    you will then have to look in the AEM user manual to see how they map AFR to 0-5V:

    ( see attached, is this the correct user manual...? )



    There is not a CALC.AFR and CALC.BEN pids for this...

    so we would create one...

    in calc_pids.txt:

    define these Units:


    Code:
    LAM   None        "LAM"     "Lambda"
    EQR   None        "EQR"     "Equivalence Ratio (i.e. 1/Lambda)"
    BEN   None        "BEN"     "BEN factor"
    


    and the slot definition would go like this:

    Code:
    *CLC-00-030
    AFR         8.0       18.0        .2   "{EXT.AD1}*2.375+7.3125"
    LAM         0.5        1.5        .3   "{CALC.AEM1.AFR}/14.7"
    EQR         0.5        1.5        .3   "1/{CALC.AEM1.LAM}"
    BEN         0.5        1.5        .3   "{CALC.AEM.LAM1}*{GM.EQIVRATIO}"
    question: what does AEM assume gasoline stoich AFR to be (14.7)...?

    and the PRN would go like this:

    Code:
    CALC.AEM1   F030  CLC-00-030  "AFR,LAM,EQR,BEN"      Wideband     "AEM 30-4900 AFR,LAM,EQR,BEN"
    
    I have not tested it, but if there's any problems I'll help you.


    You would log these pids:
    - GM.EQIVRATIO
    - EXT.AD1
    - CALC.AEM1

    the BEN pid would be CALC.AEM1.BEN

    to view AFR, Lambda or EQR, you would chart CALC.AEM1.AFR, CALC.AEM1.LAM, CALC.AEM1.EQR.
    But this is listed later in the thread...

    *CLC-00-030
    AFR 8.0 18.0 .2 "{EXT.AD1}*2+10"
    LAM 0.5 1.5 .3 "{CALC.AEM1.AFR}/14.638"
    EQR 0.5 1.5 .3 "1/{CALC.AEM1.LAM}"
    BEN 0.5 1.5 .3 "{CALC.AEM1.LAM}*{GM.EQIVRATIO}"
    Last edited by joecar; October 31st, 2016 at 07:51 AM. Reason: fixed html formatting
    00 GMC,LQ4, Jarrett Faggart pistons, callies rods, Ebay studs, LS9 gaskets, 317's, KBRacing KIT, PT76/75, treadstone intercooler,Eboost2, dual walbro, FIC 75lb, br7ef, Trutrac, Shaftmasters Shaft, 3.5" DP w/4" magnaflow dumped, turbo blanket, Circle D 3200, Jake's built 4l80w/brake, hydroboost, EFILive v2,Lunati dual springs,222/226 cam, cal-tracs, QA1 front shocks, Street/strip Bogarts,Drum swap, Alky-control,MSD8733 936 HP to the tire DD.

  8. #28
    Lifetime Member
    Join Date
    Aug 2007
    Posts
    222

    Default

    I mention the above because I used the latter one and my gauge and scan tool read almost a point off now.
    00 GMC,LQ4, Jarrett Faggart pistons, callies rods, Ebay studs, LS9 gaskets, 317's, KBRacing KIT, PT76/75, treadstone intercooler,Eboost2, dual walbro, FIC 75lb, br7ef, Trutrac, Shaftmasters Shaft, 3.5" DP w/4" magnaflow dumped, turbo blanket, Circle D 3200, Jake's built 4l80w/brake, hydroboost, EFILive v2,Lunati dual springs,222/226 cam, cal-tracs, QA1 front shocks, Street/strip Bogarts,Drum swap, Alky-control,MSD8733 936 HP to the tire DD.

  9. #29
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,189

    Default

    Which AEM do you have...?

    Does your user manual show and equation relating V and AFR...?

    Or a table of voltages and AFR...?
    Last edited by joecar; October 31st, 2016 at 07:54 AM.

  10. #30
    Junior Member
    Join Date
    Jun 2016
    Posts
    23

    Default

    Quote Originally Posted by joecar View Post
    From the AEM data you posted:
    AFR 10 --> 0V --> lambda 0.683
    AFR 19.98 --> 4.99V --> lambda 1.365

    Find AFR as a function of V:
    (AFR-10)/(V-0) = (19.98-10)/(4.99-0) = 2
    AFR = V*2+10

    This is the same as CALC.AFR_PLX1, so you can use that pid... but the corresponding BEN pid CALC.BEN_PLX1 uses GM.AFR instead of GM.EQIVRATIO...

    so if you wanted to use GM.EQIVRATIO (which I would recommend), follow along (you already know algebra):

    0V --> lambda 0.683
    4.99V --> lambda 1.365

    Find lambda as function of V:
    (lambda-0.683)/(V-0) = (1.365-0.683)/(4.99-0) = 0.1367
    lambda = V*0.1367+0.683

    We now want to find the assumed stoich AFR...

    Solve V for lambda = 1:
    1 = V*0.1367+0.683
    V = (1-0.683)/0.1367 = 2.319V

    Find AFR for lambda = 1 (i.e. for V = 2.319V):
    AFR = 2.319*2+10 = 14.638

    so AEM device assumes stoich to be 14.638.


    So now modify CLC-00-030 from the above calc_pids.txt to read as follows:
    Code:
    *CLC-00-030
    AFR                8.0          18.0       .2  "{EXT.AD1}*2+10"
    LAM                0.5           1.5       .3  "{CALC.AEM1.AFR}/14.638"
    EQR                0.5           1.5       .3  "1/{CALC.AEM1.LAM}"
    BEN                0.5           1.5       .3  "{CALC.AEM1.LAM}*{GM.EQIVRATIO}"
    Thank you Joe. Things have been busy lately, so haven't had time to test yet. I got an understanding of how the calculation's work after following https://forum.efilive.com/showthread...g-autove-wrong

    Hopefully I will be able to do some testing next weekend.


    Sent from my iPhone using Tapatalk

Page 3 of 5 FirstFirst 12345 LastLast

Similar Threads

  1. AEM X-Series OBDII Wideband UEGO AFR Sensor Controller Gauge
    By Gelf VXR in forum General (Petrol, Gas, Ethanol)
    Replies: 206
    Last Post: July 24th, 2017, 07:58 AM
  2. Aem failsafe gauge not serial
    By Slowrc in forum General
    Replies: 25
    Last Post: August 12th, 2014, 11:23 AM
  3. Question on Hooking LC1 up on 02 Camaro
    By gpr in forum Gen III V8 Specific
    Replies: 6
    Last Post: July 10th, 2012, 07:33 AM
  4. 98 to 99 Fuel Segment swap gauge output table
    By AutomagicLS1 in forum Gen III V8 Specific
    Replies: 3
    Last Post: September 27th, 2011, 09:29 AM
  5. AEM Gauge type 6 in 1 WB UEGO controller
    By JET LEE in forum Gen III V8 Specific
    Replies: 10
    Last Post: January 25th, 2007, 08:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •