Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: PLX SM AFR Serial

  1. #11
    Junior Member
    Join Date
    Apr 2009
    Posts
    18

    Default

    Quote Originally Posted by Blacky View Post
    Are you using the latest software available here: https://forum.efilive.com/showthread...se-Candidate-3
    If not I highly recommend updating to it - it has a number of updates to the serial wide band data comms.

    Can you connect up the PLX to FlashScan, and select the FlashScan menu option: F1 Scan Tool -> F2 Data Logging -> F3 Display WO2.

    Use the Backspace key to cycle through the supported wide band controller types until you have selected PLX.
    Use the Enter key to cycle the display data until you can see Lambda and AFR, like this:
    Attachment 21571

    Allow FlashScan to "see" the serial data for 5-10 seconds (the left orange LED should flash periodically to indicate that serial data is being sent/recv).
    Then (without powering down FlashScan) select the option: F1 Scan Tool -> F3 Scan Options -> F4 Save COM Data
    Then using EFILive Explorer, copy the saved file from FlashScan to your PC and send it to me at paul@efilive.com (or attach it to this thread).

    Regards
    Paul
    Hi Paul

    I was going to send you the data. But when I checked with PLX they told me the only reason that might happen is if the internal setting would be CNG. With my PLX a DM6 gauge was missing and i just ordered it yesterday. Let me get the gauge first and make sure its on Gasoline and then i will log again and send you the data. I thought the TTL adapter was faulty so i removed off the connections. When i get the gauge i will solder them back and send you the data.

    Also I'm trying to modulate the same signal internally from a NTK AFRM. What would you need to add it to show on EFI Live Serial data ?

  2. #12
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    8,916

    Default

    Quote Originally Posted by ne0c0de View Post
    Hi Paul

    Also I'm trying to modulate the same signal internally from a NTK AFRM. What would you need to add it to show on EFI Live Serial data ?
    The same type of serial info that you posted for the PLX.

    Regards
    Paul
    Before asking for help, please read this.

  3. #13
    Junior Member
    Join Date
    Apr 2009
    Posts
    18

    Question

    Ok I got the gauge and it is set to AFR. I had an older version of EFI Live and i updated to the one that Paul suggested. Also i noticed there is a STOICH option for PLX so i set that to 14.7 as the PLX manual.

    I constantly get weird lambda readings and they don't change with the AFR on the PLX. I checked all connections and then checked all options and did it again.
    https://drive.google.com/file/d/0Bw-...J0SjIxSFE/view

    For some reason the stoich was set as 0.2 when i updated and that is the COM log USR_0002.bin
    I set it to 14.7 and saved the data as USR_0003.bin


    After i restarted the device and logged again I get AFR correct at times and it jumps to weird values later. What i have found is on the gauge is that it now displays BATTERY VOLTAGE, SENSOR HEALTH and SENSOR RESPONSE TIME.

    Could it be that it is getting other readings on the TX Port ?

    Paul I am emailing the BIN files to your email and hope its sorted out soon.

  4. #14
    Lifetime Member SS2win's Avatar
    Join Date
    Feb 2005
    Posts
    272

    Default

    Are you sure your TTL adapter is working properly?
    ss2win AT classicgm.com
    2001 Camaro SS #2020

    InconTT | REV Springs | M6 | Z06 Clutch | 17" CCW Classics
    425@6lbs | EFILive Custom OS3 | !MAF | SD Tune all the way
    11.73@12x/1.7 on worn out nittos... yaaawn!
    1972 GMC Jimmy "the submarine"
    383SBC | Q-Jet | dublah | locked 1ton | 42 TSL on stazworks | 4iz | Heavy FOotE | too much to list...

    1999 GMC Suburban 2500 (project Escalate)
    7.4 L29 | 4L80E
    | 0411 Swap | 37" Wrangler OZ Military tires on Centerline Wheels | Pop's toy

  5. #15
    Junior Member
    Join Date
    Apr 2009
    Posts
    18

    Default

    Quote Originally Posted by SS2win View Post
    Are you sure your TTL adapter is working properly?
    To make sure, I am going to use a brand new one today. Even the one I used was new.

    Anyway hope that's the issue. I guess there is something different on this GEN IV. The old PLX worked perfect and I was using the same adapter.

  6. #16
    Junior Member
    Join Date
    Apr 2009
    Posts
    18

    Default

    I tried a new one and it still reads 2.55 lambda and 30 + AFR.

    Here is the info from PLX
    The extended information has the addresses and data for each of these values. I don't think it's similar as the old PLX so Paul please take a look for me. It would also help other plx users to obtain the serial data.

  7. #17
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    8,916

    Default

    Quote Originally Posted by ne0c0de View Post
    I tried a new one and it still reads 2.55 lambda and 30 + AFR.

    Here is the info from PLX

    The extended information has the addresses and data for each of these values. I don't think it's similar as the old PLX so Paul please take a look for me. It would also help other plx users to obtain the serial data.
    The trace data you sent to me shows 4 serial devices are connected.
    Device: 00 = wide band
    Device: 18 = volt meter
    Device: 25 = unknown
    Device: 26 = unknown

    FlashScan is only designed/configured to connect to 1 or 2 wide band controllers - the data from the other devices is being interpreted (incorrectly) as wide band data.

    I will update the FlashScan firmware to ignore those other devices, but for now you should only have 1 or 2 wide band controllers connected.

    Regards
    Paul
    Before asking for help, please read this.

  8. #18
    Junior Member
    Join Date
    Apr 2009
    Posts
    18

    Default

    Quote Originally Posted by Blacky View Post
    The trace data you sent to me shows 4 serial devices are connected.
    Device: 00 = wide band
    Device: 18 = volt meter
    Device: 25 = unknown
    Device: 26 = unknown

    FlashScan is only designed/configured to connect to 1 or 2 wide band controllers - the data from the other devices is being interpreted (incorrectly) as wide band data.

    I will update the FlashScan firmware to ignore those other devices, but for now you should only have 1 or 2 wide band controllers connected.

    Regards
    Paul
    Ok so it is different from the old PLX models. I think the other two that it reads is Sensor Health and Sensor Reaction time since other than the wideband and nothing else connected, that is what the gauge reads.

    So i guess i will have to wait for the firmware update to make sure its all working ok.

    Btw, will we have to select a new WIDEBAND from the list of gauges or will it work on the old PLX ?

    Finally, how long will it be approx for the firmware update ?

    Thanks

  9. #19
    Junior Member
    Join Date
    Apr 2009
    Posts
    18

    Default

    Quote Originally Posted by Blacky View Post
    The trace data you sent to me shows 4 serial devices are connected.
    Device: 00 = wide band
    Device: 18 = volt meter
    Device: 25 = unknown
    Device: 26 = unknown

    FlashScan is only designed/configured to connect to 1 or 2 wide band controllers - the data from the other devices is being interpreted (incorrectly) as wide band data.

    I will update the FlashScan firmware to ignore those other devices, but for now you should only have 1 or 2 wide band controllers connected.

    Regards
    Paul
    And currently only one wideband is connected and nothing more.

    Thanks

  10. #20
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    8,916

    Default

    Quote Originally Posted by ne0c0de View Post
    And currently only one wideband is connected and nothing more.

    Thanks
    Ahh, I see. So a single wideband controller sends sensor data as if from 4 different sensors. Nothing has "changed" in the PLX implementation, it is EFILive's implementation of the PLX serial protocol that is a bit naive. It assumes (incorrectly) that only a single sensor data packet will be transmitted from a single wide band controller.

    Depending on the complexity of the fix, it may make it into the next public release due out in a day or two.
    If not, then it will be in the next update. The schedule for that update is not yet decided.

    Regards
    Paul
    Before asking for help, please read this.

Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. PLX SM-AFR Serial upgrade
    By ntae in forum FlashScan V2 BB Logging
    Replies: 116
    Last Post: May 25th, 2017, 07:26 AM
  2. Plx sm-afr v2 serial mods
    By barbermi in forum FlashScan V2
    Replies: 20
    Last Post: April 16th, 2015, 04:56 PM
  3. plx sm-afr serial
    By blazinblue in forum General
    Replies: 4
    Last Post: June 23rd, 2009, 07:29 AM
  4. PLX SM-AFR Serial control not found.
    By aaronr in forum FlashScan V2 BB Logging
    Replies: 4
    Last Post: February 15th, 2009, 07:59 PM
  5. Anyone willing to convert my PLX to serial???
    By exploder in forum General (Petrol, Gas, Ethanol)
    Replies: 9
    Last Post: November 16th, 2008, 03:51 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •