Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: $06FF Checksum Failure

  1. #11
    Member
    Join Date
    Feb 2019
    Posts
    67

    Default

    I know this thread is old but I'm in dire trouble. I am working on a 2010 Chevy 2500 6.0L vin 1GC4KXBG3AF147376 OS:12636005.
    I made a copy of the original tune. Then disabled the downstream O2s in the DTC type n mil. When I did the full flash, at the very end I got the checksum fail $06FF. Now the truck will not start
    Nothing I do allows me to flash the computer and now 7.5 scan won't recognize the E38. There is no checksum fail parameter.
    Where do I find the checksum patch or how do I fix this. Thanks
    Attached Files Attached Files

  2. #12
    Lifetime Member Doc's Avatar
    Join Date
    Oct 2005
    Posts
    738

    Default

    Have you attempted to full flash the original file? It probably has a Diablo tune or what not on it that is causing the issue. Once a tune file has been altered from factory with some can'd tune thing best not to mess with it unless you have THAT software and have permission to do so. Worst case, you have to have your local dealer or equivalent or greater capability flash it back to stock.

    2000 Silverado Full Size 4x4: Forged 6.2, H/C F1R Procharger
    98A4 Z28: 02 PCM H/C Forged 347, 9" Moser 3.73
    V1 V2 99+up RR COS #5 OLSD Dual Stg N20
    www.efialchemy.com
    www.greatamericancarwar.com

  3. #13
    Member
    Join Date
    Feb 2019
    Posts
    67

    Default

    Thanks for answering...yes I did try to flash the original but got the same error sooooo I guess it's to the dealer
    LS3 Manual 6 spd E38 os:12633056
    Texas Speed 1 7/8" headers w/3" exhaust
    Texas Speed cam 229/236 .629/.615 112 LSA
    Hi-Ram intake stock injectors 90mmTB

  4. #14
    Lifetime Member Doc's Avatar
    Join Date
    Oct 2005
    Posts
    738

    Default

    Well, hold on just a min. Pm me.

    2000 Silverado Full Size 4x4: Forged 6.2, H/C F1R Procharger
    98A4 Z28: 02 PCM H/C Forged 347, 9" Moser 3.73
    V1 V2 99+up RR COS #5 OLSD Dual Stg N20
    www.efialchemy.com
    www.greatamericancarwar.com

  5. #15
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    I found this thread using the search, and I think this extra line of code from third party programmers might be the root of the problem I'm experiencing, but I have an older truck with a different PCM(?) so this may not be the place to find the answers I need. I will share the base info with hopes that someone can direct me to the right place?

    2004 Avalanche 2500 (LS1B?) with a hypertech 3 tune that failed to uninstall properly. Truck won't start, I get an invalid checksum error that shows speedometer segment 8. I don't have a stock tune file because it had the hypertech on it when I purchased it.

  6. #16
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,123

    Default

    It is unlikely on the older PCM's this is the problem, but you'd need to post up the Hypertech tune you read out to be sure.


  7. #17
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    Quote Originally Posted by GMPX View Post
    It is unlikely on the older PCM's this is the problem, but you'd need to post up the Hypertech tune you read out to be sure.
    I started a thread here: https://forum.efilive.com/showthread...une-assistance

    When it allows me to upload files I will post it up and hopefully someone can help me out.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Checksum $06FF
    By autronika in forum E39, E80, E82 & E92 SIDI ECM's
    Replies: 11
    Last Post: May 27th, 2019, 01:45 AM
  2. Checksum $06FF
    By autronika in forum E37, E38 & E67 PFI ECM's
    Replies: 2
    Last Post: December 5th, 2016, 10:10 AM
  3. 06FF Checksum Failure on E38 PCM for 06 Z06
    By injected in forum Gen IV V8 Specific
    Replies: 4
    Last Post: April 1st, 2015, 07:58 AM
  4. T43 TCM code $06FF: checksum failure
    By 400ss in forum 6 speed/8 speed RWD/FWD Transmission Tuning (incl T43, T76, T87)
    Replies: 11
    Last Post: August 15th, 2014, 09:26 AM
  5. Replies: 2
    Last Post: July 17th, 2012, 03:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •