Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: What are some things that could cause my truck to not go into open loop?

  1. #1
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default What are some things that could cause my truck to not go into open loop?

    2001 Silverado 2500 6.0L stock work truck

    For a while now I've been noticing knock during hard acceleration. I was thinking my fuel pump was starting to get weak and since I've never changed it since I've owned the truck I went ahead and changed it. Of course the knock is still there so I get out the scanner and notice that it never goes in to open loop even with tps at 99%. What should I look for to remedy this issue. Anyone have any ideas? Thanks

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    Post tune/log files.


    Measure rail pressure (with FPR reference hose disconnected).

    Check PCV plumbing for oil.

  3. #3
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    Here is the tune
    Attached Files Attached Files

  4. #4
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    Logs...?

  5. #5
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    I don't have any logs to post at the moment and I didn't bring my laptop with me today so I will have to get them tomorrow. There is no oil in the PCV tubing and fuel pressure is 68psi with fpr unplugged

  6. #6
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    Shouldn't it be 58 psi...?

  7. #7
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    Hmm, yes. I will investigate this. Could this cause no open loop though? Fuel trims are perfect even with high fuel pressure...

  8. #8
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    Update: I have fixed the fuel pressure problem. I know have 58psi with reference hose disconnected. Truck is going into open loop under acceleration but still has some knock. Air/Fuel ratio stays near stoich. I just need to figure out now how to add more fuel to eliminate the knock.

  9. #9
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    Post log showing knock.

  10. #10
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    I have been pouring through the forums trying to figure out the best way to get my LM-2 connected to the scanner so I can log A/F and have decided that serial connection is the best way to go. I have a serial Molex cable ordered and it should come in one day this week. When I get that figured out and working I will make a log of the truck and post it. Are there any particular PID's you are wanting to see that would help you understand what is going on. Thanks again joecar for your input.

Page 1 of 4 123 ... LastLast

Similar Threads

  1. E38 Open Loop VS Closed Loop - strange issue
    By BLK02WS6 in forum E37, E38 & E67 PFI ECM's
    Replies: 6
    Last Post: June 11th, 2016, 11:47 AM
  2. Replies: 1
    Last Post: April 11th, 2013, 03:28 PM
  3. Open loop or semi open loop still?
    By louis in forum General (Petrol, Gas, Ethanol)
    Replies: 15
    Last Post: October 18th, 2007, 02:46 AM
  4. Semi-Open Loop Vs Just Open Loop
    By BowlingSS in forum Custom Operating Systems
    Replies: 16
    Last Post: April 14th, 2006, 04:25 AM
  5. Truck wont idle during open loop speed density
    By mtnman in forum General (Petrol, Gas, Ethanol)
    Replies: 2
    Last Post: February 23rd, 2006, 05:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •