Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: What are some things that could cause my truck to not go into open loop?

  1. #11
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    We want to see GM.EQIVRATIO and EXT.WO2LAM1 in addition to the usual pids (RPM, TPS, MAF, MAP, LONGFT1/2, SPARKADV, KR, ...).

  2. #12
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default Here is a log without wideband

    Here is a log without wideband. Still waiting on the serial cable for the LM-2. First WOT knock was very audible. There isn't a saw tooth pattern but it does appear that timing is being pulled (although I'm not a pro at reading these logs). What is the GM.EQIVRATIO PID? Thanks again for the input.
    Attached Files Attached Files

  3. #13
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    Also, after looking back and studying the log I noticed the LTFT's adding 9+% WOT and I'm thinking that is probably not normal (not sure). Is this an issue?

  4. #14
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    With steady WOT throttle above 4000 rpm: use MAFFREQ to index the MAF table and bump it up a little in this area.

    With WOT throttle below 4000 rpm: use MAP and RPM to index the VE table and bump it up a little in this area.

  5. #15
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    Reduce pid channel count to 24 (or less) to get faster sampling rate (i.e. better resolution)...

    see "Selected Channels" at bottom of PIDs tab...

    since we're going to use GM.EQIVRATIO for tuning, drop the pid GM.AFR, this will get pid channel count down to 23.

  6. #16
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    Do you have anything (exhaust pipe) banging anywhere (chassis)...?

  7. #17
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    Quote Originally Posted by joecar View Post
    Do you have anything (exhaust pipe) banging anywhere (chassis)...?
    Exhaust is in good condition. There isn't anything banging. It is definitely spark knock that I hear and it logged it when I heard it.

  8. #18
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,804

    Default

    In your log, KR coincides with TP going WOT, and commanded fueling (GM.EQIVRATIO) is only EQR 1.0391... this is way too lean for WOT (so you get knock).

    ( it actually steps 1.0195, 1.0391, 1.0195 )

    When I look in your tune, I can't see where EQR 1.0391 is coming from.

  9. #19
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    Well the serial cable showed up tonight and I crimped the RJ11 connector on there and I'll be damned if it didn't work perfectly. It was easier than I expected so here is the log with the wideband logged as well.
    Attached Files Attached Files

  10. #20
    Member sixltrbtr's Avatar
    Join Date
    Jun 2009
    Posts
    57

    Default

    Here is another log I made after adjusting the MAF on the upper end. There was a bobble in the transition but fuel came in much better where I made adjustments. I will have to figure out how to adjust the VE table to add fuel at lower rpm's now. I also attached the tune so you could see what I did to the B5001 MAF table.

    Robert
    Attached Files Attached Files

Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. E38 Open Loop VS Closed Loop - strange issue
    By BLK02WS6 in forum E37, E38 & E67 PFI ECM's
    Replies: 6
    Last Post: June 11th, 2016, 11:47 AM
  2. Replies: 1
    Last Post: April 11th, 2013, 03:28 PM
  3. Open loop or semi open loop still?
    By louis in forum General (Petrol, Gas, Ethanol)
    Replies: 15
    Last Post: October 18th, 2007, 02:46 AM
  4. Semi-Open Loop Vs Just Open Loop
    By BowlingSS in forum Custom Operating Systems
    Replies: 16
    Last Post: April 14th, 2006, 04:25 AM
  5. Truck wont idle during open loop speed density
    By mtnman in forum General (Petrol, Gas, Ethanol)
    Replies: 2
    Last Post: February 23rd, 2006, 05:43 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •