Results 1 to 10 of 10

Thread: E78 - 2017 Sonic 1.4t Code 95 Code 84 on dash

  1. #1
    New Member
    Join Date
    Aug 2018
    Posts
    6

    Exclamation E78 - 2017 Sonic 1.4t Code 95 Code 84 on dash

    Hello everybody,

    Need some help here, just flashed a 2017 Sonic 1.4T and 2 things are happening, once I connect the efilive unit on the OBD and the engine is on the code 95 pops up on the dash and gauges shut down, traction control light on and some others on, well I have to do logs so i am kind of blind, checked logs all ok and then removed everything went for a drive and 100 mts driving and code 84 on the dash, try to check DTC's with efilive, everything is clean, used launch scanner and clean, any clues to what might be happening, there is no apparent power loss when code 84 pops up.

    tahnks in advance,

    Alejandro

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Does it say "95" or "P0095" or "U0095"...?

  3. #3
    New Member
    Join Date
    Aug 2018
    Posts
    6

    Default

    Quote Originally Posted by joecar View Post
    Does it say "95" or "P0095" or "U0095"...?
    Nope it's just a "dash" code i cannot find anything doing a full scan sweep. I attach the results after flashing which I cleared and instantly after driving code 84 on dash

    https://imgur.com/a/SalVf64

  4. #4
    New Member
    Join Date
    Aug 2018
    Posts
    6

    Default

    Joe, I made a test I installed the file without any mods (not original from the read out) and 3 mins afterwards same error on dash 84 so it seems it is something while writting.

  5. #5
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Does that error code go away...?

    ( during writing to the ECM, other modules can't talk on the CAN lan/bus, so they might emit a code (looks like dash did this) )

  6. #6
    New Member
    Join Date
    Aug 2018
    Posts
    6

    Default

    Quote Originally Posted by joecar View Post
    Does that error code go away...?

    ( during writing to the ECM, other modules can't talk on the CAN lan/bus, so they might emit a code (looks like dash did this) )
    Not at all drove it for a day with about 15 start/stop cycles to check and never went away.

  7. #7
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Quote Originally Posted by sama13 View Post
    Hello everybody,

    Need some help here, just flashed a 2017 Sonic 1.4T and 2 things are happening, once I connect the efilive unit on the OBD and the engine is on the code 95 pops up on the dash and gauges shut down, traction control light on and some others on, well I have to do logs so i am kind of blind, checked logs all ok and then removed everything went for a drive and 100 mts driving and code 84 on the dash, try to check DTC's with efilive, everything is clean, used launch scanner and clean, any clues to what might be happening, there is no apparent power loss when code 84 pops up.

    tahnks in advance,

    Alejandro
    Hi Alejandro,

    Are you saying that just connecting the FSV2 to the OBD-II port causes dash to display code 95 and gauges shutdown...?

    Are you sure your 2017 Sonic 1.4T has the E78 and not the E84 ECM (my 2017 Spark 1.4 uses the E84)...?

    Please post a pic of your engine bay showing the ECM.

  8. #8
    New Member
    Join Date
    Aug 2018
    Posts
    6

    Default

    Quote Originally Posted by joecar View Post
    Hi Alejandro,

    Are you saying that just connecting the FSV2 to the OBD-II port causes dash to display code 95 and gauges shutdown...?

    Are you sure your 2017 Sonic 1.4T has the E78 and not the E84 ECM (my 2017 Spark 1.4 uses the E84)...?

    Please post a pic of your engine bay showing the ECM.
    HI Joe,

    When I connect it it literally goes dead and code 95 pops up after like 5 seconds.

    Well the auto detect provided the E78, check this info I did a prtscr

    Click image for larger version. 

Name:	E78 Sonic.png 
Views:	30 
Size:	95.7 KB 
ID:	22389
    I will take picture and post on monday

  9. #9
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,119

    Default

    You could try removing* pin 1 from the FlashScan OBDII cable. That pin is not used (never will be) but it is connected through to FlashScan and on some vehicles, PIN 1 is the low speed CAN bus. Sometimes FlashScan may cause interference on that pin causing modules that communicate over the low speed CAN bus to set trouble codes. Pin 1 is labelled on the OBDII cable end.

    First though, make sure you are using the latest boot block and firmware. Over the past few years we've updated the firmware to lessen the potential for interference on the low speed CAN bus.

    *removing means actually physically cutting the pin out of the end of the OBDII cable.
    Before asking for help, please read this.

  10. #10
    New Member
    Join Date
    Aug 2018
    Posts
    6

    Default

    Quote Originally Posted by Blacky View Post
    You could try removing* pin 1 from the FlashScan OBDII cable. That pin is not used (never will be) but it is connected through to FlashScan and on some vehicles, PIN 1 is the low speed CAN bus. Sometimes FlashScan may cause interference on that pin causing modules that communicate over the low speed CAN bus to set trouble codes. Pin 1 is labelled on the OBDII cable end.

    First though, make sure you are using the latest boot block and firmware. Over the past few years we've updated the firmware to lessen the potential for interference on the low speed CAN bus.

    *removing means actually physically cutting the pin out of the end of the OBDII cable.
    OK I will remove.

    I have updated everything last week just to double check and same issue, instant issue when connecting will remove pin #1

Similar Threads

  1. Replies: 3
    Last Post: October 29th, 2017, 12:06 PM
  2. Replies: 0
    Last Post: April 30th, 2017, 12:41 PM
  3. SONIC turbo - E78?
    By Boost in forum E78, E83, E84 PFI ECM's
    Replies: 22
    Last Post: February 1st, 2012, 09:24 AM
  4. SONIC turbo - E78?
    By Boost in forum E39, E80, E82 & E92 SIDI ECM's
    Replies: 22
    Last Post: February 1st, 2012, 09:24 AM
  5. Code P062F and Code P0633 Help
    By Airtime in forum General (Diesel)
    Replies: 6
    Last Post: September 28th, 2009, 12:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •