Results 1 to 3 of 3

Thread: cm871

  1. #1
    Junior Member
    Join Date
    Oct 2015
    Posts
    45

    Default cm871

    I hooked up to the truck fine started reading and then this it did it 5 times to me then I stopped



    CliffClick image for larger version. 

Name:	cm871.PNG 
Views:	57 
Size:	112.2 KB 
ID:	22423

  2. #2
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,646

    Default

    Hi Cliff,

    The CM871 (and CM876) have had this issue fixed with an update we've sent a couple of people for testing. However there is a bigger issue with these that might mean we remove flashing support for the time being.
    Essentially the ECM is sending back faulty data at random points, to make matters worse Cummins have the checksums disabled in this ECM so we have no idea if what was read is valid to flash back.
    There has been once incident of a CM871 ECM being bricked using tune that was read from the ECM (though recovered using forced bootmode).

    We will continue to work on some sort of solution to ensure what is read out is ok.

    FWIW there is major bugs in the ECM read code as this was the first ECM to go to the new comms protocol Cummins used, we have many workarounds to try to handle what the ECM does wrong (as does the factory software).

    I have now posted this sticky thread.

    Cheers,
    Ross
    Last edited by GMPX; September 30th, 2018 at 12:10 PM.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  3. #3
    Junior Member
    Join Date
    Oct 2015
    Posts
    45

    Default

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •