Results 1 to 5 of 5

Thread: GM.GearCom PID causing error report

  1. #1
    Lifetime Member
    Join Date
    Aug 2012
    Posts
    226

    Default GM.GearCom PID causing error report

    Trying to diagnose a 4l80e not upshifting. I am trying to log gm.gearcom (commanded gear) but whenever I select that PID (had to validate to make it active) and then try to connect I get a 'generating error' report ($31 I believe). I tried to connect multiple times after restarting, new cable, etc... finally connects ONLY when I disable that PID.

    Desperately need this PID to figure out why I'm not shifting out of first ( I can command gear changes through DVT. VSS is dead on, TPS reads correct, shift table is normal, MAP reads normal)

  2. #2
    Lifetime Member
    Join Date
    Aug 2012
    Posts
    226

    Default

    Since I tried doing this I have updated the V2 firmware. I have yet to try logging again since the truck is an hour away. I just want to come prepared when I make the drive.

  3. #3
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,493

    Default

    The pid is GM.GEAR


    post your V2 config file.

  4. #4
    Lifetime Member
    Join Date
    Aug 2012
    Posts
    226

    Default

    Now is gm.gear the commanded gear OR the current gear? I believe I had the current gear PID working fine. I wanted to see if the PCM was saying ‘shift’ or not.

  5. #5
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,493

    Default

    GM.GEAR is the commanded gear.

    The pids GM.GEARCOM and GM.GEARCURR are for Allison and not for 4L60E/4L80E.

Similar Threads

  1. ls1a error report maf HZ
    By Tool Guy in forum Gen III V8 Specific
    Replies: 18
    Last Post: July 21st, 2018, 03:58 AM
  2. Ls1 Logging error report
    By Tre-Cool in forum Gen III V8 Specific
    Replies: 4
    Last Post: December 7th, 2012, 04:49 PM
  3. error updating pid in bbl
    By nathans1987 in forum General (Petrol, Gas, Ethanol)
    Replies: 1
    Last Post: February 1st, 2010, 07:47 AM
  4. Error Report.
    By horsehaulin in forum FlashScan V1
    Replies: 5
    Last Post: June 5th, 2008, 09:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •