This is a 2002 6.0 with 4l80e. It has a digital dakota 8k pulse generator on it.

Truck originally had a 3 wire dakota digital speed sensor and the shop tapped in the VSS high to the signal wire. I was called out to help diagnose and fix the problem of strange shifting. When I logged the data I noticed the VSS line was very choppy and snapping around 5-7MPH from actual speed. I told them to order a 2 wire DD 8k pulse generator, reflashed for the new pulse per mile. I then get a call that it won't shift out of first now. When I show up with my V2, connect and start logging, we go for a drive and the truck shifts fine. It felt like I came down for no reason. I did notice the speed was off by 15% so i made that correction and went for another drive. Then it was acting like before where it wouldn't shift out of first. I tried a new PCM with a good, known tune. Still same problem.

I can use DVT and trigger shifts through all gears. It doesn't feel like it's commanding them. I am currently trying to get the Commanded Gear PID to work (It had an X through it and when I validated it and tried to connect it generates an error report when clicking the yellow or red record button, thread here

I would like to know what to test for IF i can get the commanded gear PID to work and it shows either A) it is not commanding a shift (and why isnt it, what are the triggers to make it command) and B) it is commanding the shift but it is not happening at the trans (despite being able to with DVT)