Results 1 to 4 of 4

Thread: 2006 8.1L IAC PIDs not Valid for RAFIG/RAFPN process

  1. #1
    New Member
    Join Date
    Apr 2014
    Posts
    8

    Default 2006 8.1L IAC PIDs not Valid for RAFIG/RAFPN process

    I have a 2006 Silverado with the Allison 6 speed and A raylar 202 camshaft with long tubes and Volant. Overall pretty mild and runs great 95% of the time. I was looking to fine tune in some of the idle parameters, but bouncing the needed PIDS off of my OS shows all the ST and LT IAC PIDs as invalid. The 2 calc PIDs for RAFIG and RAFPN are valid and will log, but just rise to 3.88 in imperial or 29.36 in metric units. As such I don't believe them. I've looked around and found a few instances of this, but most were disabling of other parameters etc. I don't have anything crazy done to this tune and have uploaded the stocker as a comparison tool.

    I have attached my tune file and a data log showing what happened. Any ideas on the PIDs? I have a 2003 Suburban with the 8.1L/4l80E combo and all PIDs are valid and as expected. Thanks in advance!

    -Alex
    Attached Files Attached Files

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Which PCM do you have...?

  3. #3
    New Member
    Join Date
    Apr 2014
    Posts
    8

    Default

    It tunes and scans as an LS1B, and is that style with the blue and green connectors. I've looked through threads for most of the day and it appears that the '06 OS PIDs were a little neglected since other platforms were moving onto the E38. Also EFILive won't ever let me select the A40 TCM for the allison 6 speed since it claims my PCM and that TCM weren't an option. Again, think I just own an oddball 2006 8.1L running an LS1B type PCM with an A40 TCM.

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Posts
    129

    Default

    All the 8.1L Gas engines used The same PCM as the regular LS based engines. But in the HD trucks, they used an allison transmission. As such they the 5 speed used the AL5 and the 6 speed used the A40 trans controller.

    I can't comment on the 06 operating system but a friend of mine has an 03 2500HD with an 8.1 and I know he tuned both the ECU and TCM in that truck. He also did a segment swap and is running flex fuel set up.

Similar Threads

  1. RAFIG not Valid? Can't find underying PIDs
    By Black LS1 T/A in forum Petrol / Gas
    Replies: 2
    Last Post: November 28th, 2015, 01:44 AM
  2. Can't RAFIG or RAFPN??
    By Wasted Income in forum FlashScan V2
    Replies: 1
    Last Post: June 1st, 2012, 04:23 AM
  3. Trying to tune RAFPN and RAFIG
    By z28ls1818 in forum Gen III V8 Specific
    Replies: 32
    Last Post: January 13th, 2010, 04:39 PM
  4. Tuning RAFIG and RAFPN NEED HELP PLEASE
    By z28ls1818 in forum Gen III V8 Specific
    Replies: 52
    Last Post: December 28th, 2009, 02:24 AM
  5. RAFIG RAFPN for E40
    By MyM8V8 in forum Gen IV V8 Specific
    Replies: 3
    Last Post: March 31st, 2009, 08:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •