Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Suoercharged 03 Silverado 1500 5.3 (LM7)

  1. #1
    Junior Member
    Join Date
    Jun 2016
    Posts
    23

    Default Supercharged 03 Silverado 1500 5.3 (LM7)

    Hi

    Hi everyone. It has been a while since I had to ask for help here but I have read trough some posts from time to time. This time I am supercharged for the first time. I've got the Edelbrock #1577 charger.
    As someone might remeber I am not experienced with efilive tuning but successfully tuned the same car with efilive following the calc vet tutorial and som help from this forum. I was running very lean after mounting headers and exhaust. That was a couple of years ago, and now Ive finally managed to find time to bolt on my supercharger.

    These are the questions that I need help with. At least for a start.
    Do i need a xx03 custom OS? If so, do i need to disable MAF? I know the Custom OS tutorials says so. But for a start I will like to keep boost low and most probably way bellow MAF limit
    What do I read to start ?
    Anyone having a tune file I could start with ?
    Ignition map??

    I have the 12609749 injector so I used data from a 09 6.2 flexfuel. For the TMAP i have been told to use 223.43 and -7.88kPa offset to scale it correctly.

    Started the car for the first time tonight. Still have to put back a few pieces but could not wait to see if it started with the "pre" charger tune. It starts, idles good for a few seconds, ten richer and richer until it suddenly gets really lean and stops. Did not touch the accelerator, so I do not know if I would be able to keep it alive.
    Last edited by EspenT; July 22nd, 2019 at 11:37 PM.

  2. #2
    Junior Member
    Join Date
    Jun 2016
    Posts
    23

    Default

    Some pictures for attention

    Also. What AFR is safe at up to 8 psi boost? 11.8?

    Click image for larger version. 

Name:	IMG_3435 2.jpg 
Views:	23 
Size:	964.1 KB 
ID:	22948

    Air water intercooler.
    Click image for larger version. 

Name:	IMG_3424.jpg 
Views:	21 
Size:	938.5 KB 
ID:	22949

  3. #3
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    319

    Default

    Quote Originally Posted by EspenT View Post
    Some pictures for attention

    Also. What AFR is safe at up to 8 psi boost? 11.8?

    Click image for larger version. 

Name:	IMG_3435 2.jpg 
Views:	23 
Size:	964.1 KB 
ID:	22948

    Air water intercooler.
    Click image for larger version. 

Name:	IMG_3424.jpg 
Views:	21 
Size:	938.5 KB 
ID:	22949
    I've always ran 11.2 AFR for boost.


    Sent from my SAMSUNG-SM-G870A using Tapatalk

  4. #4
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    319

    Default

    Quote Originally Posted by EspenT View Post
    Hi

    Hi everyone. It has been a while since I had to ask for help here but I have read trough some posts from time to time. This time I am supercharged for the first time. I've got the Edelbrock #1577 charger.
    As someone might remeber I am not experienced with efilive tuning but successfully tuned the same car with efilive following the calc vet tutorial and som help from this forum. I was running very lean after mounting headers and exhaust. That was a couple of years ago, and now Ive finally managed to find time to bolt on my supercharger.

    These are the questions that I need help with. At least for a start.
    Do i need a xx03 custom OS? If so, do i need to disable MAF? I know the Custom OS tutorials says so. But for a start I will like to keep boost low and most probably way bellow MAF limit
    What do I read to start ?
    Anyone having a tune file I could start with ?
    Ignition map??

    I have the 12609749 injector so I used data from a 09 6.2 flexfuel. For the TMAP i have been told to use 223.43 and -7.88kPa offset to scale it correctly.

    Started the car for the first time tonight. Still have to put back a few pieces but could not wait to see if it started with the "pre" charger tune. It starts, idles good for a few seconds, ten richer and richer until it suddenly gets really lean and stops. Did not touch the accelerator, so I do not know if I would be able to keep it alive.
    Post your tune and a log.
    Also are you running 89, 91, or 93 octane?

    Sent from my SAMSUNG-SM-G870A using Tapatalk

  5. #5
    Junior Member
    Join Date
    Jun 2016
    Posts
    23

    Default

    Just finished up the install tonight.

    Vent trough the custom os tutorial found here. http://download.efilive.com/Tutorial...20Tutorial.pdf

    First i used a tune with some map data i found online for a ford tmap sensor used on the e-force chargers, but could not get car run long enough to log anything and is showed around 75kpa key on engine off.

    Serched some more and found some data for a bosch sensor here. There is no markings on the sensor so hard to se what kind it is.
    https://forum.efilive.com/showthread...rger-and-COS-5

    kPa now in the 90s and car started.. Extremely lean, but I was able to "drive" it out from the garage to free up the workshop lift. Did not want to rev it or anything being that lean. How dangerous is it to be that lean on idle? I was going to try some calc VE but there are a few years since I used EFILive and i could not find the pids referenced in the manual. Also I do not know if it is my ve that is completely off, or something else. Car does idle pretty good.. A few backfires. But i did drive up a "step" slope as the garage is at a lover level than parking spaces outside.

    DK61031_charger_0002.ctz
    LS1B_bosch_tmap5.pld
    LS1B_bosch_tmap4.pld
    LS1B_bosch_tmap3.pld

    Noticed now that there is a 7.5 version of the scan tool as well. I think that is what I used last time. The Auto VE tutorial is for that version. Is it possible to do Auto VE in version 8? If so, is there a guide?
    Last edited by EspenT; July 23rd, 2019 at 09:53 AM.

  6. #6
    Junior Member
    Join Date
    Jun 2016
    Posts
    23

    Default

    Quote Originally Posted by nonnieselman View Post
    Post your tune and a log.
    Also are you running 89, 91, or 93 octane?

    Sent from my SAMSUNG-SM-G870A using Tapatalk
    Forgot to answer this.
    I'm in Europe and our octane rating is RON not RON+MON/2 like in US. So my 95octane is something like 90.5-91 ish..

  7. #7
    Junior Member
    Join Date
    Jun 2016
    Posts
    23

    Default

    After reading up some more I would really like to do a calc.vet to tune both maf and ve in a single operation. Is that possible in COS3? Seems like most posts I read suggests that MAF should be disabled in COS3, but is it this absolute?

  8. #8
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    319

    Default

    Quote Originally Posted by EspenT View Post
    After reading up some more I would really like to do a calc.vet to tune both maf and ve in a single operation. Is that possible in COS3? Seems like most posts I read suggests that MAF should be disabled in COS3, but is it this absolute?
    The reason to disable MAF for COS3 is so the pcm will ignore it's readings and you will tune it in speed density. Then you could enable MAF and tune it

    Sent from my SAMSUNG-SM-G870A using Tapatalk

  9. #9
    Junior Member
    Join Date
    Jun 2016
    Posts
    23

    Default

    Quote Originally Posted by nonnieselman View Post
    The reason to disable MAF for COS3 is so the pcm will ignore it's readings and you will tune it in speed density. Then you could enable MAF and tune it

    Sent from my SAMSUNG-SM-G870A using Tapatalk
    Ok.. I did a try to log AutoVE with the scan and tune 8 software but think i used the wrong pids. The ben i had is stuck at 0. I do not understand how to create maps in the v8 software either. Wish there where some tutorials not only for the old versions.. If I was able to do it I would make them myself.
    Also I think there is something seriously wrong with the tune. Had to increase the VE table ridicules much to get AFR in the 14-15 range. Did a short test drive but had to stop and restart the car twice. Trottle became unresponsive and the engine went 4 cyl or something. Ok after stop/start. Is that the MAX predicted airflow that kicks in?
    Would appreciate any input.

    SD_Auto_VE.ctz
    run1_start_to_stop1.pld
    run1_stop1_to_stop2.pld

  10. #10
    Member
    Join Date
    Aug 2016
    Posts
    86

    Default

    I've been staying with V7.5, but I've looked into switching to V8 recently. You can copy your V7.5 maps to V8 pretty easily. In the V7.5 scan tool, go to your desired map, open its properties, then click the button labeled "Copy for V8."

    Go to your V8 maps, open a map's properties by clicking the little arrow next to "Config" or pressing Shift+F8, then press the clipboard paste button in the top right corner.

    Have you changed your injectors during your installation?

Page 1 of 2 12 LastLast

Similar Threads

  1. lm7 to lq9
    By powellbuilt95 in forum Gen III V8 Specific
    Replies: 16
    Last Post: April 14th, 2019, 01:06 PM
  2. lm7 speed density tuning
    By 2003gmc1500 in forum Gen III V8 Specific
    Replies: 4
    Last Post: February 7th, 2017, 03:27 PM
  3. 5.3 LM7 low idle
    By hoff2483 in forum Gen III V8 Specific
    Replies: 0
    Last Post: March 3rd, 2009, 12:13 PM
  4. 01 5.3 lm7
    By Big D in forum Gen III V8 Specific
    Replies: 9
    Last Post: February 24th, 2009, 06:21 PM
  5. 2001 Silverado 4x4 LM7 Vortec with Whipple & 42lb injectors
    By bratch in forum Vortec V6/V8 Specific
    Replies: 13
    Last Post: April 1st, 2007, 05:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •