Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: cruise control thoughts

  1. #11
    Junior Member
    Join Date
    Jul 2019
    Posts
    16

    Default

    This should be my conclusions about getting my CC working.
    In the end it turned out to be the TCC control. I foolishly thought that just leaving 12 volt permanently connected to the TCC. and relied on the brake TAC. connections (one with a grd till brakes are applied then 12volt.}
    This would work till the ECM detected that the brakes are showing up at the TAC but not at the TCC. which through s a code that disables the CC on next keyup.
    Now that the TCC is hooked up to the positive when brakes are released and nothing when there depressed. You can verify this by using the GM.STATe01-09 PID to check.

  2. #12
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Quote Originally Posted by trona View Post
    Here is the emisions test failure
    "Oxygen Sensor Heater X/y Samples Test - B1S2 $0E $12 9.0000 8.0000 Maximum Samples"
    maybe this is a clue
    Thanks
    Dave
    Do this to pass the catalyst test:
    Quote Originally Posted by In-Tech View Post
    ... set p0420,p0430 to X not-reported reporting but leave the MIL active it will instantly set the catalyst monitor passed.
    And no, you can't leave the rear sensors active and have the sensors in the glove box, above tip should work for those rears too.
    The last sentence of that is saying this: do same for the rear O2 sensor tests, find all the BxS2 DTC's and set them to not-reported and set MIL on.

  3. #13
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,752

    Default

    Quote Originally Posted by trona View Post
    This should be my conclusions about getting my CC working.
    In the end it turned out to be the TCC control. I foolishly thought that just leaving 12 volt permanently connected to the TCC. and relied on the brake TAC. connections (one with a grd till brakes are applied then 12volt.}
    This would work till the ECM detected that the brakes are showing up at the TAC but not at the TCC. which through s a code that disables the CC on next keyup.
    Now that the TCC is hooked up to the positive when brakes are released and nothing when there depressed. You can verify this by using the GM.STATe01-09 PID to check.
    Sorry, I'm not following (lol, it is 4:01 am)...

Page 2 of 2 FirstFirst 12

Similar Threads

  1. ABS, Traction control, Cruise control..
    By GMCAMARO in forum Gen III V8 Specific
    Replies: 5
    Last Post: January 23rd, 2016, 02:10 PM
  2. DBW and cruise control
    By sjfiore in forum General
    Replies: 1
    Last Post: March 24th, 2015, 01:55 PM
  3. Lean Cruise and Cruise Control
    By neil in forum Tuning For Economy
    Replies: 11
    Last Post: July 9th, 2007, 08:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •