Results 1 to 6 of 6

Thread: MDI2 and V2 compatibiltiy problems

  1. #1
    Senior Member
    Join Date
    Jul 2012
    Posts
    158

    Default MDI2 and V2 compatibiltiy problems

    So, in the past we have been able to load stock tunes with the GM MDI2 hardware then tune with EFI Live. There was never any issue and the ECMs always reacted exactly as a completely bone stock ECM would. Something recently changed and now after an MDI2 flashes an ECM our EFI Live cannot read the tune. This happened on 2 or 3 different e38 ECMs then I thought to try "Try common Alternative Keys" and I am able to read the file. However, on one ECM in particular that was already unlocked, then changed with MDI2, I cannot write a file to it. It's like its no longer unlocked. Again, this didn't use to be the case. I attached a pic of the error message discussing the custom key.

    I also cannot license an altogether different e38 that we have tried to work with.

    Obviously this could be something that has changed with the MDI2 and GM setup, I am not sure. Has anyone else dealt with this? My buddy at GM says that the MDI2 is being used exactly as they do every day at the dealership. In theory if that's the case a vehicle could come in and need a new ecm under warranty, get replaced, then a year later try to be tuned by EFI Live and have this issue.

    Has this already been discussed somewhere and I missed it?

    Click image for larger version. 

Name:	efilive error custom key.jpg 
Views:	21 
Size:	335.2 KB 
ID:	22993

  2. #2
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,760

    Default

    Post up a trace file if you could please.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


  3. #3
    Senior Member
    Join Date
    Jul 2012
    Posts
    158

    Default

    Forgive me, I'm trying to figure out what a trace file is...

    In other news this is the error I get when trying to check the license of the OTHER e38 in my hand. A 2010. I had to use the "try common alt keys"
    and it tried to go through but as you see the serial numbers being all 000000 didn't go over well. I guess this might be a change the MDI2 is making???Click image for larger version. 

Name:	15670008693503779656482411672656.jpg 
Views:	22 
Size:	767.9 KB 
ID:	22997
    Last edited by LS-SWAPPER; August 28th, 2019 at 07:11 AM.

  4. #4
    Lifetime Member ProperTuningOG's Avatar
    Join Date
    Dec 2014
    Posts
    218

    Default

    How are you TIS flashing? Re flash or replace and re flash?

  5. #5
    Senior Member
    Join Date
    Jul 2012
    Posts
    158

    Default

    Tried both, but replace and reflash is what I normally do.

  6. #6
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    12,760

    Default

    Quote Originally Posted by LS-SWAPPER View Post
    Forgive me, I'm trying to figure out what a trace file is...
    In the folder below (where XXXX is the user name logged in to the PC):

    C:\Users\XXXX\Documents\EFILive\V8\Trace

    There is files saved with the extension .htx, look for the ones with E38 in the file name and post a couple of those up in a zip.

    However I think I know exactly what is happening, as you may have experienced with EFILive before when you go to full flash an E38 (and some others) it comes back and says the OS's are not compatible and will not flash the file in.
    I don't believe TIS has such checks which means when you flash an incompatible OS in the ECM will corrupt like you are experiencing (eg you are putting a 2010 OS in to an ECM that has a 2008 OS in it).

    The number one sign this has happened is when the S/N's returns as all zeros and the ECM becomes locked.....I asked for trace files just to confirm that for you more than anything else.
    Need official EFILive help, please go here.
    For tuning support please post your questions on this forum (or other auto forums).
    Sorry if I don't respond to your PM, don't take it personal.


Similar Threads

  1. Replies: 7
    Last Post: May 28th, 2018, 05:52 AM
  2. Help problems......
    By VACARELLAB in forum Duramax LB7
    Replies: 7
    Last Post: April 13th, 2009, 11:16 PM
  3. Problems
    By goodwrenchtech in forum General (Diesel)
    Replies: 3
    Last Post: November 25th, 2008, 05:19 PM
  4. Got some problems
    By mwalls54 in forum General (Petrol, Gas, Ethanol)
    Replies: 2
    Last Post: November 10th, 2007, 08:05 AM
  5. Having some Problems with LM-1
    By mwalls54 in forum General
    Replies: 5
    Last Post: January 21st, 2006, 08:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •