Results 1 to 8 of 8

Thread: T42 4L60E 3-4 UpShift issue

  1. #1
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    353

    Default T42 4L60E 3-4 UpShift issue

    So been trying to help a buddy out with his truck.
    08 E38/T42
    Heads/cam 6.0
    Rpm level 6 4L60E
    4.10 gears

    It is shifting 3-4 at WOT.
    No matter what MPH/RPM I put in the tune, it shifts at the same mph (about 100mph) every time.
    Even in manual 3rd, set tow/haul to max rpm/mph and even tried Bi-Di control to hold 3rd gear and it still shifts into 4th.

    I'll try and post log/tune in a little while.

    I'm not too familiar with T42 tuning as much as I am with LS1B tuning so I may be missing something?


    Sent from my SAMSUNG-SM-G870A using Tapatalk

  2. #2
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,930

    Default

    Check that the Throttle Kickdown tables are all set to 100% all across.

  3. #3
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    353

    Default

    I completely forgot to post the tunes.... I'll try and do that tomorrow at lunch.
    The flexplate broke so truck is down getting transmission freshened up and new Torque converter. So maybe in the next couple weeks I can get more time to tinker with it.

    Sent from my SAMSUNG-SM-G870A using Tapatalk

  4. #4
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    353

    Default

    Here is the original tunes that were on the truck.
    Startup was crazy with all the air they had in the tune. It would rev to 4000rpms.
    Attached Files Attached Files

  5. #5
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    353

    Default

    Quote Originally Posted by joecar View Post
    Check that the Throttle Kickdown tables are all set to 100% all across.

    Im not seeing any of the throttle kickdown tables in this T42.

  6. #6
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    27,930

    Default

    I'm looking thru your T42 file...

    I'm checking that none of the shift curves cross anywhere.

  7. #7
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    353

    Default

    Should be able to get back to the truck this weekend to try out a stock tune with slight adjustments to see what happens.

  8. #8
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    353

    Default

    The transmission builder is tryin to sort it out with HP tuners and not having any luck.
    I think it would be best to just start over with a stock tune and flash it in.

    Can I do a full flash of the same OS with a T42?

    Sent from my SAMSUNG-SM-G870A using Tapatalk

Similar Threads

  1. E38/T42 4l60E P0717 Code
    By minytrker in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 29
    Last Post: March 17th, 2020, 02:49 PM
  2. Manual upshift downshift 1,2,3,4 on 4L60e without manual valve body
    By Test101 in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 12
    Last Post: October 7th, 2013, 08:30 PM
  3. T42 4L60e TCC tuning
    By jpgmtech in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 6
    Last Post: October 1st, 2010, 09:13 AM
  4. 4l60E / T42 TC lockup problems
    By harascho in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 8
    Last Post: February 16th, 2009, 07:34 AM
  5. E38 with T42 for 4L60E (no ISS)
    By gmh308 in forum 4speed RWD/FWD Transmission Tuning (incl T42)
    Replies: 0
    Last Post: July 24th, 2008, 01:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •