Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: e38 6L80E to 4L80E help

  1. #1
    Member
    Join Date
    Jun 2013
    Posts
    88

    Default e38 6L80E to 4L80E help

    I'm swapping a 2008 Pontiac G8 from a 6L80e(t43) to a 4L80e(T42). The wiring is done and I'm able to read/write to the new t42 controller. The new t42 is out of a 2008 chevy 2500 work van that was controlling a 4L80E. From what I've read it seems like I have to change the OS on the E38 ECM to something that's looking for a t42 controller. If possible I would like to retain the tap shift feature. I know the t42 used in the 2008 Pontiac grand prix has this feature using a 4T65E. The current E38 OS is 12624402 and the old t43 was using 24243170 and the new t42 has OS 24239927. What OS(s) should be used for this? Any help or advice would be greatly appreciated.

  2. #2
    Member koolky's Avatar
    Join Date
    Aug 2013
    Posts
    56

    Default

    The 08 Grand Prix runs an E67 ECM with OS 12618164. I'm not sure if any of the platforms that run an E67 and have the correct communication options to work with the G8 modules.

  3. #3
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,849

    Default

    PCMofNC sells a swap harness for this exact scenario, not sure what they do for tuning around it: PCM of NC 6l80e to 4lxxe conversion harness/. Shoot them an email or call, they may be willing to sell you the TCM and/or tuning they use to make it work.

    The 12618164 ECM OS was apparently a widely used 2008 E67 ECM OS. The TrailBlazer platform uses it too and the 24239927 TCM OS is the factory 08 TrailBlazer OS for 4L70E. The Express Vans use the same OS for 4L80E, but are E38 based with ECM OS 12617631.
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, tuned, turbo mods, etc.
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  4. #4
    Member
    Join Date
    Jun 2013
    Posts
    88

    Default

    Quote Originally Posted by koolky View Post
    The 08 Grand Prix runs an E67 ECM with OS 12618164. I'm not sure if any of the platforms that run an E67 and have the correct communication options to work with the G8 modules.
    I didn't know it was paired with an E67. I'm sticking with the E38 in the car now. What I was getting at was that the t42 does support tap shift in some vehicles. Some options are there for it in the 24239927 OS that's in the t42 already. I have the signal wire for tap shift that went from the bcm to the t43 going to pin 10 on the t42 like it does on the grand prix. I don't know if this will work but it seems plausible. Maybe I'll have to use a hex editor to look at the differences between the GP t42 OS and others.

    I full flashed OS 12617631 to the ECM(found the compatibility list). I applied the VATS patch to it and I guess I have the settings correct for that. I haven't worked with many E38s and I'm starting to see that VATS issues aren't as simple to deal with as they are on an LS1B. The car won't crank when I turn the key. The dash shows the correct gear so at least that's working. What PIDs should I be monitoring when I'm trying to start the car?

    Thanks for the info ScarabEpic22 but I'm trying to learn how to do this.

    Thanks for the replies.
    Attached Files Attached Files

  5. #5
    Member koolky's Avatar
    Join Date
    Aug 2013
    Posts
    56

    Default

    Log ENGR - Power mode / starter status. Even if you made a mistake doing the VATS patch I believe the car should still crank, fire and stall a few seconds later. My guess would be a configuration difference between the G8 and the file that you loaded (truck or van?). I'd have a look at the ignition wiring and ECM pin used for the two platforms. Also, with the key in the run position you could pull the starter relay out, bridge the 2 terminals to force it to crank over.

  6. #6
    Member
    Join Date
    Jun 2013
    Posts
    88

    Default

    I went back to OS 12624402 that came from the factory in this g8. Turning the key does nothing. Jumping the starter relay with the starter relay coil in place so the ECM sees the right amount of resistance just turns the engine over with spark and no fuel pressure. If I do all of that while jumping the fuel pump relay it does start. When it does start, the dash lights up like a christmas tree. The dash also tells me that the engine has been immobilized while it's running fine. I guess that's because the original OS isn't looking for a t42. I have also tried all of this with x1 pin 52 grounded or connected normally. I updated my V2 firmware and 7.5 and 8 tuning and flashing software. I tried applying the VATS patch and full flashing it again. I have tried everything I can find in this forum that has to do with this problem. I really don't know what else to do. One of the guys I know that has HPT keeps telling me to buy him the credits and he will fix my vats problem. When he reads the tune HPT says that vats is enabled. It seems like the two pieces of software go about disabling vats in different ways so that might not mean anything. If anyone can help point me in the right direction I would really appreciate it. Click image for larger version. 

Name:	2008 pontiac G8 4L80E codes.png 
Views:	19 
Size:	74.5 KB 
ID:	23237g8 tune 0_0002.ctz

  7. #7
    Member
    Join Date
    Jun 2013
    Posts
    88

    Default

    I just tried a 2008 Vette 6 speed OS because I saw that it worked for someone else. This time, the fuel pump gets power without jumping anything. I did the vats patch and full flash with all the other options that go along with it. Nothing much happens when I turn the key. When I jump the starter relay it does start for a second or two and then dies. That sounds more like a vats problem to me. The display on the dash still shows park, reverse, neutral and drive correctly."FIN" I have an alternate theory that this is related to the COVID 19 outbreak. If the car is infected, will a full flash fix the problem? I'm having trouble finding any PIDs to do with viral infections. Should that car be using a specific kind of intake filter for screening out viruses? I haven't taken it to any strange gas pumps. I live in Florida and we are currently under "lockdown". My family and I have everything we need but we are going a little stir crazy. Due to the alcohol shortage I learned how to LS1B (P59) swap a makeshift distillation rig. I'm using the fan control output and a coolant temp sensor to regulate a hot plate under "THE STILL". I'm able to datalog the still's temp and it's very consistent. I'm not really sure how much ignition timing this thing wants but so far I'm not seeing any detonation. I also have a 2 bar map sensor installed so that If I build more that a few kpa of pressure it kills the heat. Has anyone made a cax file for still protection mode?
    Attached Files Attached Files

  8. #8
    Member
    Join Date
    Jun 2013
    Posts
    88

    Default

    Nobody has any ideas?

  9. #9
    Member
    Join Date
    Jun 2013
    Posts
    88

    Default

    Click image for larger version. 

Name:	e38 vats hell.jpg 
Views:	18 
Size:	228.0 KB 
ID:	23242 I took this screen shot with the key turned. The ECM isn't turning the starter on. Any suggestions would be great.

  10. #10
    Member koolky's Avatar
    Join Date
    Aug 2013
    Posts
    56

    Default

    Looks like the ECM might not be getting P/N input (log show inactive). You could log RVSDH to see if 'Trans Range Not Park'.

Page 1 of 2 12 LastLast

Similar Threads

  1. 2008 Pontiac G8 6L80E to 4L80E swap OS help
    By greasess in forum E37, E38 & E67 PFI ECM's
    Replies: 0
    Last Post: March 28th, 2020, 03:55 AM
  2. E38 Custom OS install with 6L80E
    By 74Apollo in forum E37, E38 & E67 PFI ECM's
    Replies: 1
    Last Post: July 11th, 2018, 11:45 AM
  3. Newbie Here. Need some help on 09 5.3 / 6L80e and e38
    By DarkKnightWong in forum E37, E38 & E67 PFI ECM's
    Replies: 41
    Last Post: September 26th, 2017, 11:50 AM
  4. 6l80e E38 no vehicle speed
    By KillaKustomKables in forum 6 speed/8 speed RWD/FWD Transmission Tuning (incl T43, T76, T87)
    Replies: 2
    Last Post: February 12th, 2013, 02:21 AM
  5. Replies: 1
    Last Post: January 31st, 2013, 08:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •