Results 1 to 4 of 4

Thread: 06 5.9 VIN is correct starts and dies after flash

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Member
    Join Date
    Aug 2019
    Posts
    74

    Default 06 5.9 VIN is correct starts and dies after flash

    I am struggling to figure out why this truck will start and die after a flash. The VIN is correct but it acts like it isn't. Trucks runs for a few seconds before shutting off.

  2. #2
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,092

    Default

    What about with the tune you read out of it, or a 100% known stock tune? (sometimes some of the handheld tuners don't do a true return to stock).


  3. #3
    Senior Member tylerltr450's Avatar
    Join Date
    Aug 2014
    Posts
    156

    Default

    is anti theft on?
    2006 Cummins Red, Auto to Nv5600, SBC 3600, Traction Bars, Visor, Running Lights, S&B Intake, ATS intake horn, EFI Live, Borg Warner S363 Turbo, Industrial Injection Dragon Fly Injectors.

  4. #4
    Member
    Join Date
    Aug 2019
    Posts
    74

    Default

    Got it figured out. I wanted to post the results here. Flashed in my tune file and the truck started. After a couple of seconds, it would shut off. Thought I had messed the VIN up but I did not. Tried multiple stock tune files and it did the same thing. Started thinking it had to be a security thing. Found a post on SKIM for people having problems with the key fob. Truck would start and die. This truck does not have a key fob. I called the owner and he said it never had one. I was thinking maybe this was it. The truck wasn't seeing the key fob. I disabled the anti-theft and turned of the DTC for SKIM. Flashed in the new tune file and ran perfectly. Dealer must have shut this off for the previous owner and when I flashed in the new tune file anti-theft was on. If you or your customer don't have a key fob be aware of this situation. Thanks, everyone for the help.

Similar Threads

  1. 2006 5.9 Starts and dies after flash
    By Twistedshafts in forum Cummins 5.9L
    Replies: 1
    Last Post: January 24th, 2021, 11:39 AM
  2. LS3 Starts and immediately dies
    By TurboCamaro in forum E37, E38 & E67 PFI ECM's
    Replies: 2
    Last Post: June 22nd, 2015, 05:44 AM
  3. Starts but then dies
    By Johnnydangerously in forum Gen III V8 Specific
    Replies: 10
    Last Post: June 12th, 2012, 03:03 PM
  4. Starts, reduced power, and then dies...
    By snax in forum Forced Induction and Nitrous Oxide (N20)
    Replies: 8
    Last Post: November 27th, 2010, 10:57 AM
  5. starts for 1 sec and then dies
    By Cablebandit in forum Custom Operating Systems
    Replies: 6
    Last Post: April 8th, 2007, 12:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •