Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: 2014 E92 standalone questions

  1. #1
    Lifetime Member
    Join Date
    Jan 2014
    Posts
    320

    Default 2014 E92 standalone questions

    Gents,

    Haven't navigated an E92 yet.

    Going to flash a friend's L83 swap project tomorrow. It's standalone, only ECM/TCM present. What's the scope on using the VATS patch? I just opened the only 2014 E92 file I have and don't see a patch in the EFI software(says not avail for this OS(12663390)). V7.5.28

    I haven't taken a read from the car yet to know what OS it actually is, just looking at a sample E92 file before I'm face2face with the guy. Is the patch avail for other OSs?

    For the TCM, I think it's a T87...but I know it's from a 2015 or 2016 and a different vin than the ECM. What is the best way to make it play nice with the ECM? Do I need to match the vin from the ECM in the TCM? I have an MDI and TIS as well I could get a factory tune from I guess if I first use EFILive to make the vin correct. Thoughts?

    The guy says the car is ready to start, so I'm hoping to just kill VATs and get the TCM tuning to mate with the ECM. I'll come back later with a full tune for his setup.

    Appreciate any tips/tricks. Thanks

  2. #2
    Lifetime Member
    Join Date
    Jan 2014
    Posts
    320

    Default

    OS for the ECM is 12663390 per TIS.

    I'll confirm this tomorrow, but hoping to have the patch with me when I go. It is about a 45 minute drive one way.

    edit: DUH. Plugged in the V2 to my PC and I see the red folder with the patch.

    Has anyone confirmed the starter relay circuit needs to see a load to ground? for 2014?
    Last edited by RADustin; February 19th, 2021 at 04:00 PM.

  3. #3
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,109

    Default

    I'll get you sorted on Monday, I'll post up a .calz file with all the stuff you need for OS 12663390.

    EDIT: I Should have read your post better, all you needed to do was the VATS disable patch and set G1219 to Disabled, then it should have fired up.
    Last edited by GMPX; February 21st, 2021 at 12:29 PM.


  4. #4
    Lifetime Member
    Join Date
    Jan 2014
    Posts
    320

    Default

    Quote Originally Posted by GMPX View Post
    I'll get you sorted on Monday, I'll post up a .calz file with all the stuff you need for OS 12663390.
    Many thanks


    Also, is it possible to get more info around F0585? If this is put to 'no', what reaction does the ECM have? What about F0612? is concerning the high pressure pump or low pressure pump?
    .
    Basically, we are hoping to run a solid state relay from the grey wire, X1(Blue) pin 44- but I'm not sure this is possible. Information I'm finding is conflicting.

    Thank you.

  5. #5
    Lifetime Member
    Join Date
    Jan 2014
    Posts
    320

    Default

    also also, do you have a pinout that explains if X1- pin 59 is ground or 5v PWM output for the fans?

  6. #6
    Lifetime Member
    Join Date
    Jan 2014
    Posts
    320

    Default

    Quote Originally Posted by GMPX View Post
    I'll get you sorted on Monday, I'll post up a .calz file with all the stuff you need for OS 12663390.

    EDIT: I Should have read your post better, all you needed to do was the VATS disable patch and set G1219 to Disabled, then it should have fired up.
    This is what I did.

    Is it possible to get clarity on these other questions? Not sure who else I could ask.

    Thanks

  7. #7
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,109

    Default

    Sorry I don't know all the answers, I didn't add in any of those calibrations myself.
    The ECM outputs will NOT be 5V, they will be 12V (regardless of either on/off style or PWM).
    I don't know if Solid Sate relays play nice with ECM's.


  8. #8
    Lifetime Member
    Join Date
    Jan 2014
    Posts
    320

    Default

    Quote Originally Posted by GMPX View Post
    Sorry I don't know all the answers, I didn't add in any of those calibrations myself.
    The ECM outputs will NOT be 5V, they will be 12V (regardless of either on/off style or PWM).
    I don't know if Solid Sate relays play nice with ECM's.
    Sounds good, thanks.

    Yeah the Hella SSRs are nice and easy to use, but they require a ground signal for the PWM.

  9. #9
    Member
    Join Date
    Aug 2016
    Posts
    56

    Default

    X1 pin 44 will control a fuel pump in the way we're used to with the old ECM's, in that it will prime the pump for a couple of seconds prior to start.
    I believe setting F0585 to NO is what allows this to happen. As for F0612, I have this set to Leading Edge on my swap, and all appears to be ok.
    I'm not sure what is happening yet with the fan output, as I am using it to control a Jeep PWM fan controller, but it comes on steady startup.
    I hope some of this helps.

  10. #10
    Lifetime Member
    Join Date
    Jan 2014
    Posts
    320

    Default

    Quote Originally Posted by RC1 View Post
    X1 pin 44 will control a fuel pump in the way we're used to with the old ECM's, in that it will prime the pump for a couple of seconds prior to start.
    I believe setting F0585 to NO is what allows this to happen. As for F0612, I have this set to Leading Edge on my swap, and all appears to be ok.
    I'm not sure what is happening yet with the fan output, as I am using it to control a Jeep PWM fan controller, but it comes on steady startup.
    I hope some of this helps.
    you are awesome, thanks.

    yeah I may need to drop my o-scope on the cooling fan wire to learn about it.

    does the jeep controller expect a pos or neg PWM signal? got a PN for it?

Page 1 of 3 123 LastLast

Similar Threads

  1. 2014 gmc sierra E92
    By fahrautomotive in forum E39, E80, E82 & E92 SIDI ECM's
    Replies: 8
    Last Post: December 1st, 2020, 05:32 PM
  2. Replies: 5
    Last Post: June 20th, 2017, 07:06 AM
  3. Looking for CAGS delete for a 2014 C7 with the E92
    By DaveGuy in forum E39, E80, E82 & E92 SIDI ECM's
    Replies: 7
    Last Post: May 6th, 2014, 06:15 AM
  4. E92 2014 t43 OS not supported?
    By blazinblue in forum 6 speed/8 speed RWD/FWD Transmission Tuning (incl T43, T76, T87)
    Replies: 12
    Last Post: May 5th, 2014, 04:19 PM
  5. Cant open e92 2014 sierra tune file on v7
    By 400ss in forum E39, E80, E82 & E92 SIDI ECM's
    Replies: 8
    Last Post: April 10th, 2014, 11:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •