Results 1 to 8 of 8

Thread: Bricked ECU, Where to get E35a for 2006 LBZ

  1. #1
    Junior Member
    Join Date
    Mar 2020
    Posts
    26

    Default Bricked ECU, Where to get E35a for 2006 LBZ

    I'm in the US in Michigan and I just bricked an E35a ECU... I think. Tune said it took successfully but now truck won't start and I can't detect an ECU. Where is a good place to get a new or good used E35a ECU?

    Thanks!

  2. #2
    Member
    Join Date
    Oct 2010
    Posts
    79

    Default

    Those can be recovered using EFIlive. Do a little reading and you should be able to recover it. I've bricked a dozen loading tunes, and recovered all of them.

    Sent from my SM-G892A using Tapatalk

  3. #3
    Junior Member
    Join Date
    Mar 2020
    Posts
    26

    Default

    I've done some reading on the forum and and I tried what is explained in this link https://service.efilive.com/kb/artic...covery-process but I still have no communication with the ECU. Most of the things I've read are only do able if I can communicate with the ECU. A push in the right direction would be greatly appreciated as I've tuned a lot of gas engines but this is my first diesel tuning attempt and it is not going good so far. I already unplugged the batteries on the truck and that didn't work. I'm about to go check what the volts to the batteries are when the key is in the run position. I've read that 12v is the minimum voltage required to flash a tune. I will post later with an update.

  4. #4
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,109

    Default

    If the tune got all the way through to the end and it bricked then there is something maybe wrong with the tune, did you do all the mods yourself or did you purchase it off someone?


  5. #5
    Junior Member
    Join Date
    Mar 2020
    Posts
    26

    Default

    I did the mods myself, this ECU has been a pain since I first tried tuning it. I tried making a tow tune for it a few weeks back. I read the tune off the truck, made the modifications, and tried to cal flash the updated tune onto the truck. Cal flash failed part way but erased the tune on the ECU before failing. Truck was dead. I believe the tune that was on the truck was tuned by a different tuning software because it had check sum errors. I was able to get a stock tune off here and cal falshed that onto the ECU and it has ran since. I later found out that I was supposed to do a full flash.
    Last night I pulled the stock tune off again and copied the settings from the original tow tune. I believe this is where I screwed up. I never doubled checked all the updated settings before trying to cal flash. Either way, I cal flashed the updated tune, tune successful message popped up and so I figured we were good to go... I have not been able to register an ECU since.
    Do you think the ECU is recoverable?

  6. #6
    Lifetime Member Cougar281's Avatar
    Join Date
    Jan 2006
    Posts
    831

    Default

    Edit: never mind, re-read, for some reason I was thinking it was a cummins ECU. Loosing my mind lol.

    Sent from my HTC U11 using Tapatalk

  7. #7
    Junior Member
    Join Date
    Mar 2020
    Posts
    26

    Default

    Update!

    I was able to recover the ECU! What I did was a full flash of the stock tune that I got off the forum from GMC-2002-Dmax when I originally had issues. I tried doing a full flash before starting this thread but when I hit auto detect it would only detect the TCU. I decided to manually put in that it was an E35A and to my surprise it flashed without issues! I guess I should have just told it what ECU to tune to in the first place. Maybe that's common knowledge, I know I will defiantly keep that in the back of my mind for future issues.

    Thanks for the help/info! It was greatly appreciated!

  8. #8
    Forum tyhee Site Admin GMPX's Avatar
    Join Date
    Apr 2003
    Posts
    13,109

    Default

    There is no need to 'auto detect' the ECM type when flashing, that is dictated by the file you have loaded.


Similar Threads

  1. Replies: 3
    Last Post: August 26th, 2013, 10:26 AM
  2. Bad Flash (possible bricked ecu)
    By FreshDA9 in forum General
    Replies: 22
    Last Post: August 23rd, 2013, 07:46 AM
  3. Flashing OS into a brand new 2006 LBZ ECM with EFILive
    By AUSDMAX in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 6
    Last Post: March 29th, 2013, 06:21 AM
  4. 2006 LBZ TCM file needed
    By Xman in forum Duramax 06 LLY / 06+ LBZ & LMM
    Replies: 4
    Last Post: July 2nd, 2010, 08:06 AM
  5. cant read 2006 lbz allison tcm
    By mrrattle in forum FlashScan V2 BB Logging
    Replies: 14
    Last Post: February 27th, 2008, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •