Results 1 to 10 of 10

Thread: June 2021, V8.3.7 Public Release

  1. #1
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,308

    Default June 2021, V8.3.7 Public Release

    Public Release - Update 2
    The current public release (which is the same as this release) is available here.

    Attention:
    V7.5 no longer supports installation to Windows XP or Windows Vista. This change is due to SHA1 having been deprecated by digital certificate authorities. More info on SHA1
    V7.5 and V8 are now only supported on Windows 7, 8, 8.1 and 10.

    WARNING:
    Due to the new security/encryption option in this release, all tune files saved using V7.5.34 or V8.3.5 (or later) of the software or V2.07.169 or V3.00.059 (or later) of the firmware will no longer be compatible with older versions of the V7 or V8 software.
    If you distribute tune files to other users (i.e. your customers), the recipients must be:


    • using version V7.5.34 or V8.3.5 or a later version of the software.
    • using version V2.07.169 or V3.00.059 or a later version of the firmware.


    Full Release Notes:

    Version Numbers:
    After installing this beta release you should have the following software and firmware versions installed:

    • EFILive V7 software: V7.5.36 To view the installed version, select Help->About (in the V7 Scan or Tune software).
    • EFILive V8 software: V8.3.7 To view the installed version, select Help->About (in the V8 Scan and Tune software).
    • FlashScan/AutoCal V3 Firmware: V3.00.066 (Jun 17, 2021).
    • FlashScan/AutoCal V2 Firmware: V2.08.175 (Jun 17, 2021); Boot Block: V2.08.009 (Feb 27, 2021)


    Download here:

    Known Issues:
    Issue #1:
    PID validation in the V8 Scan Tool hangs and does not validate PIDs.
    Workaround: None.
    Will be fixed in the next update.

    Issue #2:
    Importing JTAG E86B files may result in a Boot Software segment checksum error.
    Workaround: None.
    Don't flash imported files with checksum errors. Don't use the EFILive software to correct checksum errors for the E86B imported files as that does not fix the underlying cause of the checksum error - it just masks the error(s) and causes additional problems.
    We are working on a solution to that problem.


    Regards,
    The EFILive Team
    Last edited by Blacky; June 21st, 2021 at 12:15 PM.
    Before asking for help, please read this.

  2. #2
    Junior Member
    Join Date
    May 2016
    Posts
    19

    Default

    Hello, if i update my V2 to the latest firmware and boot block will it still be compatible with the older versions of v8 and 7.5 that i use on my other older laptops? Thank you

  3. #3
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,308

    Default

    Quote Originally Posted by 26sutphen View Post
    Hello, if i update my V2 to the latest firmware and boot block will it still be compatible with the older versions of v8 and 7.5 that i use on my other older laptops? Thank you
    It depends on how old the other versions are.

    The current V7 software will work only with V2 firmware versions: 2.7.163 to 2.8.175
    The current V8 software will "work" with most V2 and V3 firmware versions.

    I say "work" because if the V8 software attempts to perform an action that is not supported in the firmware version that you are running then that operation will fail with errors like these:
    $0109 Received data message contained unknown command group.
    $010A Received data message contained unknown command action.

    The bigger issue you will face if using older versions is that the *.ctz tune file compatibility will be different. If you create/save a tune file using the latest V7 or V8 software then your older software versions will not be able to open that tune file.
    As explained in the warning in the first post.

    Regards
    Paul
    Before asking for help, please read this.

  4. #4
    Junior Member
    Join Date
    May 2016
    Posts
    19

    Default

    Ok i should have included that.
    Old faithful never online laptop is running 8.2.24 and 7.5.28, v2 has firmware 2.07.140 and boot block 2.07.008
    If i update the v2 to firmware 2.08.175 and boot block 2.08.009 will i still be able to use my old laptop with new v2 firmware and boot block to flash my older files?
    I realize i will have to instal the latest version on another laptop to be able to use these newer files, but im not wanting to give up the older 8.2 and 7.5 im used to just yet. Thank you for your reply

  5. #5
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,308

    Default

    Quote Originally Posted by 26sutphen View Post
    Ok i should have included that.
    Old faithful never online laptop is running 8.2.24 and 7.5.28, v2 has firmware 2.07.140 and boot block 2.07.008
    If i update the v2 to firmware 2.08.175 and boot block 2.08.009 will i still be able to use my old laptop with new v2 firmware and boot block to flash my older files?
    I realize i will have to instal the latest version on another laptop to be able to use these newer files, but im not wanting to give up the older 8.2 and 7.5 im used to just yet. Thank you for your reply
    The latest V2 firmware works with:
    V7.5.30 to V7.5.36
    and
    V8.2.24 to V8.3.8


    Regards
    Paul
    Before asking for help, please read this.

  6. #6
    Junior Member
    Join Date
    May 2016
    Posts
    19

    Default

    Thank you very much

  7. #7
    Senior Member
    Join Date
    Feb 2006
    Posts
    113

    Default

    Problem I have 98 camaro, logging is all messed up. some PID's not valid like MAF,IAC. Logging,numbers are all off. Issue's in both v7 and v8.

  8. #8
    EFILive Developer Site Admin Blacky's Avatar
    Join Date
    Mar 2003
    Posts
    9,308

    Default

    Quote Originally Posted by slowhawk View Post
    Problem I have 98 camaro, logging is all messed up. some PID's not valid like MAF,IAC. Logging,numbers are all off. Issue's in both v7 and v8.
    Can you please create a support ticket here: https://service.efilive.com/new-ticket
    Include a sample log file and the PID selection that you are attempting to log.
    And if possible a screen shot showing the messed up data log as it is displayed on your screen.

    Thanks
    Paul
    Before asking for help, please read this.

  9. #9
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,126

    Default

    Also, did you validate pids (while connected to car)...?

  10. #10
    New Member
    Join Date
    Aug 2021
    Posts
    1

    Default

    Quote Originally Posted by Blacky View Post
    It depends on how old the other versions are.

    The current V7 software will work only with V2 firmware versions: 2.7.163 to 2.8.175
    The current V8 software will "work" with most V2 and V3 firmware versions.

    I say "work" because if the V8 software attempts to perform an action that is not supported in the firmware version that you are running then that operation will fail with errors like these:
    $0109 Received data message contained unknown command group.
    $010A Received data message contained unknown command action.

    The bigger issue you will face if using older versions is that the *.ctz tune file compatibility will be different. If you create/save a tune file using the latest V7 or V8 software then your older software versions will not be able to open that tune file.
    As explained in the warning in the first post.

    Regards
    Paul
    Hey!
    Can you please tell me if it's worth updating your V2 to the new firmware at all?
    And is it possible to affect the compatibility of * .ctz somehow ?
    I'm not good at it, but I have to make a decision to work.
    I would be grateful for your advice!
    "There are limits to self-indulgence, none to self-restraint."

Similar Threads

  1. May 2021, V8.3.6 Public Release - Update 1
    By Blacky in forum Software Updates and Installation Help
    Replies: 8
    Last Post: May 27th, 2021, 06:10 PM
  2. Known issues with June 02, 2015 Public Release
    By Blacky in forum Software Updates and Installation Help
    Replies: 18
    Last Post: July 8th, 2015, 05:07 PM
  3. Public Release June 03, 2011
    By Blacky in forum Software Updates and Installation Help
    Replies: 71
    Last Post: July 9th, 2011, 07:59 AM
  4. Public Release Update June 24, 2011
    By Blacky in forum Software Updates and Installation Help
    Replies: 105
    Last Post: July 9th, 2011, 06:21 AM
  5. Public Release Update June 06, 2011
    By Blacky in forum Software Updates and Installation Help
    Replies: 18
    Last Post: June 20th, 2011, 07:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •