Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: LS1B 8.1/4l85 with failed hypertech tune assistance

  1. #1
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default LS1B 8.1/4l85 with failed hypertech tune assistance

    Background: I am in Nevada, USA (pacific time zone). I bought an 04 Avalanche 2500 with the 8.1 and the 4l85 trans. I *think* this is the LS1B ECM(?) The previous owner lifted it, slapped 35's on it and regeared to 4.56 front/rear. He used a Hypertech to adjust the shift points and account for the gear ratio/tire size.

    I have a flash scan v2 I bought years ago when I had a previous truck tuned, so I grabbed some data logs. Then I realized, the Hypertech probably pulled bunk data so it would be best to de-tune with the hypertech before getting good logs for EFILive tuning.

    I went to uninstall the hypertech tune and it failed to re-write the stock tune multiple times, giving code 8E and saying to call hypertech (they are closed weekends). The truck won't start now, and is parked on the street in front of my house. I don't really want to pay a tow truck to take it to the dealer if this is a simple procedure I can do with this device I have already paid for.

    I pulled out my old computer, updated the EFILive software, the Flash Scan Firmware, bought a new VIN license and tried to read the tune that is on the truck. The result shows there is an invalid checksum in speedometer segment 8. I don't know where that is, or how to fix it. I exported the speedometer data into a CSZ file(?) but it looks like gibberish in notepad and I wouldn't know how to save it anyways.

    Instead, I tried to modify some of the speedometer values that seemed waaaaay out of range (e.g. tire size = 11138.84"). I compared the data to some old tune info, and some files I found here, but the PCM wouldn't take my tune.

    I've searched and read, and I feel like I'm fairly close to getting this resolved, especially if I can get a good stock file and change the VIN to match mine, or if I can read what this segment value is and modify it to something that works. I've read that there might be more in-depth solutions like updating the OS to the newer version and copying over my engine data, but this is really the first time I've done anything other than move tunes around from email to the truck.

    Any assistance would be helpful, and I appreciate the time you took to read this post.

    (I will have to post a few more times before I can upload files, I think)

  2. #2
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    Click image for larger version. 

Name:	Speedo parameters.JPG 
Views:	26 
Size:	110.9 KB 
ID:	23886Click image for larger version. 

Name:	PCM Calibration bad speedo.JPG 
Views:	23 
Size:	58.4 KB 
ID:	23890
    Last edited by Phil_Miller_86; 3 Weeks Ago at 02:51 AM.

  3. #3
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    This is the only file I have from the PCM and it contains an error.

    LS1_0076 - 2004 Avalanche K2500 8.1 4L85E - Error in speedometer.ctz
    Last edited by Phil_Miller_86; 3 Weeks Ago at 05:29 PM.

  4. #4
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    Update: I called Hypertech customer support about my experience and the code E8 that popped up on the tool. Dude said 'that code means the device needs to be replaced. we don't stock them or service them anymore, so you would have to have the dealership reflash it and buy a new device'.

    My insurance covers the tow to the dealership and they are going to try to squeeze it in this week (there's a 3-4 week wait for service appointments).

    I'd much rather just flash a new OS on it and call it good. I could even order a new PCM and install it before their appointment time opens up.

  5. #5
    Member
    Join Date
    Dec 2016
    Posts
    80

    Default

    I have this in my archives, maybe it will help. I do NOT know the history of this file so adjust accordingly. 3GNGK26G84G291431 2004, 8.1l, 4l85E, 4X4.ctz

  6. #6
    Joe (Moderator) joecar's Avatar
    Join Date
    Apr 2003
    Posts
    28,164

    Default

    Subscribing...

  7. #7
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    Update:

    I towed the truck to the dealership, the tech says he tried to reflash it, but the tune wouldn't take. I don't know how their system works, or what tool or mode or method he used, but I overheard him say "a flash isn't going to fix it". The service advisor said the tech was deep into a corvette right now, but would try to get back to diagnosing mine after lunch.

    Looks like I still need to find (or configure) a stock tune file and load it myself in their parking lot so I can drive it home. Either that, or I order a new PCM from someone online? I'm supposed to be hauling a trailer for my move to washington this week, not sitting around hoping my truck gets fixed.

  8. #8
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    Quote Originally Posted by In-Tech View Post
    I have this in my archives, maybe it will help. I do NOT know the history of this file so adjust accordingly. 3GNGK26G84G291431 2004, 8.1l, 4l85E, 4X4.ctz
    I appreciate your assistance here with a tune file. I don't know enough about this process to tell if the values look reasonable or safe for my vehicle but at this point I'm willing to try just about anything. I'm sure the dealership is going to want buku bucks to install a new PCM, and that's if they can source one.

    I am currently trying to modify this file you sent to match my known information (I changed the VIN, the gear ratio, and the values in the speedometer settings to match my measured 33.5" tall tires). I noticed this file has a newer/higher number OS so I'm hoping that is a good thing and it will help me out.

    I imagine I'm going to try a full-flash, any tips for me to prevent totally bricking the module?

  9. #9
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    Update:

    I went to the dealership to try and flash this tune onto the truck. I plugged it in and turned the key, but got only a check engine light. nothing else, no needle movement or lights or anything.

    I asked the service advisor what they did to my truck, and they said they had problems reading the PCM and it wouldn't take a tune, so they 'removed the vin' from it and are waiting for GM to call back and advise them about connecting to it through some other method(?) which they say has about a 50/50 success rate. Sounds like incompetence or unwillingness to work on it to me but hey, what do I know.

    So I had what was probably a recoverable controller but they messed it up and now I need a new one. I ordered one from some place in florida that should be here early next week, so at least I should have resolution. i'll need a new vin license so I can fix the gear ratio and tire size and wasted $160 taking it to the dealer, but at least I'll be able to get it running.

  10. #10
    Junior Member
    Join Date
    Sep 2021
    Posts
    18

    Default

    I picked up the truck today, the battery was completely dead, so thanks for that dealership. I received shipping notification of my replacement PCM so it will be here in about 16 hours. I took the battery back to the auto parts store to be charged (hopefully replaced under warranty) and removed the PCM from the truck. Hopefully I can get my EFI live license replaced so I can tune this one after I save a stock file. haha

Page 1 of 2 12 LastLast

Similar Threads

  1. Need some assistance with a modified tune on my 05 LLY
    By 1FastBrick in forum Duramax LLY
    Replies: 3
    Last Post: August 2nd, 2017, 12:04 AM
  2. Failed Smog... tune?
    By ferocity02 in forum Gen III V8 Specific
    Replies: 10
    Last Post: March 27th, 2013, 12:03 PM
  3. Need hypertech/efi cant do
    By JST in forum E37, E38 & E67 PFI ECM's
    Replies: 9
    Last Post: August 1st, 2012, 01:28 AM
  4. Hypertech damage? What should I do?
    By jonnyk in forum Gen III V8 Specific
    Replies: 2
    Last Post: November 30th, 2009, 01:54 PM
  5. reading hypertech flash
    By warscout2 in forum General (Petrol, Gas, Ethanol)
    Replies: 7
    Last Post: February 16th, 2007, 08:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •