Results 1 to 7 of 7

Thread: E67 Discrete two fan wiring and settings

  1. #1
    Junior Member
    Join Date
    Nov 2008
    Posts
    34

    Default E67 Discrete two fan wiring and settings

    I know this has been up for discussion before but I got some strange behaviour that I want to sort out before closing the harness.

    Have a LSA with a 6L90E from a ZL1 Camaro 2013 that is going into a Impala 1959.
    Have done a stock harness cleanup and added external fusebox/relays.
    Engine starts fine and transmission is alive, on a pallet.

    I have now done the two speed fan wiring as on the stock harness as on the schematics down below and is trying to test the functionality.


    Testing in DVT
    This makes some confusing results?!?
    Cooling Fan Relay #1 OFF
    Cooling Fan Relay #2 OFF
    Nothing

    Cooling Fan Relay #1 ON
    Cooling Fan Relay #2 OFF
    Nothing

    Cooling Fan Relay #1 OFF
    Cooling Fan Relay #2 ON
    High speed fan ON

    Cooling Fan Relay #1 ON
    Cooling Fan Relay #2 ON
    Low speed fan ON
    High speed fan ON


    Now the E67
    Added the patch B9904 Cooling Fan Operation Range Patch.
    Setup G0901 as this (for testing purposes)
    76 0,000000
    78 25,999451
    81 39,999389
    84 50,999450
    87 64,999389
    90 91,000366
    92 91,000366
    95 91,000366
    98 91,000366
    101 91,000366

    Now I do the real world test, putting the ECT sensor in boiling water.
    Fans will not start?!?

    What am I missing, will not the fans start without the engine running first?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	fans.jpg 
Views:	15 
Size:	112.0 KB 
ID:	23970  

  2. #2
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,912

    Default

    You need to adjust settings in the Fan settings section that aren't available in EFILive. You will need to supplement with another tuning suite or have someone patch your tune file for you.
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, tuned, turbo mods, etc.
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  3. #3
    Junior Member
    Join Date
    Nov 2008
    Posts
    34

    Default

    Quote Originally Posted by ScarabEpic22 View Post
    You need to adjust settings in the Fan settings section that aren't available in EFILive. You will need to supplement with another tuning suite or have someone patch your tune file for you.
    Thanks for your input!

    I have tried to mimic the exact same setup, tune (just added theB9904 patch) and wiring as the donor car (Camaro ZL1 2013), the car has two fans.
    How come is that I need a patch, with a cax i guess? Now I got very confused :(
    Do you have any more information to share?
    Last edited by Hocky; November 30th, 2021 at 06:48 PM.

  4. #4
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,912

    Default

    The difference is the OS' are different. The ZL1 may be setup this way from GM, so it works with discrete fans.

    Are you trying to do a 2 or 3 relay fan setup?
    Was the donor ECM + OS using the same fan setup? If not, you need to access parameters and tables outside of what EFILive has mapped. These are available in competitors software or via a .cax if you find someone to define them.
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, tuned, turbo mods, etc.
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  5. #5
    Junior Member
    Join Date
    Nov 2008
    Posts
    34

    Default

    Yes the stock Camaro ZL1 seems to have a two fan setup (and I got the fans to) as on the schematics (from alldata) I posted earlier.
    I have replicated the schematics but with external relays.

    It do click the relays when I do the tests in DVT, a little confusing results but still makes them click.

    Its just the tune that dont pull them when I cook the sensor.
    Maybe its just that the engine needs to be started first (to activate the function) and then reaching the temp?

  6. #6
    Lifetime Member
    Join Date
    Mar 2006
    Posts
    4,912

    Default

    As I mentioned initially, you cannot make this happen with EFILive alone and will need to use other software or find someone to define the necessary parameters for you in a .cax file for your OS.
    ~Erik~
    2013 Sonic RS Manual - 1.4L I4T E78, tuned, turbo mods, etc.
    2008 TrailBlazer SS 3SS AWD Summit White - LS2 E67/T42, bolt ons, suspension, etc.
    2002 Chevy TrailBlazer LT 4X4 Summit White - 4.2L I6 P10, lifted, wheels, etc.

  7. #7
    Junior Member
    Join Date
    Nov 2008
    Posts
    34

    Default

    Quote Originally Posted by ScarabEpic22 View Post
    As I mentioned initially, you cannot make this happen with EFILive alone and will need to use other software or find someone to define the necessary parameters for you in a .cax file for your OS.
    Sorry for beeing hard headed but I am really interested in why this setup will not work when I have done the exact same wiring as on the stock Camaro ZL1?

    On a prior build I had a Corvette tune E38 combined with discrete fans and then I got help from @LastCall with a cax file to get it working.
    Now I am on a E67 so I cant compare the bin files and figure it out by myself.

    EFILive should really get this thing sorted out with the fans setups. I cant imagine how many hours users have put into this problem!

Similar Threads

  1. Running Discrete Fan with Vette Tune
    By SkinnyPedal in forum E37, E38 & E67 PFI ECM's
    Replies: 59
    Last Post: July 25th, 2018, 06:44 AM
  2. E67 Discrete Fan Control Issues....any help is appreciated
    By quik95lt1 in forum E37, E38 & E67 PFI ECM's
    Replies: 5
    Last Post: March 6th, 2014, 12:37 PM
  3. E67 After Run Fan Settings?
    By MattS in forum E37, E38 & E67 PFI ECM's
    Replies: 2
    Last Post: September 27th, 2010, 02:22 AM
  4. e fan wiring and control
    By kostelacd69 in forum Gen III V8 Specific
    Replies: 9
    Last Post: July 22nd, 2009, 08:36 AM
  5. Fan settings E38
    By eboggs_jkvl in forum E37, E38 & E67 PFI ECM's
    Replies: 10
    Last Post: August 14th, 2008, 10:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •